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Introduction

Office suites are one of the most popular types of software, and most computer users
will, at some point, find themselves staring at the user interface of a word processor,
spreadsheet, or presentation package. Traditionally, office suites have been quite
expensive packages, but thanks to the generosity of Sun Microsystems and a massive
community of developers, writers, and testers, there is an alternative to shelling out
hundreds of dollars or taking the risks (computer viruses, law suits) associated with
downloading and running pirated editions of commercial software. OpenOffice.org
(which is both product name and web address) is a piece of software that offers access
to the most common features used in office environments, and some of the more
uncommon ones too. In addition to being a great collection of applications, one of the
revolutionary things about this “business class” software is that it costs less than your
daily paper. In fact, anyone—individuals, businesses, charities, governments—can down-
load and install OpenOffice.org for absolutely nothing. And this isn’t trial software; it’s
not restricted in any way. Who said there’s no such thing as a free lunch?

A Tiny Bit of History

The suite started out as a proprietary product called StarOffice developed by StarDivision
in Germany, but this changed when it was purchased by Sun Microsystems in 1999. Sun
released the software under a permissive license in 2000 in the hope of gathering a com-
munity of developers around the application that would then build and improve upon

it, allowing it to emulate the success of other open source projects such as the Mozilla
browser suite, which spawned Firefox. The intention of the project is to compete with
Microsoft Office, and it therefore borrows much of the structure of Microsoft’s flagship
suite and also supports its file formats. The latest version of OpenOffice.org can open files
created using Microsoft Office 2007.

OpenOffice.org’s native formats—collectively called the Open Document Format
(ODF)—have been adopted as an international standard and are in use across a growing
range of applications.

The latest version of OpenOffice.org has been released for Windows, Linux, Solaris,
and, for the first time, as a native OS X application. Previously, it required users to run
within an X terminal session. So with this version, it’s now possible to deploy the suite
across an organization regardless of the operating system choices. The software itself is

Xix
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INTRODUCTION

divided into five main sections covering word processing, spreadsheets, presentations,
database building, and illustration. These are complemented by a selection of smaller
applications and a growing range of third-party plug-ins, which extend the available fea-
tures considerably.

The StarOffice name lives on in Sun’s “official” version of the OpenOffice.org suite.

The Applications

Writer is, for most users, the core of the application suite. It can be used for a wide range
of text-based tasks from newsletter design and thesis writing to posters, flyers, and book
production. Writer is also a very usable web-editing package that is ideal for creating
templates for e-mail newsletters. Its equivalent in the Microsoft Office suite is Word, and
Writer can open and save documents in both Microsoft’s .doc format and .docx format
from the latest version of Word. In addition to printed output, Writer also outputs stan-
dard PDFs, Rich Text (RTF) documents, HTML, and many other current and historical
formats. The first three chapters of this book deal with documents in Writer.

Calcis the spreadsheet element of the software, which will be familiar to anyone
who has used Microsoft Excel. Calc can open and save Microsoft Excel’s .x1s file format
and includes support for the vast majority of the functions available in that package. In
addition to being useful in large-scale accounting work, Calc includes options useful in
managing household budgets, performing small business tasks, and producing table data
for the Web. Chapter 4 works through the tools and options in Calc.



INTRODUCTION

Impressis a presentation package that ships with all the tools you might find in
Microsoft PowerPoint. As with the other parts of the suite, Impress opens and saves the
ubiquitous Microsoft Office formats, in this case .ppt, and compares well with the compe-
tition. Impress features a large number of usable animations, effects, and transitions, and
can use the many PowerPoint templates available on the Web, making the job of building
engaging presentations a breeze. Impress can also output presentations in various for-
mats suitable for distribution on the Internet or through more traditional channels, and it
dynamically integrates data from other parts of the suite. Chapter 5 explores Impress.

Draw often seems like the black sheep of the OpenOffice.org family, but its extensive
graphical prowess provides other parts of the suite—especially Writer and Impress—with
some useful design tools. The package’s collection of standard shapes, lines, and fills
makes it ideal for building flow chart diagrams and editing clip art for adding to word-
processing documents or presentations. Chapter 6 runs through a basic Draw project.

Baseis the newest element of the system and allows users to build, edit, and query
small and large databases. These databases can be anything from a small address book
of club members—perfect for creating mail merges in Writer—to more extensive asset-
management applications complete with forms, multiple views, and role-based queries.
Despite its power and complexity, you can build and manage small-scale projects in Base
without advanced technical knowledge. Chapter 7 features a simple Base project capable
of being adapted to much broader applications.

Although these applications are strong individually, the common OpenOffice.org
core and the ability to take elements from one document and insert, paste, and migrate
them into another makes this a powerful package.

About This Book

This book is divided into project-based tutorials that have been designed to expose as
many of OpenOffice.org’s individual tools and features as possible. Although the projects
may seem quite specific, the processes and tools discussed are transferable to many other
office tasks. The projects themselves are based on real-world scenarios and will guide you
from the basic options available in the suite to more ambitious uses. Additional tips and
guides are included outside of the main text to help take your experience of the software
even further beyond the tutorials.

This is not a book for elite hackers, rather it’s aimed at those approaching OpenOffice.
org for the first time with the intention of getting the most out of the suite in the short-
est time. You may have experienced other office suites, in which case, you'll find many
tools in expected locations, but it’s not a prerequisite. In fact, many of the skills, tools,
and processes we’ll work through will be useful way beyond OpenOffice.org, and
after you've mastered this, you should be able to sit down at any basic application on
Windows, Linux, or OS X and feel confident that, with just a little exploration, the appli-
cation will behave as you want.

XXi
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INTRODUCTION

The first part of the book is perfect for those who’ve been given a horribly tight dead-
line to put together a report, chart, or presentation or to format a long essay because it
covers the most commonly used parts of the OpenOffice.org package. It begins with basic
word-processing document creation and then moves on to cover the tools available that
will allow you to create smart, consistent documents, spreadsheets, presentations, data-
bases, and illustrations with the least effort.

After we've covered the main applications themselves, Part 2 looks at various ways
of dropping content from one application into another, looks at document and author
management, runs through the methods of output, and takes a quick tour through some
of the essential extensions for the suite.

The screenshots used in this book were taken on a Linux PC (running Ubuntu Hardy
Heron 8.04), but the key combinations, menu structures, and options are applicable to
both Windows and Mac OS X, although on the latter, the Ctrl key should be transposed to
the Apple key directly to the left of the spacebar.

Conventions Used in This Book

Graphical user interfaces can be difficult to represent in written form, but the method
used in this book is as follows:

e Menu entries are shown with a » between each element. You should follow from
left to right; for example, File » Save As launches the Save Document dialog box.
Many menu entries contain an ellipsis, and for the purposes of visual clarity in the
text, these have been removed from the written commands.

e Many options in the applications have associated key combinations. These are
joined together with a + sign. For example, Ctrl+S saves a document, whereas
Ctrl+Shift+S launches the Save Document dialog box.

* And finally, although OpenOffice.org is a perfectly serviceable name for an appli-
cation, we’'ll often shorten it to O0.0, and individual applications within the suite
will be referred to by their shortened names—Writer, Calc, and Impress.

Anything else will be explained in the text because, well, we need to crack on...
there’s so much to do!



PART

The Applications

Let’s crack on then. Part 1 runs through the five core applications of the suite with a bit
of a bias in the first three chapters toward Writer, the word processor. These three chap-
ters each start with a very basic document and then use the tools and options available
in Writer to create something much more sophisticated. In the course of these jobs, you’ll
explore many of the ways in which Writer can be used to make document creation and
editing not only more versatile but also easier through the use of automation, saved styles,
and document variables. Writer gets the lion’s share of space in Part 1 because, as well
as being the most used part of the suite, the dissection of the interface and customization
options in this application are also relevant to the rest of the suite. Along with being a jour-
ney through Writer, these chapters also explore OpenOffice.org itself.

After we leave Writer behind, you should be ready to explore the rest of the suite without
too much assistance on customization and optimization. This is the perfect time to intro-
duce Calc, the suite’s spreadsheet. Calc is capable of everything from home budgets to
corporate accounts; we’ll be heading for something in between—an adaptable accounts
system for a small business.

Impress is the presentation package that is capable of some very smart results. We’ll be
going through the process of building a basic presentation, turning that into a template,
and outputting documents in a variety of formats.



We’ll then move on to Impress’s twin, the illustration package Draw, before finishing up
with a small, uncomplicated project built with Base, the newest member of the 00.0 fam-
ily. Databases are often regarded as hideously complicated things with no relevance to
everyday life unless you’re a big business or club. In fact, 00.0’s Base application can be
used to build something as small as an address book or a home inventory.

After completing the tutorials in this book, you will have the confidence to create a selec-
tion of different document types for a variety of uses and also have the skills necessary to
apply those procedures and ideas on your own projects. You will also be able look beyond
the basics and explore. Remember, the Undo button is always just two clicks away.



CHAPTER 1

Writer: Basic Documents

We’ll begin in the obvious place with a run through the core applications in the Open-
Office.org (00.0) suite beginning with Writer, and then moving on through Calc, Impress,
Draw, and Base.

If you have two hours to prepare for a seminar presentation, feel free to leap into
the Impress section straight away. However, it might be a good idea to read through the
following annotations that explain the user interface conventions used in OO.o. Although
the screenshot is from Writer, most of the interface elements are consistent across appli-
cations (see Figure 1-1).

Rulers Work Area Menu Bar Toolbar  Formatting Toolbar

A

Status Bar Optional Palettes

Figure 1-1. The advantage of using an office suite is that the user interface is consistent
across the different elements.
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Menu Bar

The menu bar (see Figure 1-2) is standard across most desktop applications. Almost all
of Writer’s tools are accessible via these menus, and most of the options available have
keyboard combinations assigned to them. For example, to quickly save a document, you
could choose File » Save or simply press Ctrl+S.

Figure 1-2. The menu bar

The menu system in OO.o is configurable via Tools » Customize, so you can redesign
the whole application to look like your favorite package. The menus are described here:

e File: Deals with file operations such as opening, saving, and closing documents,
but also contains the document properties section and print options.

 Edit. Allows you to cut, copy, and paste as well as find and replace particular words
or phrases.

* View: Provides options for setting the view in the main window and also opening
and closing Writer’s various toolbars.

* [nsert. Allows you to add things to the page, including frames, images, headers,
footers, and breaks in the text.

e Format: Allows you to make changes to everything from pages and paragraphs to
individual characters.

e Table: Provides options for adding tables to a document. Tables can be used to
present data like a spreadsheet and also to position elements when it comes to
building web pages.

* Tools: Enables you to configure OpenOffice, configure the user interface of Writer
(or another of the applications), perform a word count, and set up options for the
spell checker.

* Window: Allows you to manage multiple documents or multiple views of the same
document.

* Help: Provides access to the OpenOffice.org documentation.
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Toolbar

The toolbar contains a range of commonly used shortcuts for opening, saving, and adding
various elements to your documents. The toolbar is divided into logical regions, which,
from left to right, are file operations, output, spelling, clipboard features, formatting,
inserting, and searching (see Figure 1-3). As with the menus, these are completely cus-
tomizable from Tools » Customize.

Figure 1-3. The toolbar

Although the default view of Writer displays two toolbars, many more toolbars are
available that contain tools for performing specific tasks such as designing forms, add-
ing rich media to web pages, or offering more control over elements such as line spacing
and bullets or numbers. These can all be accessed using the View » Toolbars menu entry.
Once added to a page, they can be dragged from the edge of the page and either left as
a floating toolbar (which means they will have a standard Close icon in the top right of
the window) or docked to another edge of the window. Docking a toolbar to the top or
bottom of the screen renders it as horizontal, whereas docking to the left or right edge
positions the icons vertically.

Formatting Toolbar

The Formatting toolbar is a specialized toolbar used to make changes at either the char-
acter or paragraph level. This element is actually context sensitive, so in most cases,

a version similar to this will be displayed. However, if you were editing a picture, con-
figuring a frame, or drawing a shape, the Formatting toolbar would display a toolset
relevant for that task.

The Formatting toolbar in Figure 1-4 is the standard text model, which has options
for changing the font, font size, style, justification, indents, and color options. The disclo-
sure arrow to the far right of the toolbar offers quick access to customization tools for that
particular toolbar.

Figure 1-4. Context-sensitive Formatting toolbar
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Rulers

Rulers provide a visual guide to your page (see Figure 1-5). By default, the rulers are set to
increment in centimeters; however, you can change this to inches, millimeters, and even
points and picas through the application preferences (see Figure 1-6).

Figure 1-5. Rulers

Figure 1-6. Set the measurements to the value you're most comfortable with.

To access these preferences, choose Tools » Options, click the OpenOffice.org Writer
disclosure arrow on the left edge of the window, and choose General. Alternative mea-
surements are available in the drop-down list. You should notice the Tab stop value (i.e.,
the distance the Tab key will move your cursor across the page) updates automatically to
reflect the measurement change. Select the appropriate value, and click OK.
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At the left edge of the horizontal ruler is a pair of marker icons that can be used to
visually define the indentation used in the document. The lighter colored space shows
the usable area of the page. The top icon can move independently of the bottom one,
which sets the first line indent. The bottom icon defines the standard paragraph indent (it
has a companion on the right side of the ruler), and it can be simply dragged and dropped
to the right place. You can create a hanging indent by dragging the top icon to the left of
the bottom icon (see Figure 1-7).

This method of creating paragraph indents is quick but imprecise. More refined con-
trol is available via the options available by choosing Format » Paragraph.

Figure 1-7. Use the ruler widgets to make a hanging indent.

Work Area

The work area is where your document is displayed (see Figure 1-8). Writer features
anumber of display modes, which are accessed through the View menu. The standard
view is a so-called WYSIWYG (what you see is what you get) view, which means the

text and images onscreen attempt to represent the look and feel of the final document,
including headers, footers, and page numbers. A more accurate rendition can be seen by
choosing File » Page Preview.
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Figure 1-8. The main work area

The two other main views are Web View and Full Screen. The former displays docu-
ments as they would appear on the Internet, whereas the latter is excellent for writers
who prefer not to have the distractions of toolbars, menus, and palettes onscreen with
their words. The work area can be zoomed to various levels by choosing View » Zoom.
Options available here include Fit Width and Height (i.e., full page), Width, Optimal, or
Variable. The last option allows you to set the zoom level as a percentage. This edition of
Writer also allows you to see double-page spreads in the full-page view.

In some parts of the application suite, notably in Impress and Draw, the main For-
matting toolbar is augmented by a set of drawing tools arranged across the bottom of
the screen.

Optional Palette

During normal use, most of Writer’s facilities are available through either menus or
toolbars; however, some options launch a new palette with a further set of tools (see
Figure 1-9). The advantage of these palettes is that they can be freely positioned on the
screen and, when necessary, removed completely with the click of a mouse. Examples
of optional palettes include text styles, the document Navigator, and the bibliographic
database.
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Figure 1-9. There are a few optional palettes that you may leave open as you work.

These palettes behave just like ordinary application windows, which can be minimized,
maximized, and removed. However, they always stay on top of the main Writer window. The
Navigator may become more useful as you investigate the powerful document creation
options in O0.o because it provides ready access to the deep structure of a document. For
example, when working on a long document with chapters, sections, and subsections, the
Navigator can display these elements in a hierarchy, so that selecting the element takes you
directly to that section for editing. Navigator also presents a list of (labeled) images, making
it easy to select a picture even if it's obscured by other page elements.

Status Bar

The status bar at the bottom of the window (see Figure 1-10) is mainly informational,
although it does have a few user editable options. Most useful are the mode switch in the
center of the bar that changes editing from inserting (i.e., preserving the existing text) and
overwriting; the selection options; the page mode; and the zoom slider, which allows you
to zoom in and out of the document without having to visit the menu. Note the two small
notches on the slider; these correspond to the Whole Page view and the Page Width view.

9
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Figure 1-10. The status bar

In the very center of this bar is the currently selected dictionary. This should conform
to the default language of your computer system, but it can be changed by clicking the
language name and selecting a new language. If your language isn’t listed, select More to
access more language options.

Creating Your First Document

The word processor is one of the core applications for almost every type of computer
user. Whether you're writing a novel, report, dissertation, or just a shopping list, a decent
word processor, such as Writer, is a good thing to have around.

At its most basic, you can launch Writer, click into the work area, and begin typing.
Words will appear on the screen within a representation of your page, and these can be
highlighted (click and drag across your selection with the mouse) and then adjusted in
a variety of ways using the Formatting toolbar. The options on the Formatting toolbar (from
left to write) allow you to apply a style to the text (we’ll cover these later); change the font
and size; make the text appear bold, italic, or underlined; change the alignment; create a list;
change the indentation of the paragraph; or adjust the color or highlighting of the text.

Your first project is based on producing a letterhead for a small business or solo
trader. You'll add a small graphical flourish, the essential address details, a space for a ref-
erence number, and a footer. After the design is satisfactory, you'll save the whole thing
as a template for use the next time you need to write a letter.

Create the Page

To begin, launch the application by either selecting the Start Center or Writer from the
Start menu. The former launches a new window containing icons for each of the indi-
vidual applications—choose Writer to get started—whereas the latter takes you straight to
the application itself. Either way, a new document is displayed onscreen using a default
page size and margins setup.

READY FOR LAUNCH

The first time you launch 00.0, you are prompted for your name (this can be used to automatically add
details to documents), and given the option of setting automatic application updates and registering the
software with the 00.0 project. Although | recommend using both of these options, neither is mandatory.
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The first task is to set up the most fundamental elements of your document, the page
size and margins. To do this, choose Format » Page, and select the Page tab. A number
of predefined page sizes (A4, Letter, etc.) are available via the Format drop-down list, and
you can also define a new page size using the Height and Width options (see Figure 1-11).
Page sizes that are higher than they are wide are Portrait (and will thus be defined as
such), and pages that are wider than they are high are Landscape. You can switch these
around using the two buttons below the page dimensions. For this document, choose A4.

Figure 1-11. The Page Style window is used to define the dimensions of the document.

At the bottom left are the margin values for the page, which can be altered either by
clicking on the increase/decrease arrows or by simply typing new numbers in the spaces.
You can also use the Tab key to move from one value to another, which automatically
highlights the next number ready for editing. For this document, use 2.54cm all round, as
this equates to about an inch.

Next move onto the Layout settings, where you can set up how the pages will be
displayed, that is, as either a series of left or right pages, right and left (as in a book or
magazine), or mirrored. The two first options are good for single-sided short documents
or individual pages; with Right and Left, you can set master objects such as page headers

1
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and footers independently for left and right pages. Finally, the Mirror option allows you to
design on one side and have those changes mirrored on the opposite page. For example,
a page number that appears on the left edge of the left page appears on the right edge of
the right page. Because this is a simple letter, choose Only Right from the list.

The Format option defines how automatic page numbers will be displayed when
added to a document. The choices are pretty straightforward.

The final option of interest in this dialog box is the Register-true check box. This is
a typographical tool that attempts to line up the text on both sides of a page so the reader
doesn’t see the shadow of the back side when reading the front side. When you select
Register-true, the text style chosen in the drop-down list will be anchored to a grid on the
page regardless of its size. This can be problematic on simple documents, so ignore that
for now.

Many other options are available in the Page Style dialog box, which you'll learn
about in Chapter 3.

A Word About Templates

Later in this chapter, you'll learn how to create a template based on the style of this par-
ticular letter. But it’s worth noting that OO.o ships with a few templates, albeit templates
designed for presentations. These are accessed by choosing File » New » Templates

and Documents. Existing templates are available under the various headings, and
custom-made templates, including the one you’ll make later, will eventually be accessible
in the MyTemplates folder.

Fortunately, the 0O0.0 community comes to the rescue here. From within the New »
Templates and Documents dialog box, select the Get more templates online link (see
Figure 1-12) to open a web browser on a web site that contains hundreds of downloadable
templates covering everything from text documents and spreadsheets to presentations and
labels. I've selected the Professional Templates Pack Il, (available in English or German)
and downloaded it to a folder on the hard disk.

Close down the browser, and go back to OO.o. Close the Templates selector, choose
Tools » Extension Manager from the menu bar, and select Add. This launches the sys-
tem’s file browser, and you can navigate and select the recently downloaded file that has
the extension .oxt. Click the Open button, read and accept the license agreement, and
then wait for just a few seconds as the extensions are installed.

Finally, close the Extension Manager, and choose File » New » Templates and
Documents to see the collection of new available templates that are all housed under
sensible headings.
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Figure 1-12. The Web is a good source of new templates.

Add and Format the Main Text

Now that you have a suitable page set up for a letter, you can add some text (see

Figure 1-13). Add the name, recipient address, your address, date, salutation, reference,
text, signoff, and your name using the default font and hard returns (i.e. press the Enter
key) after each line.

You can format sections of this letter by highlighting the text you want to effect and
then choosing the appropriate options. To begin with, adjust the size and position of the
first element to make it look more like a letterhead by highlighting that and choosing 24
from the Font Size drop-down list (third from the left on the Formatting toolbar). You
can also draw more attention to this particular element by making it bold. With the text
highlighted, click the B icon on the Formatting toolbar or press Ctrl+B. Finally, select the
Centered icon from the Formatting toolbar (or press Ctrl+E) to center the new heading.

13
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Figure 1-13. If you launch the application and begin typing a letter, you'll end up with something
like this.

Next you need to reposition your address so it’s flush with the right edge of the page
by highlighting the whole address and then clicking the Align Right button or pressing
Ctrl+R.

Note You can highlight text using just the keyboard. You can move around the document with the Up,
Down, Left, and Right cursor keys, and if you hold down Shift, these movements will select the text. For exam-
ple, Shift+Right Cursor Key selects the letter to the right of the cursor. However, pressing Ctrl+Shift+Right
Cursor Key, you can select the whole word to the right of the cursor. Putting a cursor at the far left of a para-
graph and pressing Shift+Down Cursor Key selects the whole line.

Although you can leave the address set right, it might look better set as a single line
below the centered letterhead. Highlight the address, and choose Edit » Cut (or press
Ctrl+X) to cut the text to the application’s clipboard. Now click below the letterhead text,
and choose Edit » Paste (or Ctrl+V) to paste the text back in. Obviously, it will be written
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across a lot of lines, so position the cursor on the left of each line, press Backspace, add
a comma between each element, and then click the Centered icon to center the text.
Next, make the Reference section bold, and you're ready to move on to the main text.

Introducing Paragraphs

Most of what you've done so far has worked with small amounts of text, but you can also
effect large changes with just a few clicks. One of the methods often used to mark out
paragraphs is to indent the first line of each paragraph. In Writer, this can be accom-
plished through the Paragraph dialog box, which is available by choosing Format »
Paragraph (see Figure 1-14).

Figure 1-14. We'll be revisiting the Paragraph dialog box later, but for now we're just interested in
the Indents & Spacing section.

There are two levels of formatting in Writer: character level and paragraph level.
When working on the character level, for example, selecting a font or making some
text bold, then every part of the text that is to be changed needs to be selected. When
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working on the paragraph level, as you are here, it’s enough to just click anywhere
inside the paragraph to be changed. If you're formatting multiple paragraphs, the selec-
tion (click and drag with the mouse) needs to touch each paragraph to be changed. You
don’t have to worry about selecting every single character.

Although the Paragraph dialog box contains a lot of options under various tabs, we’re
sticking with Indents & Spacing for the moment.

The top section deals with indents, which are the distances between the edge of our
work area and the text itself. The Before text option defines the gap between the left edge
and the text, whereas the After text option deals with the right. Earlier you saw how you
can alter these values visually using the widgets on the ruler, but this method offers far
more control.

The Spacing section allows you to define the gap that appears before or after each
paragraph. Usually you'll only use one of these options, but there are exceptions such
as when adding subheadings to a piece of text. For this letter, I've set a small gap Below
paragraph to create a visual break between each section of text. In most cases, a more
elegant solution to identifying the beginning of a paragraph is to have a first line indent
(discussed next), but on documents where the text covers a large horizontal area, a small
gap can improve readability.

The third option in this dialog box, and the one you’re going to actually change, is
the First line indent. We can increase the value by using the up arrow next to the box, or
by typing a value in the box. Enter 1.50cm. The Automatic check box just below the First
line section allows Writer to define the “perfect” first line indent value based on your font
style and size. It overrides any value defined in the First line box.

The final two options, which you’ll use later, are Line spacing and Register-true.

The former can be used to adjust the space between lines of text in various ways, from
the blunt instrument approach of single- or double-line spacing (typically, a letter has
single-line spacing, whereas an essay or a manuscript has double-line spacing to accom-
modate notes) to more refined options based on the proportions of the text or a proper
DTP-like leading setting. The latter is a paragraph-specific version of the tool we looked
at earlier in the Page Style dialog box and can be used to override the global setting.

To set this—it’s not particularly useful for a single-sided document—simply select the
Register-true check box.

After the indent is set, click the OK button to go back to the document and see the
effect of the change.

Personalizing the Interface

As you advance through Writer, you'll be revisiting the Paragraph dialog box quite often.
You can save some time by adding a new icon to the Formatting toolbar to launch the
dialog box and also giving it a keyboard shortcut.
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Usually there are levels of keyboard shortcuts in use on most computer systems.
First, there are systemwide shortcuts that work across many applications. These include
things like Ctrl+S for saving, Ctrl+C for copying, and Ctrl+P for pasting. The second-level
shortcuts are suite-specific; Ctrl+B makes selected text bold in all of the OO.o0 applica-
tions (and in many other office suites), but launches, for example, a text options box in
Adobe’s InDesign. The third level is application specific, such as using Ctrl+1 to apply
a particular text style to some selected text.

Although you can assign any combination of keys to almost any task in OO.o, it’s best
to steer clear of the most common combinations when defining or redefining shortcuts
using the following method.

To do the former, choose Tools » Customize, and select the Toolbars tab (see
Figure 1-15). Under the OpenOffice.org Toolbars section, choose Formatting from the
drop-down list, and scroll down the long list to find Paragraph. Click Paragraph, and
anew icon will appear at the far right of the Formatting toolbar. You can change its posi-
tion by clicking the up arrow next to the list; the higher it appears in the list, the farther
left it will be on the toolbar.

Figure 1-15. The Paragraph button has been added to the Formatting toolbar next to the
styles drop-down list, making it much quicker to access.

17
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The keyboard shortcut is again added by choosing Tools » Customize, but this time,
you choose the Keyboard tab. Although hundreds of options are available here, the pro-
cess is actually quite simple, as you can see in Figure 1-16.

Figure 1-16. Commands can be bound to any keyboard shortcut, making it possible to repli-
cate the workflow of your favorite applications.

Start by choosing a vacant key combination to contain the command from the Short-
cut keys section. Ctrl+6 is free, so you can use that. It might seem sensible to choose
something like Ctrl+P for the paragraph settings, but that is a standard keyboard shortcut
for printing, so it’s better to opt for something that doesn’t conflict. With the shortcut
defined, you can now add the command using the three windows at the bottom of the dia-
log box, which is just an alternative way of looking at the menu structure of the application.

In the Category pane, select Format to repopulate the Function pane in the center.
Scroll through the list until you find Paragraph, and click it.

Click the Modify button on the top right of the dialog box, and the key combination
will be bound to the command. Note that commands can be bound to any number of key
combinations, but each shortcut can only have one command.

You can also edit a shortcut; for example, if you wanted to bind Ctrl+P to the Para-
graph options, you find the shortcut in the list, reconfigure the Functions at the bottom
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of the dialog box, and click Modify. More importantly, if you're working with OO.o across
anumber of computers, you can save reconfigured shortcuts by using the Save button,
moving the file to the second machine, and importing them with the Load button, which
means there’s no need to duplicate a lot of effort across machines. You can also restore
the default combinations using the Reset button.

Any changes you make are written to the system only when you click the OK button,
so if you mess things up, just select Cancel to revert to the pre-edited state.

Now the all-important paragraph options are just a button or shortcut away; but while
you're editing the user interface, think about the other tools that might be useful on one
of the toolbars or that might need to be moved. The entire interface can be edited through
the Customize option. Moreover, if you only need regular access to a particular button for
a short time, you can hide previously added buttons from a toolbar (and, obviously return
them) by clicking the down arrow at the far right of any toolbar, selecting Visible buttons,
and then deselecting the appropriate option. This is different from removing a button
using Tools » Customize because the button is not completely removed; you can add it
again by going back to the Visible buttons and reselecting the tool.

COMMON KEYBOARD SHORTCUTS

e (Cirl+B: Bold

e Ctrl+l: Italic

e Ctrl+U: Underline

e Cirl+Shift+P: Superscript
e (Cirl+Shift+B: Subscript
e Cirl+C: Copy selection
e (Cirl+X: Cut selection

e Ctrl+V: Paste selection

o Ctrl+A: Select all the text
e Ctrl+R: Align text right

e Cirl+L: Align text left

e Ctrl+E: Center text

e (Ctrl+P: Print

Refer to the appendix for more keyboard shortcuts.
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A Word About Toolbars

The primary use for a word processor is creating largely textual documents, so the devel-
opers of any piece of word-processing software have, as their primary goal, the desire to
make creating and editing text easy. This means ensuring that the most commonly used
tools are always available.

However, many users need more extensive tools as their documents become more
sophisticated, and Writer can accommodate this growth with the addition of no fewer
than 20 other toolbars.

Most of the toolbars are set up to cover very specialized work such as adding formu-
lae, building web forms, and adding hyperlinks, but others, such as the Drawing Tools
and Bullets and Numbering, can provide quicker access to particular tools than using
menus and dialog boxes. All toolbars can be enabled or disabled by choosing View »
Toolbars. They will either appear as docked toolbars—that is, they will be appended onto
an existing toolbar—or they will be floating free (see Figure 1-17). You can undock a tool-
bar by clicking on the dotted vertical line at the left of the toolbar (this is also true for the
two default toolbars) and dragging out to the page. The toolbar then becomes a regular
window that can be placed anywhere on the screen. Redocking involves dragging a free-
floating toolbar back into the space at the top of the window.

Figure 1-17. Toolbars can be either free-floating or docked to any edge of the screen.
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If the top of the user interface is getting cluttered, you can drag any toolbar to any
edge of the main window, and it will be docked to that edge. Many applications place
a selection of drawing tools along the base of the window, and you can re-create the expe-
rience by enabling the Drawing toolbar (View » Toolbars » Drawing), which will default
to the base of the window.

If none of the available toolbars suit your requirements, new ones can be built from
scratch, which become accessible (either locked, movable, or floating) in the same way as
the pre-made ones.

Caution It's important to remember when you're adding, removing, and editing the Writer user interface
(or any other part of the suite) that the purpose of productivity software is to increase productivity. If your
computer screen is totally obscured by buttons and widgets that you might use once every three weeks—or
even just once a week—you might think about simplifying things a little.

Saving

With your basic document created, you now need to save it to the hard disk. Choose

File » Save as, navigate to the desired location on your disk, and input a file name. After
you click the Save button, the document will be written to the disk and can be opened by
choosing File » Open. As you work, save the most recent version of your document by
pressing Ctrl+S or choosing File » Save. For peace of mind, OO.o0 performs an autosave
periodically and can also be set to make a backup of the document that can be recovered
in the event of a crash. In fact, 00.0 has some pretty smart crash recovery systems, which
means you won'’t lose too much work should anything unforeseen happen.

You also can take a snapshot of the document, which allows you to return to a pre-
vious version (this is especially useful if you're going to make a radical, experimental
change) by choosing File » Versions. This launches a new dialog box with a large area
(which will eventually hold the different versions of the document) and a series of buttons
on the right. Click Save Version to create a new snapshot and close the window. Save the
document in the normal fashion as you’re working and then save a new version using the
same method when necessary. You can roll back to a new version by selecting it from the
list and clicking Open. You can also compare versions, delete old versions, or set the soft-
ware to create a new version whenever the document is closed. All of these versions are
saved with the document.
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Template Building

Templates are one of the most versatile tools available in OpenOffice.org. They allow
users to create designs that can be reused again with new content, thus saving you time.
The template system is common across all applications in the suite, so you can build tem-
plates for text documents, spreadsheets, presentations, and even databases.

Add Placeholders

The purpose of using word-processing software, as opposed to a manual typewriter for
example, is to reduce the need to perform repetitive tasks such as inputting the same
address or date on every letter you write. Now that you've created a simple letterhead,
you'll remove the unique content from it, replace that with a series of placeholders,

and then save the whole thing as a template that can be reused over and over again (see
Figure 1-18). This means that the next time you need to write a letter, you can open the
template, add the unique content again, and save it as a new document without the fear
that you're saving over some other important document.

Figure 1-18. From very plain text, we've added a little style. We'll save even more time by creating
a template from this document for all of our letters.
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You'll start from the top of the document and work down, changing items as you
come across them. The recipient address is likely to be variable data—that is, it will
change on every letter—so you need to add placeholder text. This text includes a descrip-
tion of what the placeholder should contain, which disappears when the element is
clicked, and is formatted so that any added text assumes that format.

Highlight the first line of the address in your letter and then choose Insert » Fields »
Other to launch the Fields dialog box. Placeholder is a predefined variable field that is
accessible under the Functions tab, so select Placeholder to reveal the three-column
configuration box. The Type of field we’re adding is a Placeholder and the Format is Text.
On the right side of the dialog box, in the Placeholder text box, you can add the text that
will appear as the placeholder in a fetching green, encased in <> angled brackets and, just
in case you don’t realize their special use, highlighted in gray. Anything typed into the
Reference text box that appears below the Placeholder text box will be displayed as a tool
tip when you or some other user hovers over the placeholder text; it’s especially useful if
you're designing for another user and you want to offer some instruction or advice on the
placeholder’s content (see Figure 1-19).

23

Figure 1-19. Tool tips are especially useful if you're designing a document that is destined to be used

by someone else.
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The Fields dialog box is entirely “live” so you can keep it open while working on the
actual document beneath it. This means that with the window open, you can select each
part of the address in turn, define the Placeholder and Reference elements, click Insert,
and see that placeholder added over the top of the selection. Complete the recipient
address by adding details such as town or city, postal/ZIP code, and phone number, and
then close the Field dialog box.

The placeholders can be formatted in the same way as any other text—simply high-
light and adjust—and so can be designed to fit in with the rest of the document. When you
reuse the template at a later date, you'll be able to click a placeholder and begin typing,
and whatever you add will assume the location and formatting of the placeholder text.

Choose the Date

The date is next down the page, and there’s a special field available for just this purpose.
Because this field should dynamically update as you create new documents, instead of
hard-coding the date into the page, you're going to add a date field by selecting Insert »
Fields » Date. This adds a standard format date to the document and adds the gray back-
ground to indicate that this is a field. You need to make a few changes by double-clicking
on the date to open the Edit Fields dialog box.

This box consists of three columns, but you can ignore the left column. The Select
column has two options: Date (fixed) and Date. Selecting the former inserts today’s date
into the document, which stays the same regardless of when you edit the letter. This is
not really appropriate for a template, so select Date to ensure the document includes the
current date. From the multitude of date formats in the third column, choose MMMM
DD YYYY, which will display Christmas Day as December 23 2008.

If none of these options suit, you can also create your own format by scrolling to the
bottom of the options list and choosing Additional formats. This opens up a more exten-
sive dialog box where you can make more radical changes to the date.

Here again you'll see the list of available formats, but at the bottom of the window is
an area for creating a totally custom date field (see Figure 1-20). The various elements you
can add are shown in Table 1-1.
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Figure 1-20. Many date options are available, but if nothing fits the house style, then you can
create custom dates.

Table 1-1. Date Elements Are Given Representative Codes

Code Description Example
NN Short day Fri
NNNN Full day Friday
DD Numerical day 25

MM Short month Dec
MMMM Full month December
YY Short year 08
YYYY Full year 2008
HH Hour

MM Minute

SS Second

You can also delimit each element with any character. For example, to create
12/23/08, you would enter MM/DD/YY, but to add a more formal dateline, you might
have NNNN MMMM DD YYYY, which would render as Thursday December 25 2008.
The options for adding hour, minute, and second information are likely to be useful in
a spreadsheet but can usually be ignored in letter writing.

25
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Now you need to add placeholder elements for the salutation and reference because
these too are likely to change on each new letter. You'll also select the body of the text and
put a placeholder there. Remember that this placeholder will inherit the formatting from
the present text, so when you write a new letter, it will automatically retain the first line
indent you set earlier.

Finally, you’ll add placeholder text for the signoff (with a short note in the tool tip
about letter-writing etiquette), add a few punctuation elements to save typing them every
time you use the template, and you're ready to save.

Save the Template

Ordinarily, you would save documents as documents, as you did earlier in this chapter,
but in this special case, we want to save as a template (see Figure 1-21). This means that
the next time the document is opened, it will open as if it were the first time, and users
will be prompted to supply a new file name when they attempt to save it. If you saved as
a document, edited the text or replaced the placeholders, and clicked Save, it would auto-
matically save over the original—you don’t want this to happen as that would destroy
your previous work!

Figure 1-21. Save the document using the correct template format so that you can create
a new document from it at a future date.

Templates can be saved to any location, but if you want them to pop up in the My
Templates section of the New Document selector, they need to be saved from within
00.0 or manually moved to the correct location.
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To save within O0.o, choose File » Template » Save. Select the MyTemplates folder,
and provide a name for the template. Click Save to add the template to the folder. To
make changes to the template name or the location of a particular file post-creation,
choose File » Templates » Organize. This will launch a two-paned organizer window
where individual files can be moved around or deleted (see Figure 1-22).

Figure 1-22. Organize templates by moving them between folders.

TEMPLATE LOCATIONS

The location of the template files that make up the My Templates collection varies from system to system.

Windows

Windows stores templates in C: \Documents and Settings\username\Application Data\0003\
user\template.

Linux

Linux users need to save in ~/.openoffice.org3/user/template, which is a hidden directory. The
simplest way to get the template into the right location is to save it first to your desktop or documents
folder, and then manually move it. After the template is saved, open up your File Manager, and select
View » Show Hidden Files. If you're already sitting in your home directory, a bunch of folders should
have appeared, including the one you need. Navigate through this in the usual manner until you open
the /template folder, and then drag the previously saved file into there. Remember to hide hidden files
again if you’re not a fan of filesystem clutter.

0S X

The new Mac OS version of the application stores its templates in /Users/username/Library/
Application Support/OpenOffice.org-aqua/3/user/template.
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Note You can set your own location for templates, which makes it much easier to add and remove them.
Go into Options (Tools » Options), open the OpenOffice.org section by clicking the little plus (+) icon next to
the label, and find the Paths section. Choose Templates, click the Edit button, and click Add. This launches
a standard file selector where you can navigate to an existing directory or create a new one. This new loca-
tion is added to the default location, which means you’ll retain access to the suite’s included templates while
being able to manage custom templates much more easily. Make sure you select the radio button next to the
new path to set this as the default save location for new templates.

To test that everything’s working, open up Writer, and select File » New » Templates
and Documents. Look under the MyTemplates tab, and your blank letter should be there.
Select this letter, and then begin adding content. The placeholder text should be click-
able, so you can enter repeated detail without having to either delete or format anything.
The other important thing about this method is that when you save the document for the
first time, it will automatically Save As, which means there is no risk of accidentally over-
writing some piece of vital correspondence.

Checking Through a Document

Writer contains a selection of tools designed to help you create great documents and
present a professional image to the world. And despite being fairly simple documents to
design, when drafting a letter, which these days tends only to be used for very important
things, you don’t want bad spelling and a flaky layout to let you down.

By default, Writer has the Auto Spell Check tool turned on. This feature draws a
wavy red line under any misspelled words. Right-clicking such a word opens a context-
sensitive menu (see Figure 1-23) offering a selection of words you may have intended to
use and also a few other options with which you can add the word to a dictionary if it is
correct or set the language correctly if, for example, you're attempting to use the word
“colour” and the document is set to US.

If the red wavy lines are annoying, switch off the Auto Spell Check (which is in the
fourth section of the main toolbar) and, after the document is finished, use the normal
spell checker (Tools » Spellcheck, or press F7). This launches a dialog box where each
“incorrect” word is shown with options for selecting a different word or redefining the
current selection as correct (see Figure 1-24). The Ignore Once button will move over
a word by highlighting it again if it appears in the text. Ignore All will note the word as
acceptable on a document-wide basis and will not highlight it again.
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Figure 1-23. The right-click menu offers a selection of words “close” to the incorrectly spelled one.

Figure 1-24. The Spellcheck dialog box allows you to go through every incorrectly typed word
in the document.
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The Add button adds the highlighted word to the standard dictionary, and the Auto-
Correct button adds the word, and the selected “correct” version to the AutoCorrect
dictionary. This latter tool is really useful if you consistently spell a word wrong (we’ll
cover this more in Chapter 3), and you want the software to change it as you type.

Tip If your version of OpenOffice.org is not displaying the wavy spelling lines, it could mean that no dic-
tionaries have been installed. Dictionaries in many languages can be downloaded from the OpenOffice.org
web site as . oxt files. These can be added to the software using the Extension Manager (Tools » Extension
Manager) as shown in Figure 1-25. Once added, a dictionary is accessible by right-clicking and choosing
Tools » Spelling and Grammar.

Figure 1-25. OpenOffice.org can have a number of dictionaries installed at one time.

Another presentational problem that often besets word processor documents is
incorrect spacing between words. For example, in the day of the typewriter, users got
into the habit of adding two spaces after a full stop (after a period). When using a type-
writer with a fixed-width typeface, this might have made sense, but in the age of dynamic
fonts, it’s unnecessary. Finding an instance of two spaces within a document can be quite
a challenge, but there are two ways you can eliminate them.

The first is to choose View » Non Printing Characters to expose all of the hidden
parts of the document—the spaces, paragraph returns, soft returns, and tabs—allowing
you to comb through the text and remove anything that is out of place (see Figure 1-26).
The text remains editable in the normal way, and when printing, will print as normal.
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Figure 1-26. The dots in this screenshot represent spaces. Each “hidden” character in a document has
its own symbol that can be used for search and replace.

The second way to remove annoyances such as double spaces, especially if there are
alot of them in a single document, is to use the Find & Replace option under the Edit
menu. The top text area of this dialog box contains the text you need to find, and the bot-
tom area contains its replacement (see Figure 1-27). After these have been added, use one
of the buttons on the right to find and replace single entities or use Replace All to replace
all instances of a certain term at once. The Match Case option is useful when you want to
change, for example, “Hope” (the town) but not “hope” the concept. The Whole words
only option is useful if you want to change “Man” to “man” but don’t want it to affect
“Manchester” or “Manager.”

Of course, the Find & Replace option can be used to make more drastic changes as
well. For example, you may write a novel with the lead character called Harry. If, 55,000
words in, you decide his name should be John, Find & Replace will save a lot of effort.
And if you ensure that Whole words only is not selected, it will also change “Harry’s” to
“John’s,” just as using the Match case option will ensure that the sentence “The boss used
to harry his staff . . .” doesn’t become “The boss used to john his staff. . ..”
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Figure 1-27. Use the Find & Replace feature to make large-scale textual changes to a document.

Printing

The final stage of any production—well, any traditional production—is printing out

a hard copy. First, however, you can get a better idea of how the final result will look by
using the Preview button (the eighth button from left on the main toolbar) or by choosing
File » Page Preview. This displays a more accurate rendition of the page.

The Print button (next to the Preview button), the File » Print menu, or the Ctrl+P
shortcut key will launch the standard Print dialog box. You can select a printer, set the
page size, define the number of copies, and set the pages to be printed in this dialog box
(see Figure 1-28). Options relating to the selected printer are accessible from the Proper-
ties button, while the Options button has many things to change, including preventing
graphics from being printed, setting left- or right-only page printing, or turning off back-
grounds. These options can be useful for proofing documents without wasting ink and
time. Click OK to initiate the printing process.
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Figure 1-28. Comprehensive printing options provide good control over how your final document
appears.

Recap

In this chapter, you've used OO.o Writer to create a basic text-based letter. You've made
some simple alterations to the format of characters and paragraphs and made a few
changes to the application’s interface to put important tools a few clicks away. You've
taken this letter, removed all the unique content, and repurposed it as a template that will
save time in later uses. Finally you've delved into the Placeholder text system—in readi-
ness for more extensive edits later—and changed the way that OO.o0 deals with dates at
the document level.

In the next chapter, you’ll work with some of these elements again, but this time,
you'll focus on a more design-intensive document and adding some graphical flourishes.
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CHAPTER 2

Design Using Writer

We’ve looked at the basics of Writer document creation, but the application is capable
of so much more (see Figure 2-1). In fact, you have a set of design and layout tools at your
disposal that, just a few years ago, would have beat a thousand dollar professional pub-
lishing package. In this chapter, we’re concentrating more on bringing text and imagery
together to create something much more stylish than a few blocks of text. And this is per-
fect preparation for the next chapter where we’ll draw together the whole Writer toolset
to create a newsletter with columns, graphics, colors, and photographs.

Figure 2-1. Writer is capable of much more than simple letters. In some areas, it even rivals
dedicated desktop publishing packages.
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Although the end result may be a newsletter, the processes and tools you'll use to
create this page are perfect for any document that requires a little more visual style than
a simple piece of text; from flyers and menus to bookmarks and class handouts. This
change of emphasis from simple text to design involves introducing a few new concepts
into the mix. Frames, which can contain any kind of content, are discussed later in this
chapter, whereas paragraph styles, which allow you to automate many elements of the
presentation process, are covered briefly next but will be examined in much more detail
in Chapter 3. In addition, Draw has some page layout features that may be useful if a
design seems too ambitious for Writer. See Chapter 6 for more on this.

Multicolumn Text

In our previous document, we followed the conventions of a letter that had a single
column down the center of the page. To add a little flexibility to the next project, you'll
begin with a two-column page. After you've created a new document (File » New » Text
Document), select Format » Page to define the page size and margins, and then click the
Columns tab.

Writer is very flexible about its columns, allowing anything up to 99 columns on a sin-
gle page and allowing you to set widths either automatically or on a column-by-column
basis. Five common layouts are offered at the top of the window; they can be used as is
or as a starting point for more editing. Adding columns to a document can give it a more
“newspapery” feel, but be aware that three columns on an A4/letter page is probably the
maximum you should aim for. Larger pages can obviously take more columns.

Below these five icons are the configuration tools; there is a measurement box for
each column (use the left and right arrows to see anything beyond the three visible
boxes). Editing the width of a column involves either using the up/down arrows or typing
avalue in the box (see Figure 2-2). These values can obviously not add up to more than
the available space, so the software won'’t let you design unfeasible widths, and increasing
the width of one column beyond these boundaries will automatically shrink any others.

If you want to create a number of columns with an equal width, choose the AutoWidth
option (the manual width boxes will be grayed out).

Note If you've added content to a column-based layout, and the text features masses of hyphens on
the right edge of each column, look at the font settings or column widths for a remedy. There are a lot of
hyphenation settings to play with by choosing Format » Paragraph, under the Text Flow tab. See Chapter 3
for more on advanced paragraph formatting.
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Figure 2-2. Writer is capable of sophisticated multicolumn design, and to save having to
design your own, the software has a set of premade layouts available at the click of a button.

Beneath the Width values are the Spacing values that define the gap—or gutter in
design-speak—between each column. Studies have shown that when readers are follow-
ing a long horizontal line of text on a page, they frequently lose their place, so the use
of columns and gutters can improve readability significantly. A gutter needs to be wide
enough to make it clear to readers that they should not continue along the current line.
For reference, a typical newspaper uses a gutter of between 0.4 and 0.5cm between each
column, whereas books have a larger gutter. Set yours to 0.6cm because you'll be adding
an extra separator between the two areas of content.

In the Separator line section of the dialog box, there are options for setting the width
of the line and its height. Selecting anything but 100% for the latter will automatically
enable an alignment option where you can choose to set the separator at the top or bot-
tom of the page or center it vertically. One thing missing here is the ability to define
a particular line type (dotted, dashed, etc.), so leave your line in place for the moment,
but note that you'll be replacing it later on.

For this project, you're going for a two-column asymmetric layout, with the left col-
umn taking up 6cm and with spacing of 0.6cm. Now add a 0.05cm line between columns,
set it to 85% of the page height, and align it to the bottom of the page (see Figure 2-3).

This sort of design divides the page neatly into three regions; there is space at the
top for a masthead or large title, the smaller left column is set to contain publication and
address information, and the right column is for some actual content. This is the perfect
layout for a community or church newsletter, school brochure, internal communications,
or formal business flyer.
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Figure 2-3. This asymmetric layout gives you quite a few options when it comes to importing a selec-
tion of different stories.

Normally, Writer expects text to flow in particular ways. For example, if you begin typ-
ing (or pasting text) in this page, the words go across the left column creating new lines as it
reaches the right edge of the column until it hits the bottom of the page; the text then flows
into the right-hand column and continues on down the page until it reaches the base of
that page, and then a new page is added to the document following the design of the first
page with the text in the left column, and on and on. However, you'll be working using the
DTP (desktop publishing) methodology, which means actually creating the three regions
mentioned earlier so that the various bits of content stay in their own frames.

The Title Frame

You'll start by adding the textual element that will dominate the page in a new frame. This
element is ordinarily the title of your publication or a section title. Frames are what make
the DTP-like functions of Writer possible because each one can contain anything from
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text or images to drawings and spreadsheets. They're like having a lot of small individual
pages on top of the main page. Choose Insert » Frame to launch the Frame dialog box.
The Frame dialog box is divided into three sections, but we’re really only interested in

the right-hand section at the moment (we’ll come back to the other parts shortly). In the
right-hand section, you'll notice that, by default, your new frame is set to Anchor To para-
graph. Any frame that is anchored to a paragraph moves up and down with its host as you
edit or add text above it. This will be useful later on, but we want the title frame anchored
to the page. An object in Writer is typically anchored to a particular place in the text, for
example, a paragraph or character. By anchoring to the page, the object will stay where
we place it, and text can—if configured to do so—wrap around the object.

Select To page and click OK (see Figure 2-4). The underwhelming result is a little
frame near the top of the page. However, you can resize this to more impressive dimen-
sions by clicking it to reveal eight grab handles and dragging these to the right places on
the page. It’s also possible to move the entire box by clicking anywhere within the box
and dragging.

39

Figure 2-4. Frames can be anchored to various parts of the content, but for the most flexibility, anchor

this frame to the page.
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Note The first time you edit text frames in Writer can be a little frustrating because the method of grab-
bing them may seem random; it’s not. It’s just that all frames in Writer have two methods of editing to deal
with the distinction between the object and its content. The most obvious example of editing an item is
clicking the edge of a frame and resizing the object with the frame handles or repositioning it on the page;
but item editing also includes things such as the border, the background, and the frame’s relationship with
the rest of the page. All of these options (which we’ll discuss further in this chapter) can be accessed by
double-clicking the frame.

You can edit the content of the frame by clicking inside it and getting straight to work on the text. Of
course, if you’ve previously selected a frame for item editing and want to edit the content, you first have to
click off of it, that is, click somewhere else on the page before clicking inside the box again.

This frame needs to go across the top of the page (from margin guide to margin
guide), and the base should fall a few millimeters from the top of the vertical line between
the columns. You probably noticed that Writer automatically adds a black border to text
frames, which we don’t want. Getting rid of the border is an “item” edit, so click one of
the frame edges to go into item mode and then double-click the frame. This launches the
Frame dialog box that you used earlier to add the frame. Before getting rid of the borders,
this is a good opportunity to refine the position of the box—your eye may be good, but it’s
probably not perfect—using the bottom section of this dialog box.

Writer’s standard method of defining position is to base it on the edge of the page. In
this case, you need to make sure that the Horizontal and Vertical values on the Type tab
of the Frame dialog box are set from Left and Top, respectively, and that the figures in the
boxes match the margins set when creating the page. If you can’t remember these num-
bers, you can also position the frame relative to the Page text area (using the drop-down
list on the right) and setting the value to 0.00cm.

Now select the Borders tab (see Figure 2-5). In this tab, you can define which edges
of the frame are bordered, the style of any borders, their color, and the gap between the
frame edges and your content. At the base of this window, there is also an option to add
a shadow to the box, but ignore that for now.

For this project, we want a newspaper-like title, so switch off the borders completely,
(selecting the first icon under Line arrangement), and click OK. Now click off the frame
box in your document, click inside it, and type a title for the document.
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Figure 2-5. Frame borders and the distance between the borders and the content can be defined for
each edge.

Advanced Text Editing

Now that you have a title, you need to make it a bit larger so it stands out from the rest of
the text that will be on the page. To do this, highlight the text, and increase the size using
the font size drop-down list on the Formatting toolbar. The drop-down list offers preset
sizes, but you can be more precise by entering any size using the number keys. You may
also want to change the default Writer font to something a little more stylish by selecting
the right look from the font drop-down list.

Tip Typically fonts for printing are measured in “points,” and the higher the number, the larger the text. In
the past, most fonts were designed to follow a standard size, which meant that 72 points roughly equaled 1
inch in height. However, this is not so standard now, and 72 points in one font may be significantly smaller or
larger than another.
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Writer has more options available to improve the look of your text beyond this simple
editing; to access the extended toolset, highlight the title, and choose Format » Character.
This launches the familiar Character dialog box where you can make a few more changes;
the dialog box launches with the Font tab highlighted (see Figure 2-6). The Font tab con-
tains the same range of tools available on the Formatting toolbar but also has a preview so
you can see changes made in real time.

Figure 2-6. You can select a font from the main interface and from the Character dialog box.

In the Font Effects tab, you can make some fairly dramatic changes. It’s easy to
go overboard with these effects and create something messy, so take care, especially
when using small font sizes. On the left are the Strikethrough and Underlining options,
featuring a range of different types of line and color, and the Font color option. On the
right, there are some case Effects—that is, they change the case of selected letters to
uppercase, lowercase, title case (each word has an initial capital), or small caps—Relief
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effects (embossed and engraved), and then some miscellaneous effects such as Outline,
Shadow, Blinking, and Hidden. The Outline and Shadow effect combination works well
for titles, so select those check boxes as shown in Figure 2-7.

Figure 2-7. The Outline and Shadow effects work well together on our newsletter title.

The Position tab provides a great deal of control over how the text is positioned not
just in terms of superscript and subscript but also in the spaces between individual let-
ters, the width of each letter, and the rotation of the text (see Figure 2-8). There is an
impressive amount of control here, as well as some sensible default options for those
more interested in the words themselves. For example, in the Subscript and Superscript
options, you can define how far to scale the letters and how far from the baseline to move
them; by default these values are set to 58% and 33%, respectively, but you can create
some interesting effects by playing around with these settings.

Rotation/scaling settings are available in the center of the dialog box.
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Figure 2-8. When outline fonts are condensed, clashing letters are dealt with in a stylish manner.
Overlaps are joined together.

Ordinarily, rotation is restricted to 0, 90, or 270 degrees (horizontal, vertical
bottom-to-top, and vertical top-to-bottom), and the Fit to line option—which is grayed
out until a rotation value has been selected—squishes the line of text vertically into the
same height it occupies horizontally.

The scaling options increase or decrease the width of the letters (the value of 100% is
Writer’s standard setting), whereas the Spacing section options expand or condense the
gaps between the letters. Pair kerning, which is only available on some fonts, pays par-
ticular attention to letter pairs such as “Wo” and “fi,” which can often cause problems.
Kerning is the process of pulling pairs of letters together to reduce ugly gaps in a word.
By using these options, you can fit your title effectively in the space at the top of the page.
There are two approaches to this; you can either reduce the size of the font slightly and
then increase the spacing until the text fills the space, or you can increase the size of the
font until the text goes over two lines and then reduce the spacing to get it back to one
line. The latter adds the most impact to the title, whereas the former is good for giving
space to subheadings.
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TEXT FORMATTING TERMS

¢ Bold: Makes the text thicker to add emphasis. Bold text takes more space on a line than
regular text.

e [talic: Slants text forward slightly, at its most basic. In practice, though, a real italic font is not
just slanted but may also be slightly more ornate.

e Underline: Adds a solid line under the text. It too can be used to add emphasis, but most modern
design tends to steer clear of it as italic is a far more elegant solution.

o Strikethrough: Denotes something that should be removed by putting a solid line horizontally
through the center of the text.

e Superscript. Reduces the size of the font and raises slightly from the baseline of the text. Used for
adding suffixes to numbers in dates (215, 3, in mathematics (10%), and to denote a footnote or
bibliography entry.

e Subscript. Like superscript, reduces the size of the text but drops it below the baseline. Often
used to define chemical structures (h,0).

Caution As with font effects, it's easy to overuse spacing and horizontal/vertical font scaling, which
results in an unprofessional-looking document. Use your eye to compare what’s on the screen with the kind
of output you’re used to looking at. Does your text look odd? Are the letters easy to distinguish?

Edit Frames

Frames can be used to add as many text boxes (and other objects) as you like to the page.
In addition to the title box you built earlier, you’ll add two text boxes in the main content
area, reflecting the column design of the page, and add a third just beneath the title for
the publication’s subtitle. You'll position these using the margin guides.

The left-hand frame will be colored in the final production, and the text will be inset
slightly in the box so it doesn’t clash with the edges. There are two ways you can accom-
plish this job: you can use the paragraph options (see Chapter 1) to add indents to the left
and right edges of the text and then add a little space to the top paragraph, or you can add
a four-sided border to the frame and then inset the contents all around the box. To do the
latter, double-click the box, choose the Borders tab, and set the All Four Borders options
in the Line arrangement section as shown in Figure 2-9.
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Figure 2-9. Border options can be set using the default or user-defined method.

With that selected, choose the line width (0.05pt) and Color (White), and then define
the Spacing to contents on the right-hand side at 2.0mm all round. The purpose of choos-
ing a white border is so that when you color the frame (later in this chapter), it won’t look
out of place. (You could also make the border the same color as the frame background.)

At the base of the Borders settings is an option to add a shadow to the box. Selecting
one of the positions (bottom-left, top-right, etc.) enables the Distance and Color settings,
providing a lot more control over the look of the shadow. You don’t need this now, but
you might come back to it later.

For now, populate the two main frames with some placeholder text to get an idea of
what the final layout will look like.

Placeholder Text

The type of placeholder you'll use is called “lorem ipsum” text, which is designed to simu-
late the look of written English (so you can make an intelligent guess at how many words
each part will accommodate) while not actually making any sense. The text we’ve used
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was cut and pasted from a website called the Lorem Ipsum generator (http://www.1lipsum.
com/), but we can make the process of adding this text with the addition of a special 00.0
extension.

Extensions are covered in detail later, but briefly, an extension is a small program
or macro that integrates with Writer, or some other element of the suite, and adds a fea-
ture that might be slightly too “niche” for the OO.o developers to worry about. One such
extension is the Lorem Ipsum generator, which uses the Lipsum website to generate
dummy text for your layouts. The extension is available from http://extensions.services.
openoffice.org/project/Lorem ipsum generator. Download the file, which has an .oxt file
extension, and save it somewhere on your disk.

In any OO.o application, go to Tools » Extension Manager, select My Extensions,
and click the Add button (see Figure 2-10). Now use the normal file browser to find the
downloaded .oxt file, and click Open. The extension appears under the My Extensions
disclosure arrow; its status should automatically be set to Enabled, but if not, click the
Enable button, and then click Close. Because of the way this extension integrates with
00.o0 (it adds a new menu entry), you'll have to shut down and relaunch the application
to see the fruits of your labor.

Figure 2-10. The OpenOffice.org community has created many extensions to improve the
toolset for specific user groups, including designers. See Chapter 11 for more on extensions.
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So, in a restarted Writer, select the appropriate frame, and choose View » Toolbars
» Lorem Ipsum to add the LI toolbar to the Writer user interface. (or you can simply add
the button to an existing toolbar as described in Chapter 1). For some reason, the icon is
a crash test symbol; click it, define how much text you want in either words, paragraphs,
bytes, or lists, and click Generate (see Figure 2-11). The placeholder is added to wherever
the cursor was before the Generate button was clicked.

When the placeholder text is in these frames, you can define the font, size, and
paragraph settings to make everything look good before you even have to worry about
the actual content. When you add the real words, the formats will be inherited from the
placeholder text.

Figure 2-11. Dummy text can be defined in particular word or paragraph lengths.
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WORD COUNTS

Writer’s word count is accessible from Tools » Word Count. This will launch a two-part dialog box; the
top section reveals the number of words and characters in a selection, and the bottom section does the
same for the entire document. Of course, if you have nothing selected, the top half won’t have any use-
ful information.

On longer projects, such as scripts, books, or dissertations, the section word count is absolutely
vital, but it’s also useful to get an overview of the entire project.

More statistics, including the number of paragraphs, pages, images, and tables in a document, are
available by choosing File » Properties » Statistics.

Colors

Almost any document can be enlivened with a splash of color, and you can add some
sparkle to almost any element on a Writer page.
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Text

Text is so important that it gets three separate types of color options: type, highlight, and
background. Most obviously, the type color changes the color of the font on the page.
Highlight a piece of text, and click the text color icon to open the selection dialog box.
The Font color dialog box is a movable palette rather than a simple drop-down list, which
makes it easy to leave open for experimentation (see Figure 2-12). Changes in text color
only affect highlighted text, but if you choose a new color before selecting text, the cur-
sor becomes a paint bucket, and you can paint across a text selection to change its color.
You'll notice, also, that if you have a shadow, and the text is black, the shadow will be

a faded gray; but when using any other color, the shadow will be black.

Figure 2-12. A large selection of colors have already been added to the system. Hover the mouse over
a color to see its name.
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The Font color dialog box contains just over 100 colors (hover over a color to see its
name), but you can also add more hues in the Options settings (Tools » Options). Under
the OpenOffice.org settings (at the top of the list on the left), select Colors. Colors in 0O.o,
in common with most computer applications, are usually defined by mixing a combina-
tion of red (R), green (G), and blue (B) light. There are 256 degrees of brightness for each
of these, giving you a potential palette of 16,777,216 colors ranging from white (255, 255,
255) to black (0, 0, 0) and all points in between. It’s best to begin with a color that is close
to what you need rather than starting from scratch, so pick a color from the available
palette, re-edit the values to get it just right, add a new name in the Name field, and click
the Add button (see Figure 2-13). Your new color will then be available whenever the Font
color dialog is opened. If changes need to be made, revisit this dialog box, select the color
to be edited, and click the Modify button. Changes made will then be reflected not just in
the palette but also in any page element using that color.

Figure 2-13. The color-editing box

Note In the color-editing box, just above the R, G, and B settings, you'll see a drop-down list; click this,
and select CMYK to define your color using the cyan, magenta, yellow, black system, which tends to be used
by professional printers. RGB (Red, Green, Blue) is how colors on a screen are defined. If your document is
destined for output by a printing bureau, it may be best to define your colors using this system, especially if
you’re working with a particular selection of colors.
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Highlights

The highlight color is used to pull out a word or phrase from a piece of text, just as you
might with a traditional highlighter pen. Select some text, and click the highlighter button
and the text will be picked out in a bright yellow (the default color). You can choose other
hues by using the drop-down arrow to launch the color selector. Obviously, particular
color combinations (black text, black highlight, etc.) won’t work well, so Writer changes
the text to black or white depending on the strength of the chosen highlight; darker
backgrounds will have white text, and lighter ones will have black text. These options are
based on the “Automatic” text color—at the top of the color selection box—and will be
overridden by any changes made to the text color.

Background

Whereas highlights work on individual characters, words, or phrases, the Background
color option highlights entire paragraphs. It uses the same methodology: make a selec-
tion (in this case, simply clicking anywhere in a chosen paragraph), and choose the
color (see Figure 2-14). Again dark colors will force the text to white, and light colors will
force it to black. As with any paragraph formatting, the background color is automati-
cally assigned to following paragraphs as you type until the color is changed or No Fill is
selected from the chooser.

Figure 2-14. Bold blocks of color can be used to highlight particular areas of the page.
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Frames

You can also set various color options for the frames you've created (see Figure 2-15),
and these are available by either double-clicking a frame or by choosing the appropriate
option from the Formatting toolbar. As you saw earlier, you can color both the line of the
border and the background of the frame itself. Your layout demands that both colors be
the same for now. After a frame has been created, it can be saved as a frame style, which
makes it easy to apply the same format to every frame in the document. Styles are cov-
ered in detail in Chapter 3.

Figure 2-15. Launch the Frame toolbar using View » Toolbars » Frames.

Note that if you have the text in this frame set to Automatic, it will change to white
text if the background color is dark and will remain black on a light background. Over-
ride this coloring by selecting the text inside the frame and defining a color as discussed
previously.

Inserting Graphics

So far you’ve been working with text and color, but now its time to introduce a little
imagery. The process of actually adding a picture to the page is very similar to what
you've previously done with frames, and it begins with choosing Insert » Picture »
From File. Writer is capable of importing a wide range of bitmap and vector pictures,
and it also has tools that allow you to create graphics (as discussed in this section and
Chapter 6) directly on the page.

You'll start by adding an image to the left column, so click into the column, and
choose Insert » Picture » From File. Now navigate to the location of your image (prefer-
ably a photographic image for this section), and select it. If you're looking for a particular
image in a sea of DCFSxxx-xx. jpg, click the Preview button to get a glimpse of the pictures
before importing (see Figure 2-16).
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Figure 2-16. Use the Preview button to get a look at a selected image before importing.

By default, the software imports the image into the page, but you can also link
the image to its original file by selecting the Link option. The advantage of this is that
the picture will be reloaded onto the page every time the document is opened, which
means if you edit an image in an external application, these changes will be automati-
cally reflected in the version on the page. Click the OK button. The image will be added
to the page. By default, Writer anchors the image to its paragraph, meaning if you
begin adding text above the image, the image will move down the column. This is use-
ful in many situations, but to get more freedom for your layout, you need to anchor it
to the page.

Double-click the image. From the Type tab, set the anchor point To page, and click
OK. This detaches the picture from the paragraph it was in, allowing you to drag and drop
it anywhere on the page. Clicking the image also reveals a set of handles on each corner
and edge that can be used to resize the picture.

When you drag to resize, hold down the Shift key to force the image to retain its pro-
portions; of course, if you want to squash or stretch the picture, don’t hold any key down.
For more refined control over the size and position of the picture, double-click to access
the Picture dialog box again (the Type tab should be selected), and edit the height, width,
and location numerically. Again, if you want to retain the aspect ratio of the image (which
is usually important), select the Keep ratio button before making any edits.

As with the frames created earlier, the position of the graphic, by default, is defined in
relation to the top and left edges of the page, but you can change this using the drop-down
lists in the Position section.
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Sometimes, such as when adding screenshots to a book page, you may want to
anchor an image to a paragraph and then have this image move with the text. To do this,
change the Anchor setting from To page to To paragraph as shown in Figure 2-17, and
then, in the Position section, click Follow text flow. You can still adjust the position of the
image, but it’'s much easier to manage if you change the Horizontal positioning from the
edge of the page to the left or right paragraph border; this is especially true when working
across multiple columns.

Figure 2-17. Adding images to a page uses the same positioning features you've previously used to
add frames.

Before we dismiss the Picture dialog box, check out the Crop tab, which does exactly
as you might imagine and a little bit more. There are three sections in this tab, a preview
window, and a big button to set the image to its original size (i.e., 100%). We’ll go from
top to bottom.
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SUPPORTED IMAGE FORMATS

These formats can be divided into bitmap and vector formats. The former, such as those with a . jpg,
.png, or .tif file extension, are used for photographic images, whereas the latter, such as .wmf, .eps,
.emf, and so on, are described in terms of mathematical properties rather than as a collection of pixels.

Bitmap: JPG, BMP, GIF, PCD, PCT, PCX, PGM, PNG, PPM, PSD, RAS, TGA, TIFF, XBM, XPM

Vector: DXF, EMF, EPS, MET, PBM, SGF, SGV, SVM, WMF, SVG

The advantage of using a bitmap is that the detail available in the image is restricted only to the
capabilities of your camera or scanner. The disadvantages are that bitmap images scaled up way
beyond their original size will look awful and that file sizes of big high-quality pictures tend to be quite
large. Vector illustrations, in contrast, can have small file sizes and can be scaled to any size with no
loss of quality.

The Left, Right, Top, and Bottom values in the Crop section affect how much of the
image is seen on the page. When using a linked image, this operation won’t crop the original,
meaning it can be easily recropped later. For example, if you select Keep scale and increase
the Left value, a portion of the image will be hidden on the page; conversely, if you decrease
that number, some white space will be exposed. It’s also possible to use this mechanism to
scale the image within the box by selecting Keep image size. Now as you increase the Left
value, the image is expanded into the left edge of the box and, therefore, will be omitted from
the page. This method uses a lot of scope to distort the image, so use it with care.

The middle section has a proper percentage scale; keep the aspect ratio safe by
ensuring both figures are the same. The section at the base of the window can be used
to scale the image to a particular size (with the same caveats as before) using the default
measurements of the application.

If, by any chance, you make a complete mess of your image or its box, it’s always
possible to get back to where you started by either clicking Reset and starting again, or by
using the Cancel button. Changes are not actually committed to the page until you click
the OK button; they can also still be undone using Edit » Undo.

In addition to playing with the location and cropping of an image, Writer also has some
editing tricks. To get to these, select the image you want to edit, and choose View » Tool-
bars » Picture to launch a small but very compact toolbar (see Figure 2-18). Like any other
toolbar this can be free-floating or can be docked to any edge of the main Writer window.

Figure 2-18. This deceptively small toolbar holds a lot of power to edit images on the page.
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This tiny toolbar is dominated by a drop-down list of image styles that can be used
to change the picture to a grayscale, black and white, or watermark, which increases the
brightness and reduces contrast, making the image suitable for use as a background pic-
ture (see Figure 2-19).

Figure 2-19. These effects are entirely nondestructive, which means they can be reversed by selecting
the Normal option at any time.

To the left of the drop-down list are two buttons; the first opens up the Picture
dialog box for positioning, cropping, and so on, whereas the second contains a collec-
tion of icons that can be used to apply various effects to the picture (see the sidebar
for examples), including smooth, sharpen, posterize, and pixellate. These filters are
not a real substitute for a full-fledged image-editing package, but for quick jobs (espe-
cially sharpening up an image that’s been reduced in size), they’re ideal. Each filter has
a selection of options that is revealed when the filter is selected from the list.
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IMAGE EFFECTS

The following image effects can be used to make rapid changes to a document but should be used
sparingly. Major image editing is a job for a more specialized application such as Photoshop or Gimp.

Invert. Changes the color values of every pixel in the image to their complete opposite. For exam-
ple, white becomes black, green becomes red, yellow is changed to blue, and so on.

Smooth: Antialiases the image slightly (i.e., adding colors to areas of high contrast) to make them
appear less distinct. Very useful for making curves look smoother.

Age: Attempts to simulate the aging process on a photo. This filter fades color, adds scratches
and dirt, and introduces some other color elements.

Posterize: Reduces the number of colors in an image, sort of simulating the process of creating
a screen print. Colors can be reduced down to four.

Relief. Attempts to make the image look like an engraving by highlighting areas of high contrast.
This effect is really hard to use well.

Pixellate: Enlarges the pixels in the image, which has the effect of obscuring detail. Good when cre-
ating screenshots of financial software or removing faces or license plate details from a picture.
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To the immediate right of the drop-down list is a Color icon that launches a Color
edit window offering very fine control over color composition of the image, including
its brightness, contrast, and the RGB values in the image. Using this toolbox, you can,
for example, knock back the image by increasing the brightness to 20% and decreasing
the contrast to -40%, and then turn the blue element up to 100% to create a light blue
watermark-type image (see Figure 2-20), which fits in nicely with the rest of the design.

Figure 2-20. Editing the brightness and contrast and then increasing the value of a single color
allows you to make a useful watermark image, which can sit behind some text without adversely

affecting readability.

Next to the Color icon, you'll find the Transparency settings with a range of 0% (com-
pletely opaque) to 100% (completely transparent), followed by the Flip Horizontal and
Flip Vertical buttons that mirror the image along either the horizontal or vertical plane.

Building an Image Gallery

Many projects and publications rely on images such as logos, signatures, and photos that
are used over and over again. Fortunately, Writer makes it simple to work with recurrent
images without having to constantly import them from some obscure location through
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its gallery feature. The gallery allows you to corral a lot of images together in themes and
then use drag and drop to add elements to the page.

The package comes with a selection of prebuilt themes, including backgrounds,
icons, and even sounds, but they all display an obvious web-editing bias, so you'll create
anew one to go with the example publication.

To begin, open the gallery by selecting its icon from the main toolbar or choose Tools
» Gallery. A new section opens at the top of the main Writer window that is populated
with web-style tilable backgrounds. On the left is a list of available galleries, and the loca-
tion of the gallery objects is set out across the top. One of the prebuilt themes is labeled
My Theme (see Figure 2-21) and is totally devoid of content. Rename it by right-clicking
My Theme, selecting Rename, and then providing the new name for the gallery: Newsletter.
Click OK to go back to the gallery, and then you can begin adding to it.

Figure 2-21. Define the name of the new gallery and note its location on the filesystem.

There are two ways to add to the gallery. First you can right-click the gallery name
again and select Properties. The General tab is displayed (with another opportunity to
change the name); click the Files tab, and then select Add (see Figure 2-22). This launches
the standard file selector with which you can navigate to the location of an image, select
it, and click OK to add the image to the gallery. If you've assembled all of the required
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images in one location, select Find Files instead, and then use the file browser to navigate
to that folder. Select OK, and the main section of this window is populated with a list of
files within that directory. Now you can select individual files (click the Preview button to
see thumbnails of the images) and click Add, or just click Add All to put every image in the
folder into your gallery.

Figure 2-22. Use the file manager to manually add an image or a selection of images to the gallery.

The second method simply involves dragging images from any file browser and drop-
ping them into the gallery window.

Note that neither of these methods copies the image to a new location; they simply
create a link to the original image, which means if you remove or edit the original image,
those changes will occur in the gallery.

To take an image from the gallery to the page, drag it onto the page and drop it
(see Figure 2-23). It will then be configured exactly as any other imported image, that
is, set as anchored to paragraph with no border and totally uncropped. All the editing
options mentioned previously are also available. You can also set it as a link (mean-
ing, once more, that any changes made to the file will appear on the updated page) by
right-clicking an image and selecting Insert » Link or by holding Ctrl+Shift as you drag
the image onto the page.
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Figure 2-23. Pictures can be dragged into a gallery from any folder on the hard disk or even from the
Internet.

The third item on the Insert menu allows you to add an image to the page or a para-
graph as a background. (See Chapter 7 for more on this.)

The menu also provides some file options such as renaming the file, deleting it from
the gallery (a move which won’t delete the file from your system), and previewing a larger
version.

If you want to see an even bigger preview of the image, choose the Preview option
(see Figure 2-24) and then resize the gallery window by clicking and dragging the bar
between the gallery and the main window down the screen; the preview image resizes
dynamically. Close the gallery by reselecting its icon from the toolbar or by choosing
Tools » Gallery.

In addition to images, galleries can also hold media files for use in web pages and
presentations.

Tip Get a better idea of what the final printed product will look like by clicking the Page Preview button
next to the Print icon (see Figure 2-24). The current page will be displayed with all guides, frame borders,
and paragraph marks removed.
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Figure 2-24. The Page Preview button

Using the lllustration Tools

So far, you've added text, imagery, and other visual content to your document and
divided up the page to present a hierarchy of content to the user. Now you’re going to
add a final touch using a few of Writer’s illustration tools. The tools included in Writer
are a subset of those available in the full Draw package (see Chapter 6) and, in the right
hands, are capable of professional results. You're just going to add a few basic shapes
as a way of introducing a trio of useful design tools: transparency, word wrap, and layer
arrangement.

Start by adding the Drawing toolbar to the interface (View » Toolbars » Drawing) to
expose the various shapes, lines, and primitives available. The majority of buttons (essen-
tially all but the first on the left and the four on the right of the toolbar) can be used to add
new shapes, text, or lines to the document. Buttons with the small arrow to the right of
the icon have more content available, which you can see by clicking the arrow and then
selecting the item (see Figure 2-25).

Figure 2-25. Click and hold an icon in the Drawing toolbar to see more options.

So, for example, to add a puzzle shape to your document, you click the Symbol Shapes
icon’s disclosure arrow and select the cloud shape. The cursor changes to a crosshair,
and you can draw the cloud shape onto the page by clicking and dragging as shown in

63



64

CHAPTER 2 DESIGN USING WRITER

Figure 2-26. As with images, holding Shift while dragging leaves the shape in its original
proportions (this is more important for squares and circles than puzzle shapes). After you
have the right shape, release the mouse button, and the shape is added to the page filled
in the default color and outlined with a thin black line.

After the shape has been created, the Formatting toolbar changes to give you imme-
diate access to the most useful tools, including the line- and fill-editing options. The
quickest way to change the color is to simply select a new one from the drop-down list
on the Formatting toolbar (this is a long list of all the system colors and any custom hues
mentioned previously); however, more options are available in the Area dialog box, which
is accessible by clicking the Pen icon next to the color drop-down list.

Figure 2-26. As with any other shape, hold down the Shift key as you drag to retain the original
proportions of the shape.

The Area tab of the Area dialog box offers a few basic options and contains a drop-
down list to select the type of Fill to apply to the shape (see Figure 2-27). Fill types are
None, Color Gradient, Hatching, or Bitmap, and the second section of this tab changes
depending on your choice. For example, selecting Color displays the list of colors men-
tioned earlier, whereas selecting Gradient offers a list of predesigned gradients and one
extra control to set the number of increments used to get from one color to the other.
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Select Gradient from the drop-down list, choose one of the available fills, and click OK.
The fill is added to the shape.

Figure 2-27. The gradient system builds on a selection of premade patterns.

More editing options are available in the other tabs, so select the shape again and
then click the Pen icon to re-edit the area fill. In the Gradients tab, there are six gradient
types—which flood an area with a fill that shifts from one color to another in up to 128
steps—including Linear and Radial, as well as options to change the start and end color,
the prominence of one color over another, and the angle or center point of the gradient
(see Figure 2-28). The workflow in here involves taking an existing gradient from the list,
editing the parts that need changing, and then appending it to the available gradients by
clicking the Add button. You'll be prompted to input a new name for the gradient, and
then it will be added to the list and can be selected as normal. Click OK to change the fill
on the shape.

Tip If you make use of a lot of custom gradients, make sure you take them with you when upgrading your
00.0 installation. In the Gradients editor, use the Disk icon to save your gradients list to your home directory.
This can then be reloaded into a new version of 00.0 using the Load icon.
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Figure 2-28. The first black gradient has been adapted and saved.

Another option is to make the shape transparent, allowing the content beneath to
show through. To do this, go back into the Area dialog box, and select the Transparency
tab. At its simplest, you can apply a uniform transparency to the entire shape (again, 0%
is completely opaque, 100% is completely transparent), but there is also a gradient option
featuring the same six gradient types available as fills and configurable start and end
transparency values. In this example, create a rectangle, fill it black, and then set a linear
gradient to run from 100% to 0% (top to bottom). Beneath this, add another black box
ready for a caption, which creates a nice glossy look on the main image.

Now use the Circle shape tool to add a circle to the page, remembering to hold down
Shift to create a perfect circle. Double-clicking the shape inserts a cursor into the shape
ready for text. One thing to remember when putting text into a shape is that the text will
not automatically wrap to the contours of the shape, so you'll need to use the Enter key to
make new lines.

Previously, you went through the process of rotating text to 90- and 270-degree
angles, but by using the text shape tool (the sixth icon from the left), you can add a text
box to the document and then rotate it to any angle you like. Begin by selecting the text
icon. The cursor becomes the crosshair again, and you can draw a rectangle onto the
page just as you would a shape. This becomes the boundary for the text you're going to
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add, and, unlike inside a normal shape, the text automatically wraps when it gets to the
right edge of the box.

Most of the text formatting options you need are available in this type of text object,
including the usual indent and spacing options, so this could be used for very long pas-
sages of text, as long as they’re restricted to a single page. When we click the Rotate icon
(next to the Color drop-down list), the handles on the corners and edges of the selected box
change to little red circles as shown in Figure 2-29. Grab any one of these, and move the
mouse in the direction you want to rotate the text. You can also add a numerical rotation by
right-clicking the box, selecting Position and Size, and entering a figure under the Rotation
tab. Note that the text remains editable; double-click it to edit the actual content.

Figure 2-29. The Rotate tool provides more extensive options for twisting and turning text shapes
from the Drawing toolbar.

To change the color of the text, highlight it, right-click, and select Character from the
context-sensitive menu. Under the Font Effects tab, select a new color from the drop-
down list, and click OK. The font is recolored. Previously, I mentioned the distinction
between the item and its content, and this is also true of this kind of text object, although
the method of selection is the opposite way around. Single-click to edit the item, and
double-click to edit the content.
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Examples of item-editing options include setting the gap between the border and
text (right-click » Text); filling the background with all the options mentioned previ-
ously (note, however, that the transparency affects the background of the box but
not the text (as shown in Figure 2-30); adding a shadow (see Figure 2-31); and adding
a border (right-click, choose Position and Size, select Slant & Corner Radius, and input
a figure in the radius box to add some Web 2.0 stylings to your document as shown in
Figure 2-32).

We've also added a circle using the Ellipse tool (remember to hold down the Shift key
to keep the ellipse perfectly circular), colored it blue to match the left-hand column, and
positioned it on the right side of the page with a few lines of text.

Figure 2-30. Any element on the page, including shapes, frame backgrounds, and text, can be filled
using the comprehensive fill tools.



CHAPTER 2 DESIGN USING WRITER 69

Figure 2-31. Text inside Drawing objects can have its color edited using the context-sensitive
(right-click) menu and selecting Character » Font Effects.

Figure 2-32. Change the radius of an object’s corners using the Position and Size settings.



70

CHAPTER 2 DESIGN USING WRITER

Arranging the Page

You now have a lot of content on the page, so it’s time to start thinking about how to re-
arrange it all. Because many of the elements on the page have been placed inside frames,
these can be moved, resized, and recolored very quickly; however, you may find that, due
to the way Writer constructs pages, some parts may obscure others. There are two tools
you can use to fix this.

First, you can use the Arrange options to restack page elements, so the parts we want
to see are actually visible. Imagine that as you construct a page, adding frames, pictures,
and illustration objects, you're laying these things one on top of another. The topmost
object will inevitably obscure the parts underneath. This is where choosing Format »
Arrange menu comes into play. This menu contains four entries. Bring to front places the
selected object on top of everything else; Bring forward moves it one level up the layers;
Send to back puts it at the bottom of the stack; and Send backward moves it a single layer
down. These four options are also available by right-clicking the object you want to affect,
and selecting the Arrange menu.

To select an object that is underneath some other object or frame, hold the Alt key as
you click above the object. Shift+Alt+click cycles in the other direction from bottom to top.

The second option that is vital when rearranging things is the Text wrap, which tells
Writer how an object (a frame, a picture, a shape) should interact with everything below it
in the layer stack. There are six basic options here as shown in Figure 2-33.

Figure 2-33. To wrap the text around an object, right-click, select Wrap, and choose one of
the options.
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No wrap puts text before the object and after it, leaving a gap where the object itself
is. This is useful in logical breaks in the text and covers most or all of a column. In our
example, though, it just looks awful (see Figure 2-34).

Figure 2-34. With No Wrap selected, the text will stop at the top of the image and resume at
the bottom. This is useful if an image fills a column completely.

Page Wrap attempts to follow the contours of the object. For example, if a square
shape is placed in the center of a piece of text, the text is knocked out by the object but
still appears on both sides of it, meaning the reader has to leap from one part of a sen-
tence to the next across the shape or image.

Optimal Page Wrap attempts to solve this problem by only wrapping along one edge
of the object as shown in Figure 2-35.

The Through option places the object on top of the text and doesn’t make it wrap at
all. In effect, the object obscures the text as shown in Figure 2-36, so you better make the
object transparent if you want to see the text!

In Background also doesn’t knock out the text, but the object is placed behind the
text as shown in Figure 2-37, like the watermark you created earlier.

n
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Figure 2-35. Page Wrap and Optimal Page Wrap make the text follow the contour of an
object. The latter only wraps around one side of an image.

Figure 2-36. When using the Through option, the object obscures the text.
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Figure 2-37. The In Background option allows the text to run right across the object.

The last option—Contour—is only available by right-clicking and choosing Wrap
» Edit. This gives you the opportunity to configure the text wrap a little more fully, for
example, by specifying how far the text should be away from the object (see Figure 2-38).
On square/rectangular objects, there are options for the Top, Bottom, Left, and Right,
whereas on circular objects, a single value works all the way around.

Figure 2-38. More extensive wrapping options are available via the Wrap » Edit menu.
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Recap

In this chapter, you have designed the first page of a newsletter using a range of design
tools in OO.0 Writer. You've structured the page using an asymmetric, double-column
layout to provide three distinct content areas. These areas were then populated with
frames for text, images, and captions. You also learned about the various ways Writer
can be used to add color, texture, and transparency to a document; how to build a gallery
of reusable images; and how to rearrange objects on the page without losing site of the
content.

The next chapter is once more mostly concerned with text—the raw ingredients of
any document—but you’ll use a range of techniques to automate many of the jobs that
can be really tedious when working on long documents or on many documents that have
a similar structure.

If you want to take the design further and prepare the newsletter project for online
distribution, skip forward to Chapter 7.



CHAPTER 3

Writer Automation

Writer, as we've seen, can be used for a lot of different tasks, but it really comes into
its own when working on long, complex documents such as dissertations, reports, and
even books. These documents have “words” at their heart, and Writer is fundamentally
a word processor designed for the purpose of writing and editing text. Letters can be
written in any old text editor, for example, and high-end DTP software will do a bet-

ter job of dealing with design-intensive documents such as magazines, newspapers,

or posters. But Writer’s main purpose is allowing a user to compose, edit, and orga-
nize words. The elements discussed in Chapters 1 and 2 such as frames, images, and
paragraph formatting feed into this, and an understanding of these processes provides
a good basis for moving onto the options available for automating the organization and
production of a finished document.

The document you’ll be working on in this chapter is a long piece of academic
writing (see Figure 3-1), which will allow you to explore many of the automation and
document management facilities in Writer. And although this is a specific form of writ-
ing, the techniques you’ll be using to create it are equally useful in other tasks, including
letter writing and newsletter design, where consistency is important. For example, in
Chapters 1 and 2, you manually formatted paragraphs and page elements using vari-
ous tools and options. With Writer’s style system, you can take that formatting and turn
it into a “style” that can then be applied across a document, to other documents of the
same type, or, in the case of the newsletter, in future issues. Any word-processing task
that is likely to be repeated can benefit from a little automation.
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Figure 3-1. Writer’s raison d'étre is the production of long and complex documents such as reports,
essays, and dissertations.

The Basic Page

The letter you created in Chapter 1 took you a little way down the road to automation by
starting with a template; in this chapter, you'll create and edit a cascade of styles, using
the information OO.o keeps about the author, setting up styles to make it simple to build
a dynamic table of contents (TOC), and adding references using Writer’s built-in biblio-
graphic database. You'll also start with a much more complicated basic page, so begin
by choosing File » New » Text document and then go into the page formatting section
(Format » Page).

Note The example is based on a single page style, but using the following techniques, you can create
any number of page styles to add more variety to the document. When using multiple page types, use the
Organizer tab to define how one page style might follow another. For example, if you’re working with differ-
ent left- and right-hand styles on your spreads, you'll need to set the Next style (in the Organizer tab) options
to reflect this design.
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Our first stop is the Page tab, where you'll define the page size (A4 again) and set the
margins (see Figure 3-2). Increase the size of the left margin to allow a reviewer or marker
to add comments or other marginalia, and under the Layout settings, change Page layout
to Right and left because you’ll only be printing on one side of the document, and it will
be bound along the left edge. If you were printing on both sides, the logical choice for the
page layout would be Mirrored.

Figure 3-2. You've defined asymmetric margins so a reviewer or marker can write comments
in the left edge.

Margins are an important part of a design and can have a real effect on readability.
For example, very narrow margins make a page look busy and may force the reader to
cover part of the text with their thumbs. Wider margins can look more “luxurious” and
also make the lines of body text narrower, and therefore easier to read, which could help
with navigation through the text.

The next stop in this dialog box is the Header tab (see Figure 3-3). The header is
a piece of information that appears at the top of every page in the project; usually it is
reserved for the document title or author name. Select the Header on button to enable
the rest of the options. Increasing the Left and Right margin sizes actually decreases the
horizontal space for the header as the 0.00cm option matches the borders already set.
The Spacing option defines the gap between the header and the main text; a more spa-
cious gap can look more formal but obviously results in less space for the document text.
Finally, you can fix the height of the header, which is good for consistency, or allow it to
expand or contract depending upon the content. Fix the Height at 0.60cm to mirror the
spacing between the header and text.
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As with the header, you'll also add a footer (under the Footer tab) that will run along
the base of each page. Stick with the same dimensions.

Figure 3-3. The header is a persistent presence along the top of each page in the document.

Finally, for this section, you'll define a space for footnotes. It’s important to define
this space, especially in academic writing because the default is the Not larger than page
area option, which means a long footnote would take up an entire page. By setting a limit
on the size, extra information is flowed to the next page in the footnote space.

In addition to setting the maximum size for a footnote, this tab also has the option
to set the spacing between the text and the footnote, and an option to put a division line
between the two parts (see Figure 3-4). As with the column lines (see Chapter 2), these are
defined as a percentage of the width of the work area and can be aligned to the left, right,
or center of the page.

After this is done, click the OK button to go to the page where you'll see faded margin
lines marking out the content area and the header and footer space.
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Figure 3-4. Add a space for footnotes so that they don’t become too prominent on the page.

Document Properties

In the interests of being well organized, you'll now add details to the document proper-
ties system. This information not only makes it easier to find this particular document (or
documents of this type) but also allows you to make large-scale changes to the document
at a later date. To access this section, choose File » Properties. As with other configura-
tion elements in O0.o, this is a tabbed dialog box.

The General tab provides information such as the document author, the date and
time it was created and last modified, the size of the document in bytes, and the amount
of time spent editing this particular document (a good idea if you are designing a book
and being paid by the hour!). The Author name is taken from O0O.0’s User Data, which is
accessible by choosing Tools » Options, and clicking the User Data entry on the left.

On the Description tab, you can define many elements of the document, such as the
title (often different from the document’s file name), subject, and a series of keywords
(see Figure 3-5). The latter can make finding and organizing multiple documents easier
within your filesystem later on; for example, all documents featuring the keywords “key
indicators” and “2008” could be found more easily with keywords than by having to make
sense of the document contents alone.
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Figure 3-5. Document properties can be used to manage files but are also useful for making
significant changes to some elements of the document.

The Comments field can, again, be used to add information useful for searching
and classifying the document without having to read the entire thing. For example, in
academic writing, it might contain the abstract, and in business, it could be an executive
summary of main points or even just a list of things needed to finish the project.

The User Defined tab is especially useful because it allows you to create four new
classes of data, which can be assigned a field name (see Figure 3-6). Fields can be entered
into the document, and then every instance of that piece of information can be edited
simply by altering one text element at a later date. Add two pieces of information in the
fields labeled Info 1 and Info 2 by simply typing the information in the text areas in the
dialog box. This method could be used to edit, for instance, the lead character in a novel
or a location in a play; in this example, you're going to insert a publication name and an
academic supervisor. Before leaving this section, you can make the user-defined informa-
tion a little more meaningful by clicking the Info fields button and giving the two fields
you've created better names so that they're easier to manage later.
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Figure 3-6. Add a few user-defined properties. These can be inserted into the document later.

After all the information has been added, click the OK button.

The last part of setting up your page is to add a few details to the header section of
the document. You could simply click anywhere in the header and begin typing away,
but you can also be a little more sophisticated than that. You’ll begin by adding the
document title (which you’ve just defined) by clicking in the header, choosing Insert »
Fields » Title, and then aligning this to the right of the page by clicking the right align
button in the Formatting toolbar. To format this using the Styles and Formatting palette,
select Special Styles from the drop-down list at the bottom of the palette, and then edit
the Header style.

The second element to go in the header is the author name, which you can add by
choosing Insert » Fields » Author (see Figure 3-7). This data will be added immediately
to the right of the document title. Click in between the title and author name, and press
Tab twice, forcing the title all the way over to the left, while retaining the right alignment
for the author name. Now format the header text with the desired font and font size, and
you can move on to actually editing text.
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Figure 3-7. Document variables are inserted into the text using the Insert» Fields menu entry.

Adding Style

At this point in the example, the text is written, so you can run the spell checker (Tools »
Spellcheck, or F7), and you're ready to start formatting. During this stage in the editing
process, it’s important to start on an even footing, so select the entire document (Ctrl+A),
and select Clear formatting in the style drop-down list on the Formatting toolbar.

To begin exploring text styles, you'll use the predefined styles in the palette, so major
headings will be styled with Heading 1 and subheadings with Heading 2, and then you'll
edit those style individually to conform to the eventual look of the document.

Every single style element is available using this method of document construction.
So, for example, you can ensure that each major section of the document begins on a new
page. Right-click Heading 1, select Modify, and click the Text Flow tab (see Figure 3-8).
In the Break section—which we previously ignored—click the Insert button to enable the
various options, and make sure the drop-down selectors are set to insert a page break in
the Before position.
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Figure 3-8. Edit existing text styles by right-clicking the name in the Styles and Formatting
palette (Format » Styles and Formatting).

Click OK, and, then as you scroll through the text, you’ll notice that each section—
we defined this with the Heading 1 style—now starts on a new page.

Next you'll create a base paragraph style for the majority of the document by for-
matting a single paragraph in the desired way. So highlight the first real paragraph of
the document, and choose Format » Paragraph. There’s a lot to do in here, so we’ll go
through the important tabs in turn.

Indents & Spacing. We looked briefly at this tab in Chapter 1, but this is where you can
set left, right, and first-line indents for the paragraph and also set how much space
appears between the end of one paragraph and the start of the next. You can also set the
line spacing, so select Double, which is standard for this kind of document. Set the first-
line indent to 0.50cm.

Alignment. Text can be either aligned left, aligned right, or justified, which means the
software introduces tiny space changes into the text to line up the left and right edges of
the text to the margins. The jury is still out on whether justified text is easier to read or
whether it makes for a better-looking document, so this choice comes down to personal
preference. For this example project, use the justified option, which bring a few more ele-
ments into play. Most significantly, you can define how the last line of a paragraph falls,
with options to set it left, centered, or right. Left is the most common option. Selecting
Justified for the last line means that, regardless of length, it will be forced to align to both
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edges—via a process called forced justification—which can introduce large gaps. The
other option is to select whether a single word should be justified. The Text-to-Text
setting is used to define how Writer will deal with two pieces of text with different font
sizes on different lines. Ordinarily it would align to the baseline (the imaginary line where
the bottom of the text sits) but can also be set to align to the top, middle, or bottom of the
two elements.

Text Flow. This section can have a big impact on the readability of your text. The Hyphen-
ation options allow you to stop words from being hyphenated at all (the default) or set the
minimum number of letters that should appear at the start or end of a line and the maxi-
mum number of hyphens that can appear in sequence (see Figure 3-9). As a rule, a higher
number is good for the first few options and a lower number is better for the latter.

Figure 3-9. Configure hyphens, widows, and orphans using the Text Flow tab. This can
make quite a difference to the look of a document.

You can safely ignore the Breaks section for now (although we’ll return to it shortly) and
move on to the Options section. Selecting Do not split paragraph means that any para-
graph formatted with this style will not ever split over a page break; this is useful for some
paragraph types—headline, for example—but not for a body text format.
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Keep with next paragraph is also useful for headlines because it ensures that the head-
line doesn’t appear at the bottom of a page with no text beneath it. Finally the widow
and orphan control can prevent a paragraph from starting on the last line of a page or
column (a widow) or ending on the first line (an orphan) with options for setting the
number of lines that should always start or end a page. For instance, if the Widow value
is set to 2 lines, a paragraph that falls on the base of a page with a single line is shifted
to the next page. A similar situation with an orphan causes a line to be taken from the
preceding page and placed at the top of the next so there is a complete line before the
last line of the paragraph. For clarity, widow and orphan control is always desirable (see
Figures 3-10 and 3-11).

Figure 3-10. Orphans, where a paragraph ends on the top line of a new page or column, can make
a document look unprofessional.
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Figure 3-11. A widow is when a new paragraph starts on the last line of a column or page. The Text
Flow options can be used to control these.

Tabs. Tabs are something of a holdover from the old world of manual typewriters, and
with sensible use of first-line indents, they should be largely unnecessary, but it's worth
knowing how to set them in case you need to line up a few columns of data and don’t
want to create a table or embed a spreadsheet. To match the first-line indent created ear-
lier, add a tab position at 0.50cm by editing the Position element on the left. You'll return
for more extensive tabs editing shortly.

So now you have a formatted paragraph that you can use as the basis for a first style.
To do this, open the Styles and Formatting palette by either pressing the F11 key or
choosing Format » Styles and Formatting, and then highlight the first paragraph. Across
the top of the Styles and Formatting palette, a range of icons appear that show (from left
to right) paragraph, character, frame, page, and list styles. Select the first icon to display
the list of premade styles (see Figure 3-12).
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Figure 3-12. Styles can be created from text formatted on the page or from scratch.

Double-clicking one of these styles applies that style to the selected paragraph, so
you don’t want to do that. Instead, click the icon on the far right, select Create new style
from selection, input a name (for this example, “Body text”), and click OK.

Tip New styles can be created from scratch by right-clicking anywhere in the Styles and Formatting
palette and selecting New.

The new style is appended to the list and becomes selectable. Because this will be the
most commonly used style, apply it to the entire document by pressing Ctrl+A to select
all, and then double-clicking the new style.

Obviously, this is not the look we want (see Figure 3-13). For example, it’'s common
practice when creating a long document with a first-line indent on paragraphs to have
no indent on the first paragraph after a heading or subheading, so we need to add some
variety.
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Figure 3-13. Before: The first paragraph after the heading has the same formatting as each other
paragraph.

The logical thing to do is to adjust the formatting of a first paragraph and then create
a new style from that, but there is an even more efficient way to achieve the same results.
In the Styles and Formatting palette, right-click the Body text style, and select New. This
clones the original style, gets it ready for a slight bit of editing, and launches the Para-
graph style dialog box. In the Organizer tab, provide a new name for the style (for the sake
of simplicity, it’s best to name this style something related to the original so it appears
next to it in the palette), and ensure that both Next Style and Linked with are configured
with Body text. The former option means that if you write a paragraph using this style
(called Body text first paragraph) and press the Enter key to start a new paragraph, the
Body text paragraph is automatically selected. The latter option is very important because
it allows you to cascade the style.
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AutoUpdate, accessible from the Organizer tab, is also an important option to be
aware of because it can lead to some confusion if you don’t understand how it works.
Ordinarily, changes to a style have to be made by selecting it in the palette and clicking
the Modify option. However, with AutoUpdate on, any changes made to any paragraph
configured with that style are automatically propagated across every other instance of
the style.

Next, move onto the Indents and Spacing tab, and remove the first-line indent.
This means that the style you're working on now is exactly the same as Body text,
except it doesn’t have the first-line indent. Go back to the Organizer tab to see a list of
the unique elements of this style. Now click OK to add the new style to the list, highlight
the first paragraph of the text, and select the style (see Figures 3-14, 3-15, and 3-16). The
result should be a piece of text exactly the same as the second paragraph, but with no
first-line indent.
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Figure 3-14. After: Having made a few changes to the style (see Figures 3-15 and 3-16), you now have

a first paragraph that looks slightly different.
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Figure 3-15. The long-form definition of the style takes up the lower part of the Organizer
tab. This covers every element of the text from the font size and alignment to the justifica-
tion and line spacing.

Figure 3-16. In contrast to Figure 3-15, this definition is very short. Because it is linked with
Body text, it only needs to control the elements that are different.



CHAPTER 3 WRITER AUTOMATION

Now create a third style based on the first one for quotations (single line spacing and
left/right indent of 0.50, to match the first-line indent of the Body text style), and save
that too. To apply the style, click into the paragraph that needs styling, and click on the
appropriate style. When working on long documents, this select-then-click routine can
get a bit tedious, but fortunately Writer has a Format Painter option. Simply choose the
second from right icon at the top of the Styles and Formatting palette (the tool tip will say
Fill format mode when the mouse is hovered over it), select the appropriate styles (see
Figure 3-17), and then click each paragraph in the document that should be formatted in
that way.

Figure 3-17. The Styles and Formatting palette can be altered to reflect the type of editing
being carried out.

It’s also possible to define a keyboard shortcut to apply a style. Choose Tools »
Customize, and select the Keyboard tab. Find an empty key combination in the top part
of the dialog box, select it, and define the Category (Styles » Paragraph Styles) and Func-
tion (Body text first paragraph) before clicking the Modify button and binding the style to
the key combination. Now you can click into a paragraph, use the shortcut, and the for-
mat will be applied. It’s probably wise to limit this method to a few very commonly used
styles; otherwise, you may end up getting lost in all the combinations.

With the entire text formatted, there’s a slight problem with the spacing of the quota-
tion body text; where the single line spacing of the quotation text meets the double line
spacing of the body text, there is quite a tight space. You can fix this by right-clicking the
quotation style in the Styles and Formatting palette, selecting Modify from the menu,
adding a little space (say, 0.50cm) in the Below paragraph section, and clicking OK. This
is where styles really show their time-saving nature because every paragraph formatted
with the Quotation body text style will now be altered to reflect the change, saving you
the work of going through the document and changing every instance.
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Note The benefits of using the tools available to manage styles and formatting in Writer, and indeed the
rest of the suite, can’t be overstated. A document created on these principles will be easier to manage and
edit and will look more consistent, and thus professional, allowing you more time to concentrate on the dif-
ficult job of writing engaging or informative text, rather than worrying if the subheadings are all the same
size. Although style definition may seem to be one of the more boring aspects of document design, it not only
makes your final output (all your final output if the styles get reused in templates) look better but can also
save serious time in the future. For example, combine a document with ready-defined styles and the tem-
plates method discussed in Chapter 1, and you start the document creation process with all the tedious stuff
already done!

Cascading Styles

At the beginning of this section of styles, you created a style called Body text and then
added two more styles that were based on this. Having finished the main text for the doc-
ument, now let’s change the Times New Roman base font, which looks a little formal, to
something that gives the essay a touch of modernity. You could select the entire text and
change the typeface to Arial (or something similar) but that will obviously change head-
ings and subheadings too.

The smart way to do this is to right-click the Body text style, select Modify, adjust the
typeface using the Font tab—change font, size, color (under Font Effects)—then click the
OK button, and watch as the paragraphs formatted with this styled are instantly reformat-
ted. The real magic, though, is that the styles based on this style will also be updated to
reflect the change. So with just a few clicks, you've edited three individual styles without
messing up any of the headings.

All headings, meanwhile, are based on the style labeled Heading, so changing the
font in that will change the font in all your headings. Smart.

In addition to paragraph styles, you can also create character styles in the same
way, and these differ by only affecting the selected text, whereas paragraph styles will
affect the entire paragraph. For example, it is common practice to present publication
names in italics, so you can find a piece of text, italicize it using the Italic button on
the Formatting toolbar, and then select the Character Styles button (second left) in the
Styles and Formatting palette. Now you can use the icon on the far right to create a New
style from selection, give it a name, and click OK. Navigate to the next publication name,
highlight it, and click the appropriate style in the palette. As with the Paragraph styles,
this seems like quite a long-winded way to make a small change, but it will pay divi-
dends later on. Promise!
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Note Deleting the premade styles included in 00.0 is hopelessly complicated, so we’re not going to
bother doing it. It's much better to adapt available styles to your needs than start digging around in configu-
ration files. User styles, however, can be deleted by right-clicking the style and selecting the Delete option.

If you've created a complete set of styles and don’t want to be swamped with standard styles, use the
drop-down menu at the bottom of the Styles and Formatting palette to select Custom Styles. To get back to
the original list, choose Automatic.

Table Making

Occasionally a document will feature some kind of data that would be most appropriately
presented in a table—sales figures, projected growth, and so on—and Writer has a useful
selection of table-editing tools that can do quite a lot before you have to migrate to the
Calc spreadsheet. Tables are covered in more detail later—skip ahead if you have an insa-
tiable desire or pressing need to organize tabulated data—but for now, let’s look at the
three most common ways of inserting a table into a document.

Method one is essentially the same as inserting a frame or image, except we choose
Table » Insert to launch the configuration dialog box (see Figure 3-18). In this dialog
box, you can define the number of column (horizontal) and row (vertical) elements in
the table and insert a header for the table that can contain labels for the columns. If the
Header option is selected, a new button is enabled that will add an extra header section at
the top of a page should the table span two pages. By default, the table takes up the entire
width of the page, frame, or column into which it is inserted; the columns are equally
spaced, and the rows expand to accommodate the information put into them. Selecting
Don’t split table makes sure the entire production appears on a single page. The Border
check box puts solid division lines between each cell.

If you're feeling particularly pushed for time, a number of predesigned table styles
are available via the AutoFormat button with good options to match most color schemes.
The AutoFormat options are actually a good place to start if you want to go beyond simple
white backgrounds and black lines. You can also create an AutoFormat based on a table
design you've created. After a table has been formatted, choose Table » AutoFormat and
select the Add button. Provide a name for the creation, and it will be added to the list of
available designs. This can be used to ensure that all tables in a single document or series
are consistently formatted.

The second way to add a table is also the quickest. Select the drop-down arrow to
the immediate right of the Table button on the standard toolbar, and drag the mouse to
define the number of columns and rows needed (see Figure 3-19). Once clicked, a table
with those dimensions will be inserted into the document at the cursor point and will
range right across the available space.
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Figure 3-18. Insert a table into a document with Table » Insert, and then define the rows
and columns to be included.

Figure 3-19. Use the dedicated button on the Toolbar to quickly add a table to a document.
Use the visual representation to define the number of rows and columns.
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BASIC TABLE FORMATTING

Clicking anywhere in a table causes the Table editing toolbox (a floating toolbar that can be anchored to
any part of the Writer window) to appear. We’ll look at most of the options in here later, but for now, we
just want to add a hint of color to the header of the table so it’s obviously not part of the data.

One important point to remember is that edits made in this toolbox will affect the cell, row, or
column that the cursor is in. So to change the color of the header, you need to click into the leftmost
column and drag across the rest of the header row. This selects just that row (you can also hover the
mouse close to the far left or right border so it becomes an arrow and just click), and then you can add
a background color by opening the chooser (the fifth icon on the top row) and picking a color. Each of
the highlighted cells assumes that color.

The third and final method—the one you’ll use in this example—is especially good
when the data is already present in a document. For example, you have a set of statistics
that are arranged in the following manner:
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Firefox [tab] Konqueror [tab] Opera [tab] Internet Explorer
Gecko [tab] WebKit [tab] Presto [tab] Trident3.0 [tab] 4.1 [tab] 9.5 [tab] 8.0

and so on. This is known as tab-delimited data because the tab key marks one element
out from the next. Turning this kind of data into a table involves highlighting all of the
parts with the mouse and choosing Table » Convert » Text to Table. This launches a dia-
log box with the same options as previously mentioned but with the addition of a section
where you can set the delimiting character (see Figure 3-20). This has various options,
such as Tabs, Paragraph (Enter key), Semicolons, and Other, where you can input any
textual element as a delimiter, which means you can deal with just about any kind of
data. In this case, selecting the Header element turns the first line of the data into column
headers. AutoFormat is also available here.

Figure 3-20. Tab-delimited text can be added to a document as a table with the Table »
Convert» Text to Table option.

Footnotes and Endnotes

Many types of writing rely on notes to clarify a point, to offer supplementary information
that might look out of place in the body text, or even just to give the reader a web address
without disrupting the flow of text. There are two main methods of adding these notes—
footnotes, which go at the base of the page the anchor is on, and endnotes, which are
positioned at the end of the text—and Writer is happy with either. Of course, you can
make your own frames at the bottom of pages for footnotes or type endnotes manually,
but this goes against our “let the computer do the difficult stuff” mantra. By allowing
Writer to organize the notes, you won't have to worry about ensuring frames stay with
their corresponding note numbers, or that the numbers themselves become jumbled up
during the editing phase.
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To add a footnote or an endnote to a piece of text, click the point where the
anchor needs to go (i.e., the text being “footnoted”), and select Insert » Footnote.
This launches a small dialog box that allows you to define how the note is anchored
to the text and whether you're using a footnote or an endnote (see Figure 3-21). Choose
Automatic to have a number assigned to the note and anchor, or choose Character to
use some other device such as an asterisk. If you opt for Automatic, Writer will also
deal with the numerical order of the notes. The Character option allows you to define
an anchor character to the text, which is referenced in the footnote. For example, the
first note might have an asterisk (*), the second might have a dagger (1), and the third
a double-dagger ().

Figure 3-21. Footnotes sit at the bottom of the page, which contains the anchor text, whereas
endnotes are positioned at the end of the main text.
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Click OK to add the anchor to the text, create a box ready for the footnote/endnote
in the appropriate place, and insert the cursor ready for writing. Note that there is a pre-
defined style for Footnotes in Styles and Formatting, which is automatically applied to
the text in the footnote. This means you can nip in and edit the format by opening the
Styles and Formatting palette, right-clicking Footnote » Modify, and then refining the
style to fit the rest of the document.

Note If you use a lot of footnotes, it could be worthwhile to add the Insert Footnote Directly (or Insert
Endnote Directly) button to the standard toolbar because this will provide one-click note entry. Select Tools »
Customize » Toolbars. Select the standard toolbar, click Add, and look under the Insert category for the
appropriate entry (see Figure 3-22). Click Add again, then click Close, and the icon will be added to the tool-
bar. Now when you want to add a note, click the icon and begin typing.

Figure 3-22. Add a button to the toolbar and make inserting footnotes a one-click process.
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After the note has been added, however, mouse over the anchor to see a tool tip of
the note (see Figure 3-23), or click the anchor to go straight to the content—especially
useful for endnotes—and edit as normal, and then click the anchor in the note itself to
go back to the original place. You can also edit the note type by clicking just ahead of the
anchor in the text and choosing Edit » Footnote. In this way, you can turn a footnote into
an endnote and vice versa.

Figure 3-23. Hover over an anchor to see the contents of a footnote.

Text Automation

Writer has a few options available for the automatic input of textual elements. We already
looked briefly at some page variables earlier when defining the page settings—we’ll go
through a few more soon—but there are also AutoText and AutoCorrect. The former
allows you to automate the insertion of text, images, and other content, whereas the latter
monitors your efforts at typing and tries to make everything a bit easier.

Let’s begin by adding the most commonly used page variable—the page number—
while taking a broad overview of the available options. The page numbers are going to
be in the page footer and aligned on the right, so click in the footer area of any page,
click the right align button on the Formatting toolbar, and define the font. Remember,
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good-looking documents usually don’t have more than two fonts, so stick with the same
one used in the header area. Now choose Insert » Fields » Page number to add the page
number to the footer. Note that any text inserted before or after the page number vari-
able will appear in that position on each page, which makes it possible to add some text
(Page 1) or visual flourishes (-1-). In some business reports, it might also be useful to

let the audience know how many pages they have to read, so the page number section
might read Page (Page number) of (Page count), where Page count is another variable
accessible from the Insert » Field menu (see Figure 3-24). Because these are variables
based on the document structure itself, it will always be completely accurate.

Figure 3-24. Page numbers are one of the most commonly used variables in any word
processor.

You can also add the publication data you defined right at the beginning of the docu-
ment by clicking to the left of the page number, choosing Insert » Fields » Other, and
expanding the Custom menu using the disclosure (+) icon. Under here we find the User
Generated fields created when editing the document properties. Select Publication name,
and click Insert (see Figure 3-25). Again, two presses of the tab key shifts this variable to
the left of the page.
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Figure 3-25. Inserting one of the variables created earlier

With these variables now set, you can quickly change the title of the document, the
author, and the publication name by going back into File » Properties and changing the data.

AutoText

In Chapter 2, you built a small gallery of images that can be reused over and over again.
One of the limitations of the gallery concept is that although it’s good for adding graph-
ics and sounds, it doesn’t have the facility to insert snippets of text. Fortunately, this is
exactly what AutoText does. More importantly, you can create a piece of text (complete
with images and tables if necessary) and then turn that into a piece of AutoText with ease.
Let’s start with a simple piece of text.

Throughout this document, the phrase “Estée Lauder/Elizabeth Arden” must be
typed. This is an annoying piece of text because it has a lot of initial capitals, the forward
slash in the center, and that accent over the first lowercase “e.” Start by highlighting the
text string, and then choose Edit » AutoText (or press Ctrl+F3) to open the configuration
dialog box (see Figure 3-26).
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Figure 3-26. Words or phrases that are used often in a document can be added automatically using
the AutoText feature.

Before you build the first entry, let’s look at one of the standard AutoTexts. Click the
disclosure icon (+) next to Standard, scroll down until the Sincerely entry is visible, and
click the Preview check box to see what the actual AutoText content looks like. Select this
to display the structure of the text. Near the top of the window, you’ll see the name of
the AutoText and the keystroke that invokes it—in this case, SI. As with the default styles
mentioned earlier, you can’t edit or delete these, but you can come back to edit user
styles later.

Now, click the minus icon (-) next to Standard, and click the entry labeled My Auto-
Text. The top elements become editable, allowing you to specify a name (which doesn’t
have to be the same as the text string) and shortcut to stand in for the text. Try to think
of something memorable that is at least a little related to the words or phrase to be
replaced—if you spend two minutes trying to remember if the shortcut for Sun Microsys-
tems is SM or SMS, you may as well just type the text! When those elements are defined,
choose AutoText » New, which saves the entry to the system, and then click Close to get
rid of the dialog box.
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Adding a piece of AutoText simply involves typing the shortcut, for example, SI for
Sincerely, and then pressing the F3 key. If you've tried this with Sincerely, you’ll see that
Writer doesn’t just put the text in but also adds a hard return ready for the next piece of
text. Anything that can be added to a Writer document—Ilinks, images, graphics, tables,
and so on—can be enclosed in an AutoText entry. It can even manage variables.

AutoCorrect

A second kind of automatic text entry is the AutoCorrect feature, which automatically
corrects commonly mistyped or misspelled words and does a whole lot more. Access the
dialog box by choosing Tools » AutoCorrect, and feast your eyes on all those tabs (see
Figure 3-27). We’'ll go through them one-by-one.

Figure 3-27. AutoCorrect can replace commonly misspelled words with their correct versions
or long phrases with a few initials.

Replace. This is the most obvious task of AutoCorrect. If you type “becuase” or “drive-
ing,” it will replace them with “because” and “driving,” respectively. It also makes light
work of the copyright symbol—just type (C)—the registered trademark symbol—type
(R)—and decent-looking arrows—type --> or <--. You can also add your own entries, so if
you always spell “Pontefract” wrong, add the incorrect spelling (Pontifract) to the left-side
text area, put the correct spelling in the right area, and click the New button. A new entry
will be added, and next time you're writing about the town in the North West of England,
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Writer will remember the correct spelling so you don’t have to. You can also set these to
automatically add an initial capital letter to city or country names (replace canada with
Canada) or use it as an alternative to the AutoText system (replace MSFT with Microsoft).

Exceptions. Sometime we spell words nontraditionally on purpose, especially when
using abbreviations and acronyms. You might want to write “approx” instead of “approx-
imately,” for example, or you might mention (musical) CDs or OO.o0, and this is where we
can prepare for those times. The latter is important because Writer typically treats words
that have two capital letters at the beginning as a typing error, so common two-letter
acronyms that might have a plural version—the aforementioned CDs—or technical terms
such as MHz will get through the filter.

Options. This is where you can define just how diligent the AutoCorrect tool is at moni-
toring your mistakes. There are two ways to work with this, which are reflected in the two
columns of check boxes. Marking an option in the [M] column means that the option
will be applied to existing text by choosing Format » AutoFormat » Apply (which is
great when importing or pasting text from another document); marking the [T] column
means that text will be corrected as you type. Options here will do things like automati-
cally make the first letter of any sentence a capital and replace a typed web address with
an active, clickable link, but they can also be used for quick formatting because text
enclosed in asterisks (like *this*) will be made bold, and text enclosed in underscores
(_like this_) will be underlined.

Custom Quotes. Content created in a standard text editor may not use proper curly single
or double quote marks. Enabling the options here will ensure your quotes are never
straight, which is regarded as a more professional finish.

Word Completion. This option has the potential for serious time saving but can take
some getting used to and, it has to be said, is more useful to those who stare at the screen
while typing. It’s a little like predictive text on a cell phone. When enabled, you can begin
typing “conn,” and the software will define that you're probably aiming for connection,
which is in the list of words to complete. As you type, the rest of the word will appear

on the line reversed out with a blue background; pressing Enter will complete the word.
Moreover, by clicking the Append space check box, the software will also add a space at
the end of an automatically entered word except—cleverly—if the next character typed is
a punctuation mark. This is one of the options that often throws users and requires a bit
of discipline to be used effectively.

If the Enter key feels wrong for completing the word (it does for many), use the Accept
with drop-down list to select another key such as Tab, Space, or the right cursor key.

You can, of course, turn off completion by deselecting the option at the top of the dialog
box. The options at the bottom allow you to configure the minimum word length to be
completed (autocompleting a three-letter word is a bit pointless) and also the number of
words Writer will add to the list.
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Document Breaks

Although the text in the example document is now looking pretty good, there are a few
important omissions, particularly the title page and contents page, and this presents

a problem. If you were to click at the beginning of the text and add a couple of page
breaks (Insert » Manual Break » Page) that would give you the space needed for these
two important elements, but it would also add the header and footer to both pages
(which you don’t want) and make the main text begin on page 3 instead of page 1.

Styles—this time Page Styles—come to the rescue. Open the Styles and Formatting
palette again, and click the Page Styles icon (fourth from the left). Use the new style icon
on the far right, and select New style from selection to create a new page style based on
the default you created at the start of this project. Give it a name (for this example project,
use the innovative “Standard”), and click OK.

To create a new style, right-click anywhere in the list, and choose New to launch the
normal page definition dialog box. Use the same values and margins as the main page,
but make sure that headers and footers are not enabled. Call this one “Front.” Finally, do
the same thing again, and call the next page style “Contents.”

You now have three page styles, and you're ready to add a new page to the beginning
by choosing Insert » Manual Break and selecting the Page break option (see Figure 3-28).
Under the Style heading, choose Standard—the style the page after the break will adopt—
enable the Change page number check box, and ensure the number below it is set to 1.

Figure 3-28. Force a document to break in a particular place using the Insert » Manual
Break menu.

When you click the OK button, a new page will be added to the document using
the Standard style, but if you look at the footer of the first two pages, you now have two
pages labeled “1.” Not good. However, if you click somewhere inside the new first page
and then double-click the Contents page style, the Header and Footer (along with the
confusing page number) will disappear. You can now do another new page, but this time
choose Contents as the Style, click OK, click inside the first page, and double-click the
First Page style.
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You now have two blank pages ready for new content, and page 1 actually begins on
page 3. For the front page, create a new frame (Insert » Frame), anchor it to the page,
remove the border, and position the frame as a band across the center of the page. Into
this frame, put the document’s title (choose Insert » Field » Title) and, beneath that, the
author name (choose Insert » Field » Author), and then format them appropriately.

You can add a new frame near the bottom and add the Supervisor variable and the
date (choose Insert » Field » Date), and you've created a title page that can be updated
using the document properties quite simply (see Figure 3-29).

Figure 3-29. The cover of this type of document can be created entirely using the Document Proper-
ties set earlier.
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Table of Contents

Now some of the effort made earlier is really going to pay off, and you’ll use Writer’s styles
and formatting system to build and maintain a dynamic table of contents to go near the
front of the document. Again, let the computer do the heavy lifting, which makes sure
that the contents page is always up to date because we don’t have to worry about manu-
ally updating page numbers or chapter, section, and subsection titles.

To begin, click in the page set aside earlier for the contents, and then select Insert »
Indexes and Tables » Indexes and Tables. On the left of this complicated-looking dialog
box is a preview of what the completed contents page should look like (see Figure 3-30). It
has a lot of elements that we won’t be covering for the moment, so we're really concerned
with the text entries at the top.

Figure 3-30. Use Insert » Indexes and Tables to access the table of contents options.

Under Type and title, choose Table of Contents, and provide a title to go at the head
of the list. Ensure Protect against manual changes is selected (make the computer work)
and then deselect Outline in the Create from section. This latter choice is necessary
because when creating the document a few user-defined styles were used in the head-
ings, so you want to be able to define entries using that scheme. Click Additional Styles,
and, for the moment, deselect Index marks. You can now define the structure by clicking
the ellipsis button (...) to the right of Additional Styles.

You now have a list of available styles and a dialog box containing a horizontal ruler
and two arrow boxes at the bottom (see Figure 3-31). This is where you define the structure
with the numbers across the top representing the “levels” in the table of contents. You
move styles to the right level using the arrows. For example, in the example document, the
section headings were styled with Heading 1, so select that, and move it to position 1. The
subheadings are styled with Heading 3, so shift that into position 2. Click OK.
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Figure 3-31. Define the various levels of content using the Assign Styles configuration box.

The Entries tab is already set up for our purposes, so ignore that for the moment, and
move on to the Styles tab. In this tab, you can define all the stylistic elements of the TOC,
and the work is just like editing any other style. The column on the left of the window
shows which styles are associated with each level, and the one on the right shows avail-
able styles (see Figure 3-32). By default, Level 1 is associated with Contents 1, so select
Contents 1 from the right column, and click the Edit button to access the normal styles
definition dialog box. This is the same dialog box you’ve used to define other styles in the
document, so you can edit fonts, spacing, and everything else.

Figure 3-32. Each element of the TOC has its own editable style.
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The table of contents is dynamic, which means we don’t have to edit the table
itself because it will update to reflect changes made to the text (see Figure 3-33). To see
this in action, scroll through the document, and edit one of the section headings. This
automatically makes the table of contents out of date, so go back to the head of the doc-
ument, right-click any part of the TOC text, and select Update Index/Table. The entries
will now reflect the content of the document. The right-click menu also offers access to
the main dialog box (Edit Index/Table) where the levels, styles, and everything else can
be refined (see Figure 3-34).

Figure 3-33. Once created, the TOC is a dynamic object built on the contents of the rest of the
document.
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Figure 3-34. Right-click the TOC to access the Update and Edit options for the page.

Writer can deal with many different styles of TOCs through the Entries tab (see
Figure 3-35). For example, you can set the page numbers to appear first, alter the appear-
ance of the “leader” character that connects an entry to its page number, or even remove
the leader.

Figure 3-35. The Entries tab allows you to make large-scale adjustments to the structure of the table
of contents.
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The Entries tab looks really complicated, but it’s not that bad really. The boxes in the
center of the page define the way that each entry is displayed. To change the structure of
the top-level part of the TOC, select 1 in the Level column, then select each structural ele-
ment (the boxes) in turn, and press Delete. Now click the first empty box, and select the
element name that you want to include first. For example, select Page No to have that as
the first part of the line of text, click in the second box, and select Entry Text to insert the
text that will accompany the page number. A space has been added before the Entry Text
so it’s not too close to the number (see Figure 3-36). The Hyperlink button will add a link
to the page, making it possible to jump straight there by clicking the link.

Figure 3-36. The final result is a TOC with a markedly different visual style.
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Recap

In this chapter, we’ve looked at some of the ways you can automate many of the difficult
jobs that arise when creating complex documents—basically getting the computer to do
the hard work so you don’t have to. You've created styles and substyles enabling you to
make global changes to the look and feel of a document with just a few commands, and
then used these styles as a basis to build a table of contents that can be updated quickly
and without lots of small edits. We’ve also looked at how to automate the management of
staple essay and report elements such as footnotes and endnotes.

The great thing about doing all of this is that it’s really a job that needs to be done
from start to finish only once. As soon as the text is finished, saved, and printed, it would
take just a few minutes of work to remove all of the content of the document and save
the whole thing as a template ready for the next job. All the styles will be saved, as will
the location of variables such as author name and title, meaning the process of setting up
a second essay or report will be done in half the time.

In the next chapter, we’ll rest our literary brain for a moment and adopt a more
numerate outlook as we enter the world of the spreadsheet and OpenOffice.org Calc.
However, if you have a tight deadline, skip ahead to Chapter 10 for more on Writer in an
academic setting with an exploration of the bibliography system built into the software.
And take a look at Chapter 11 to find out about some of the extensions that can make
working with Writer a more fruitful experience.



CHAPTER 4

Spreadsheets with Calc

Although word processing may be regarded as the core application in any office suite
for general users, spreadsheets are starting to find their way into more homes, class-
rooms, and offices as users discover the benefits of organizing data in more useful ways.
And that, in a nutshell, is what a spreadsheet does; it takes pieces of information entered
by either humans or some process and then allows the user to display and interrogate it
to make something meaningful.

In this chapter, you'll use OpenOffice.org’s Calc program to create a couple of simple
projects, including a very basic accounting spreadsheet and a more ambitious home bud-
get system. These two jobs will allow you to explore the most commonly needed tools in
the software to input and arrange information and to create charts that will display this
data in a more visual way.

A spreadsheet is made up of cells (individual units of data) that are arranged into
rows (left to right), columns (top to bottom), and worksheets. A single spreadsheet could
contain main worksheets that are accessible via the tabs at the base of the main window.
The software’s power comes from the fact that you can run an operation such as find-
ing the average value of a range of cells, and then feed this into other operations, and
then on to other operations, and so on. And with this chain of relationships defined, you
can change one of the earlier values (that fed into the first averaging operation) and see
how that small change propagates through the rest of the spreadsheet. For example, in
a household budget, you can see how a change in the monthly cost of gas will affect the
chances of a two-week vacation in France next year (see Figure 4-1); whereas in a busi-
ness account, it allows an accountant to monitor income or model cash flow for the
forthcoming quarter.
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Figure 4-1. Calc is the ideal choice if you need to organize a family’s annual budget, and it costs less
than a “home finance” package.

The Basics

When you select the spreadsheet option from the Start Center or manually launch Calc
from the Start menu, you'll notice the familiar divisions in the interface. Across the top
are the menus, and below that are two toolbars similar to those seen in Writer. Many of
the options available in Calc use elements from the other parts of the suite. For example,
defining the borders of cells uses the same options that you used to add borders to cells
in tables and even in text frames in previous chapters, and the various text options that
appear in Writer are available here as well. One of the major additions in Calc is a third
toolbar called the Formula Bar. This is where formulas can be constructed and where
individual cells are edited. Ordinarily, the Formula Bar has five parts: the name box,
which identifies the currently selected cell; the Function Wizard, which is designed to
make defining functions easier; Cancel and Accept buttons to enact, or not, a function;
and the input line, which can be used to add or edit a function manually.

Dominating the rest of the window is the sheet itself. This is divided into rows, which
are labeled with numbers, and columns, which have alphabetical headers. When navigat-
ing a spreadsheet, it’s vital to remember that cells are always referred to with the column
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value first; that is, F21 signifies the column F and the row 21, whereas Al is the first cell
in the sheet. You can see the reference for any cell by selecting it and looking for the
value on the Formula Bar. If the rows in a sheet go beyond row Z, then it will follow the
sequence AA, AB, AC, AD, and so on. The rows, of course, simply increment normally.
Under this scheme, a spreadsheet can contain thousands of cells.

The most recent version of OpenOffice.org Calc has increased the number of col-
umns available in a spreadsheet from 256 to 1,024, making much larger sets of data, and
thus more complex actions, possible. As mentioned earlier, a single spreadsheet could
contain multiple worksheets, and although these may work as individual datasets, they
are also linked, so you could, for instance, take the data from sheet 3, cell A3 and have
that work in sheet 1, cell F4.

Editing and Selecting

The most basic operations on the spreadsheet are inputting data and selecting cells.

The simplest way to do the former is to click inside a cell and begin typing. As the words
or numbers (spreadsheets don’t have to contain just numbers) appear in the cell, they
also show up in the input bar just above the main window. After text has been added,
deselecting a cell can be accomplished in a few different ways. Clicking into another cell
deselects, as does pressing the Enter key. Tapping Tab moves the cursor onto the next cell
to the right; whereas the up, down, left, and right cursor keys move the cursor one cell in
the appropriate direction.

In Figure 4-2, I've created a short list of names and e-mail addresses in columns with
named headers. I've changed the color of the headers by using the Background color
option on the toolbar. Note that the e-mail addresses have become clickable by default,
meaning if you select one, it will launch your e-mail client ready to send that person
a message.

Selecting cells follows the logic of making selections in most common file managers,
including Windows Explorer.

Select a single cell by clicking it with the mouse or using the Tab and cursor keys. To
add to or edit a cell’s content, either double-click the cell, or select with a single click and
begin typing.

Select multiple adjacent cells by either clicking and dragging the mouse over the
required cells, or by clicking in the first of the selection and then Shift-clicking in the
last. For example, you could select everything between Al and G3 by clicking A1 and
Shift-clicking G3.

Select multiple nonadjacent cells by clicking the first and then Ctrl-clicking each
subsequent cell.

You can also select an entire row (or selection of rows) by clicking the row labels ranged
along the left edge of the window; select a whole column by clicking a column heading at
the top of the window; or select the entire table (useful for making universal changes to font
size) by clicking in the small rectangle where the row and column labels meet.
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Figure 4-2. Cells can be selected by clicking and dragging the mouse over the area to be formatted.

Sorting Data

In our example, data has been entered in quite a haphazard way, which can make it
difficult to find a particular record. Fortunately, you can sort these names and e-mail
addresses into a more orderly list.

Select all of the data in both columns, including the headings in A1 and A2. Now
choose Data » Sort to launch the Sort dialog box. This has three spaces for defining sort
criteria (see Figure 4-3). Click the first drop-down list, which contains entries that refer-
ence the column headers. Calc assumes that the top column content is the header, which
is why it’s important to make sure those parts are selected before sorting. Select Name
from this list, and click OK. The content of the spreadsheet is reordered alphabetically.
Note that if you only select the Name column, only that column will be sorted, meaning
your names and e-mail addresses will no longer correspond. If this happens, choose Edit »
Undo to get back to the original state.
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Figure 4-3. Select each column to be sorted and then choose Data » Sort to define the sort order for
the spreadsheet.

SPREADSHEET OR DATABASE?

Both spreadsheets and databases are designed for organizing and visualizing data, but which should you
use for your project? For those that require complicated financial or numerical sorting, the spreadsheet
is the obvious choice, whereas those managing a lot of variable information (text, lists, images) will find
a database more suitable. In the middle, there are projects such as address books, client lists, and home
inventories that would work well in both. In these cases, scale and requirements should be your guide.

Use a Spreadsheet When

¢ The nonnumerical dataset is going to have less than 50 entries (rows).
e The scope of the information collected has less than 10 elements (columns).

e There are no big image needs.

The collected information doesn’t need to integrate with other applications in the suite.

¢ You're uncomfortable with the perceived “difficulty” of a database.
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Use the Database When

e You're collecting large volumes of data, that is, thousands of cells.
e Multiple users will be entering information.

e The data will be used elsewhere in the suite, for example, in a mail merge.

One useful thing to remember is that it is entirely possible to extract the contents of a spreadsheet
as a CSV file and build a database on that, and that the contents of a database can be loaded into
a spreadsheet.

Create a Spreadsheet

For many users, setting up a complex(ish) spreadsheet can be quite exciting because

the functions often appear to be magic, but actually adding data can be quite tedious.
It’s important, however, to be diligent because you’ll only get out of any piece of soft-
ware what you put in, so for a spreadsheet to provide an accurate view of a person’s or
company’s finances, the right information has to be entered to base that view on. Yes, it
can be boring, but after the data are in there, you can sort things and make charts, which
is exciting. Maybe exciting is the wrong word, but it can be interesting to visualize all
those numbers.

You may also find some templates on the Internet that could save some work, but
even if you find a template that does exactly the job you want, knowing how things hap-
pen inside the cells is very helpful.

Let’s begin by creating and formatting a simple spreadsheet, which can then be used
to examine the chart options in Calc. We’ll then move on to the more ambitious project
that uses functions and sums.

So begin by choosing File » New » Spreadsheet, and add some data similar to
Figure 4-4.

To create the title cell, select everything between C1 and I1, and then choose
Format » Merge Cells. You can then center the title text and format it using the Format-
ting toolbar.
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Figure 4-4. This spreadsheet features a typical array of information such as labels and figures,
though the formatting could do with some work.

The new, more manageable spreadsheet contains sales figures for five stylish prod-
ucts over six years. Before you actually investigate the charts, let’s make this display of
raw data a bit more readable. By default, Calc squashes up cells to get as much onscreen
as possible, but for this example, this is not an issue, so you can create a bit more space
around the data. Select the entire spreadsheet by pressing Ctrl+A, choose Format » Row
» Height, set the height to 1.00cm, and click O