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Introduction

Alias’ Maya 5.0 is an incredibly powerful and deep program. A person could
work for months in the program and then one day accidentally stumble upon

a feature that they had no idea was there. Often people working in Maya
become so focused on one particular area that, if asked to work with a toolset
different to those they are familiar with, they wouldn’t be able to make head or
tail of it. That is where this book comes in.

The purpose of this book is to show, by example, the many different work areas
available in Maya 5.0; after following the examples, you will be able to navigate
comfortably through these. The examples are designed to be open-ended; this
means that the workflow from the tutorials can be applied to more complex

scenes.

Follow along and soon you will have the knowledge to model your own
characters, to light a world you have built, to animate a person talking to

himself, or to do anything else you can imagine.

Jason Patnode
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System Specs

Working in 3D is very demanding on your computer. Being such a robust
package means that Maya has some fairly steep requirements. The

requirements listed below are the minimum needed to use the program.

Maya 5.0 system requirements:

Maya Personal Learning Edition has different requirements:

Windows XP Professional.

Windows 2000 Professional (Service Pack 2 or higher).
SGI IRIX 6.2.15.

RedHat Linux 7.3 or 8.0.

Apple Mac OS X 10.2.4 or higher.

Internet Explorer 4.0 or Netscape 7.0 or higher.
Pentium Il or higher.

AMD Athlon or higher.

512 MB RAM.

Hardware-Accelerated OpenGL graphics card.
CD-ROM Dirive.

3-button mouse with mouse driver software.
450 MB of hard disk space.

Windows XP Professional.

Windows 2000 Professional (Service Pack 2 or higher).
Apple Mac OS X (10.2.4 or 10.2.6).

Internet Explorer 5.0 or Netscape® 6.0 or higher.
Pentium Il or higher.

AMD Athlon or higher.

Macintosh G4.

512 MB RAM.

Hardware-Accelerated OpenGL® graphics card.
CD-ROM Drive.

3-button mouse with mouse driver software.

450 MB of hard disk space.

xiii



SYSTEM SPECS

Maya PLE also has the following difference from the commercial version of the

program:

e A watermark appears in the rendered image.

e You cannot render using the Mental Ray or Maya Vector renderers.

e Rendering is limited to a single CPU.

e Images are limited to 1024 X 768.

e The file format is specific to the PLE version (.mp). You cannot save your

scene as (.ma) or (.mb) files. Particle disk caching is not supported.
Text dump from the Blind Data Editor window is not supported
Exporting skin weight maps and character maps is not supported.
The script editor output section is limited to 75 lines of output.

The script editor > Save Selected menu item has been removed.

Once you begin working with very dense scenes, you will always wish you had

more memory and a faster processor. This is not an area to skim on. Max out

your RAM as soon as possible and get the fastest processor you can.

A good starting system would be:

Xiv

2 GHz Pentium 4.

Macintosh G4.

1024 MB RAM.

120 GB 7200 rpm hard drive dedicated to your art.



Common Hotkeys

Menus:

F2
F3
F4
F5

Tools:

Insert

J

j

Alt+Up arrow
Alt+Down arrow
Alt+Left arrow
Alt+Right arrow

Hotbox:

Spacebar (hold)
Spacebar (release)

File:

Loads Animation menu.
Loads Modeling menu.
Loads Dynamics menu.
Loads Rendering menu.

Pivot point edit mode.
Select tool.

Move tool.

Rotate tool.

Scale tool.

Show manipulators.
Snap rotate.

Snap move.

Move up one pixel.
Move down one pixel.
Move left one pixel.

Move right one pixel.

Decrease manipulator size.

Increase manipulator size.

Show hotbox.
Hide hotbox.

Ctrl+s (or Command+s on the Macintosh)

Edit:

z or Ctrl+z (or Command+z on the Macintosh)

z
[

Saves current scene.

Undo.
Redo.

Undo viewport change.

Xv



COMMON HOTKEYS

] Redo viewport change.
Ctrl+d (or Command+d on the Macintosh) Duplicates selection.
Ctrl+g (or Command+g on the Macintosh) Group selection.

P Parents first selection to second.
P Unparent.

Viewports:

a Frame all in current view.

f  Frame selection in current view.

4 Wireframe mode.

5 Shaded mode.

6 Textured and shaded.

7 Textured and lit.

Display:

Ctrl+h (or Command+h on the Macintosh) Hide selected.
Alt+h Hide unselected.
Ctrl+H (or Command+H on the Macintosh) Show last hidden.

Status line:

Snap to curve.
X Snap to grid.
v Snap to point
F8  Toggle selection masks.
F9  Vertex mask.
F10 Edge mask.
F11 Face mask.
F12 UV mask.

Xvi
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Maya 5 was designed from the ground up for complete customizability. Hotkeys,
hotboxes, and shelves are just some of the functions and options that can be
customized on a per user basis. Be aware that Maya is case sensitive. This really
comes into play when working with hotkeys — for instance, ‘p’ has a different
function than ‘P". The former parents one node to another, the latter will
unparent the nodes. Alias has done a good job making Maya similar across all
platforms. This book is written using the PC keyboard. If you are using a
Macintosh and a tool calls for using either the Ctrl or Insert key then you should
use the Command or Home key respectively.

Figure 1.1 Maya’s default startup window.

To navigate properly in Maya you need a three-button mouse. Holding down
the Alt key press the left mouse button to tumble, the middle mouse button
(MMB) to track, or right mouse button (RMB) to dolly.

Tumble rotates the view around the camera’s center of interest. Track moves the

camera horizontally and vertically in the current view. Dolly moves the camera
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view in and out. The track and
_ . Camera Tools _I

dolly tools will work in most

maximize/minimize the current

window. This allows you to move Azimuth Elevation Tool

windows. If you open a window Tumble Tool

and can't see all of the options, Track Tool m |

try to dolly out some. DD"';." Taol ]

Moving your mouse over a Zaom Toal '

viewport window and quickly

tapping the Spacebar will either Rall Taal |
m
m )

quickly and easily between Yaw-Pitch Toal
viewport windows.

Fly Tool

Figure 1.2 The camera move tools.

Tip: By pressing Alt + Shift while tumbling or tracking, the movement will be
constrained to a single axis. Alt + Ctrl + RMB allows you to draw a marquee and
instantly dolly into or away from the selected area.

The Hotbox

Pressing and holding the Spacebar will bring up the Hotbox window. The
Hotbox contains each of the drop-down menu items available in Maya.
The Hotbox can be customized so that only the menus you use frequently will
show up when you access the tool.

1 To customize the Hotbox, press and hold the Spacebar.

2 Click on the Hotbox Controls menu on the right.

3 Using your left mouse button drag to the option you want to enable or

disable and release.

The Marking Menu

A Marking Menu is another tool that can greatly increase your workflow.

Holding down the RMB while working will bring up the Marking Menu of the



THE FOCAL EASY GUIDE TO MAYA 5

options available at that time. To select an option from a Marking Menu, press
and hold the RMB, highlight the desired tool, and finally release the mouse
button. To select an option from a Marking Menu that is accessed through

the Hotbox, click it with the left mouse button and release. It may seem a bit

awkward at first, but soon you will be able to zip through the different options.

1 To assign a marking menu to a hotbox area and mouse button, go to
Window > Settings/ Preferences > Marking Menus to bring up the

main marking menu window.

2 Select Create New Marking Menu. This will display a marking menu
popup window. Enter EasyMaya as the name in this new window.

3 Using the MMB, drag the icon of the polygonal sphere from the Polygons
shelf onto the uppermost left square in your new marking menu.

4 Click Save and close the marking menu popup window.

5  You will now be in the main marking menu window again. Make sure

Use Marking Menu In is set to Hotbox.

6  Set the Hotbox Region to West. The Hotbox is organized like the points
on a compass: North is up, South is down, East is right, and West is to
the left.

7 Set the Mouse Button to Left and Middle.

8 Click Apply Settings and close.

Go to a viewport in Maya and press the Spacebar. Now if you move your
mouse to the left of the Hotbox and press the left mouse button, your new
marking menu will appear. Click and drag up to the Polygonal Sphere option

and release. A new sphere will appear in your scene.

The Title Bar

The title bar displays which version of Maya you are using as well as the name
of the current scene. If the scene does not have a name it will be listed as
\untitled. The title bar also displays the path for the current scene you are
working on.
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The Status Line

The Status Line contains shortcut icons to many of the more commonly used
Maya tools.

Tl RR|Z+L2efly07 BR|([ME"DC|acZ|ESEE|w]  REE
Figure 1.3 The status line.

Construction History allows you to undo operations. Each operation you perform
on an object is added to its history. When you are happy with the current state
of an object, you can delete its history by going to Edit > Delete by Type >
History. The selection masks allow you to set node types to non-selectable. This
can be very useful if you have a dense scene and need to drag select only
specific object types. The snap tools allow you to snap the current object to the
specified snap type: grid, curve, or point. The Render Current Frame and IPR
(Interactive Photorealistic Rendering) buttons on the Status Line will quickly
become two of the most commonly used tools. These shortcuts will render the

current frame based on the values set in the Render Globals into a new window.

" Render Yiew ' -|0O] x|
IFiIe Miew Render IPR Options Display Help

RN JORETE S ¢

size: 320 240 zoom: 0.483 (Maya Software)

Figure 1.4 Render current frame window.

The IPR has the added benefit of constantly updating as you work. For
instance, if you change a texture while the IPR is open, it will automatically
re-render the change.
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The shelf tabs allow you to create customized toolsets. The icons in the shelves
are shortcuts to various tools. To add a button to your shelf, press Ctrl + Shift
and click on the desired tool in the drop-down menus. A shortcut will appear in
your current shelf. If you change the shelves, remember to click the arrow on
the left-hand side of the shelf bar and select Save All Shelves.

The Menus

The Menu bar displays the drop-down menus available for the current menu
set you are working in. In addition to the unique tools available while working
within a specific menu set, there are six drop-down lists common to each menu
set (File, Edit, Modify, Create, Display and Window).

File — Contains options to load/save scenes and set your project information.
Edit — Contains Undo/Redo functions and object duplication and manipulation.
Modify — Deals with node transform information and conversion.

Create — Contains creation controls for primitives, lights and cameras.

Display — Is where you can set your Maya HUD (Heads Up Display) options.

Window - Is the menu to access various work areas in Maya.

Each drop-down menu is organized into different sub-groups that have
different themes associated with them. This lets you know right away what type
of function you can expect from a particular tool. Many tools have adjustable
options designated by 3. If you need to change the options for a particular
tool, navigate to and click on the 3 next to it. If you are happy with the tool
settings, simply click on the name of the tool and it will apply the most recently
used settings. Many menus can also be made to float on top of your work area.
Floating windows are designated with a double line known as the tear-off line.

To tear off a menu, simply select the double line.

Working with Projects

The first thing you want to do when you begin work on a new project is create

a project directory. This directory will house all files to be used for your current
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project. When you begin work on a different project, you can create a new

project directory.

Hint: If you are using a Windows-based system, avoid creating projects in the My
Documents folder. Maya won't be able to find your textures and references if you
copy your work to a different computer.

When you open or save a scene or import or export a file, it points to the
Scenes folder that is set in your current project. If you need to change to a
different project use File > Project > Set and point to the new project.

Let's create a project to hold all of the scenes you'll be creating from the

tutorials within this book.

1 Go to File > Project > New to bring up a blank Project window.

2  Click on the Use Defaults button. Unless there are specific needs for the
project you are working on, | suggest that upon creation you select the
Use Defaults option. This will place all of the project folders in their
proper paths.

3  Type Easy Maya in the Name box.
4  For the Location, browse to your C:\ drive.

5 Click Accept.

Il New Project i =III:II X'C.I

Mame |New_F'ru:uieu:t

Location |E:"-.JasunHFncaIHFDcal_chapters

|_I|5tiiene File Locations ﬂ

IEPmiect Data Locations

IB Data Transfer Locations LI
Accept i Uze Defaults Cancel I

Figure 1.5 The Project window.
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You now have a project folder for all of the tutorials you'll be working through.
If you go to your C:\ drive you will see a folder named Easy Maya. The Easy

Maya project will now open each time you start Maya 5.

The File Menu

There are a few items to take special note of in the File menu. Optimize Scene
Size allows you to automatically remove unused data from your scene to reduce
the size of the Maya file. Be wary, though, because Optimize Scene Size is not
undoable. Import allows you to import data from another file. You can import

an entire Maya scene or one of the many other available file types. Export and

Export Selection allow you to export your scene in a different format. You can

also export animation curves into a separate file.

The Edit Menu Edit
Undo
The Edit menu contains undo and redo Reta
) ; o . Repeat "Mew,.."
functions and commands. It is split into six R cenEEamrarts,
areas: undo/redo, keys, delete nodes, i
selection, duplication, grouping, and Capy
. Paste
parenting.
Keys »
Undo and redo perform as they would in any n
elete
other program. You can undo as many times as Delete by Type v
. 3
you have set in your Maya preferences. To set the reenl e
number of undo levels select Window > sl sl
. Select Hierarchy
Settings/ Preferences > Preferences and go to Tnvert Selection
the Undo category. A large Queue Size will slow Select 4l by Type 4
, . . ick Select Set ’
Maya'’s performance, so | wouldn't set it to QL!'C S
Paint Selection Tool o
infinite. | like to set mine to Finite 200.
Duplicate m |
. Duplicate with Transfarm
The Keys sub-group allows you to perform various :
. . o o]
edit functions on animation keys. Many of the E'C'”P 5
. . ngroup
options in the Keys sub-group work the same as Leveler oot ’
their geometry-based equivalent. You can delete e o
a key or copy a key from one place in the Unparent o

timeline, go to a different frame and paste the key

Figure 1.6 The Edit menu.
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into the new time. Scale Keys allows you to change the duration for a range
of keys. You can use the Scale Keys options to also change the start and end
times of your animation. Bake Simulation is used to convert the selected
simulation into keyframes. Once the simulation is baked into keyframes you
can edit the curves as you would any other animation. This is very useful if you
want to use dynamics in a game because most engines will only recognize
keyframe animation so you will have to convert the simulation before it can

be used.

Quick Select Sets are a handy way to easily pick objects and/or components
(vertices, edges, and faces, etc.) that you select regularly. Follow the steps
below to create a Quick Select Set.

1 Select the objects or components you wish to have in your Quick
Selection Set.

2 Choose Create > Sets > Quick Select Set.

3  Type a name for your Quick Select Set. This name will be saved as part

of your scene file.

When you need to pick this Quick Select Set, go to Edit > Quick Select Sets and

choose the name of the desired set.

The Paint Selection tool lets you pick an object’s components by painting them.
This makes component selection very intuitive.
1 Create a new scene by going to File > New Scene.

2 Create a Polygon Plane. Create > Polygon Primitives > Plane > .
Set the Width and Height to 20 and the width and height subdivisions
to 40.

3 Click Create.

4  With the plane still selected, right mouse click on the plane to bring up
the Marking Menu and select Vertex.

5 Choose Edit > Paint Selection Tool > 3.



THE FOCAL EASY GUIDE TO MAYA 5

6 When the options come up for the Paint Selection Tool, set the Radius
(U) to .5 and leave everything else at the default.

7 Paint your initials on the object to select the components.

Figure 1.7 Painted initials.

The Paint Selection tool makes picking a complex layout of components very
easy. Once you are happy with the paint selection you have made, you can add
it to a Quick Select Set.

Tip: Many functions in Maya can be used with a drawing tablet. If you have a tablet
available, it can make working with the Maya paint tools much easier.

The Modify Menu

The Modify menu is used for object manipulation and conversion. It is split into six
parts: transforms, node evaluation, miscellaneous, attribute, conversion, and paint.

The transformation sub-menu contains the functions needed to move, rotate,

and scale your objects.

10
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Transformation Tools

Figure 1.8 The transform tools.

Figure 1.9 Tools in
the Tool Box.

In addition to access through the drop-down menu and hotkeys, the move,
rotate, and scale tools have permanent buttons in the Tool Box.

By picking one of the transform tools, a manipulator will appear for the selection.

Figure 1.10 The move, rotate, and scale transform manipulators.

The manipulator handles are color-coded to correspond to the X, Y, and Z axes.
Red represents X, green is for the Y axis, and blue corresponds to Z. When using a
manipulator, the handle of the selected axis will become yellow indicating that it is
currently active. When you click on a tool in the Tool Box, it uses the current
settings for that particular tool. To bring up the options for a particular tool, you
can either double click on an icon in the Tool Box to bring up the Attribute Editor
or press and hold the keyboard hotkey while pressing the left mouse button to
display a Marking Menu of the available options.
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To use the Move tool, select and drag an arrow on the manipulator to move
along a specific axis. To move freely, click the yellow square at the center of the
manipulator and drag across the view plane. There are several coordinates
systems you can use to move your selections in Maya. The default coordinate
system is World. When World is selected, the object is set to move along the
world axes. Selecting Object will move your selection in object space. Local will
align the object to match the parent object’s rotation. The Normal option allows
you to move control vertices on a NURBS surface in the U and V directions.

To use the Rotate tool, select and drag a ring on the manipulator to rotate around
a specific axis. To rotate freely, select and drag the imaginary sphere centered in
the rotate manipulator. Click and drag the outermost ring to rotate your object
around the view axis. To rotate an object on its local coordinates, select the Local
radial button. If you select the Global swatch, objects will rotate around the world

space. The Gimbal option will only allow one channel to be rotated at a time.

To scale an object, select and drag a box on the manipulator to scale along
a specific axis. To uniformly scale your object, click the yellow cube at the
center of the manipulator and drag across the view plane.

Freezing the transformations sets the current transform information on the

selected objects as the new zero. To freeze transformations on the selected

Figure 1.11 Before and after Freeze Transformations.

12
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objects, go to Modify > Freeze Transformations. Whenever you move, rotate or
scale an object, Maya calculates the new information starting from zero.

To reset the selected objects back to their zero state, select Modify > Reset
Transformations.

Make Live is a tool that forces curves to snap onto the selected surface. Go to
Modify > Make Live to make a surface live. When an object is live it will draw
as a green wireframe in the viewport. Select Modify > Make Not Live to turn
this function off.

Try making a sphere live.
1  Click on Create > NURBS Primitives > Sphere.
2  Select the plane and go to Modify > Make Live.

3 Select Create > Pencil Curve Tool and draw over the sphere.

Figure 1.12 Live sphere.

Notice how the curve draws directly onto the Live sphere. Making an object
Live allows you to easily trim surfaces or paint directly onto an object using
Paint Effects.

13
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To center the pivot of an object go to Modify > Center Pivot. To freely move an
object's pivot point, press the Insert key to go into pivot point edit mode. Now
the pivot point is unlocked and can be moved to the desired spot without
affecting the object itself. When done, press the Insert key a second time to

return to normal mode.

The Convert sub-menu allows you to convert from one modeling format to another.
For example, if you created a character using NURBS and later decided it needed
to be polygonal, you would go to Modify > Convert > NURBS to Polygons. Being
able to convert an object can be really handy for game production. You can use
SubD or NURBS models for your hi-res cutscenes and later convert these to
polygons for the in-game work. In the options window for the tools, you can even
set the maximum amount of polygons that can be used during the conversion, thus
ensuring you won't go over your limits of your game engine.

The Create Menu

The Create menu is where you create your geometry, curves, lights, and
cameras. This is also where you create locators and sets. A locator is more

Figure 1.13 Locator.

14
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commonly known as a dummy object. It is a non-renderable object that other
nodes can be parented to. To create a locator go to Create > Locator.

A set consists of a group of objects or components. A set at first glance
may look like a group but, unlike groups, sets do not change the scene

hierarchy.

The Display Menu

The Display menu contains all of the user interface settings for Maya 5. To turn
the grid on or off in all viewports select Display > Grid. If you need to change
your grid options go to Display > Grid > 3. You can set the length and width
of the grid as well as the number of subdivision lines.

The Display > Heads Up Display options allow you to show object and scene
information in your viewports.

icads Up Display 51

Figure 1.15 The Heads Up Display.

Figure 1.14 Heads Up
Display options.

| always work with Poly Count, Camera Names, and View Axis checked, and will
turn other options on as needed. But those three let me know if a character fits
within the polygon limits and whether or not it is oriented correctly.

Hide is very important. You can hide selected objects or all objects of a specific
type. Hidden objects will not render. Hiding objects can make your scenes
much easier to work with. Once you are ready for the final render, use the Show

commands to make any hidden objects visible.

15
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The Window Menu

The Window menu is where you access the many different editors available in
Maya. We'll be going over the various editors in more detail in their respective
chapters. Settings/ Preferences is where you go to set your Maya options. It's very
important that before you begin working on your scene that you have all of
your preferences set correctly. Unless your project requires specific settings,

I would leave the majority of the preferences at their defaults. You should make
sure your axis and time settings are correct though. Go to Window > Settings/
Preferences > Preferences.

tr| Preferences

Kinematics
Animation
Manipulators
HUREBS
Palpgons
Settings
Diynamics
Filez/Projects
Keys
Modeling
Rendering
Selection

Timeline
Unda
Modules

Figure 1.16 The Preferences window.

Click on Settings and set the World Coordinate System to Up Axis Y, and make
sure the Working Units and Time are correctly set for your project. Leave the other
Settings options at their defaults. Having the axis Y up will save you countless
hours of frustration. Almost every software program or game engine is Y up, so if
you have to work with other animators or third-party tools you'll be making things
much easier for yourself by setting your axis correctly to begin with.
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Modeling Concepts

Modeling is the actual building of objects in 3D space. The object can be as
simple as a flat plane or as complex as a wilderness ecosystem. Maya 5 has
three different modeling modes available: Polygonal, NURBS, and Subdivision
surfaces (or subD surfaces). Each method has its benefits and disadvantages.

Object types. From left the spheres are Polygonal, NURBS, and
Subdivision.

Figure 2.1

Polygonal modeling has been around longer than the other types and is
generally easier to learn and more straightforward to work with. If you want to
work in video games, polygons are what you will be using. To get smooth,
detailed models with polygons, however, takes a large amount of data, thus

causing the meshes to be much denser and harder to work with on the higher
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end. NURBS, on the other hand, work very well for creating smooth, organic
objects. On the downside, they have a steeper learning curve and are difficult
to use when creating objects with sharp edges. Subdivision surfaces are the
newest modeling method. In essence subD surfaces are a combination of
polygons and NURBS surfaces. They offer many of the advantages of polygons
and NURBS surfaces. For pre-rendered work, subD surfaces are becoming much
more popular. The disadvantages of subD surfaces are the initial high learning

curve and incompatibility with game engines.

Before you begin modeling, you'll want to have concept sketches and a
minimum of a front and side orthogonal view of the model you plan on
building. The concept sketches are for visual reference during model
construction. The orthogonal views, though, will be used directly in Maya to
help you create your model. First, you will need to scan your orthographic
drawings. Next, you will need to bring the scanned images into Maya for use

as a template to build your model.

Figure 2.2 Front and side sketches of a model ready for construction.
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Tip: When creating a character for animation you should only model half of the
object in a neutral pose. Later you can mirror the object and join the two halves
together. This will save you hours of work.

1 Create a new scene by clicking on File > New Scene.

2  Inthe Front viewport select View > Image Plane > Import Image.
3 At the prompt, load the front view sketch of your character.

4 In the Side viewport select View > Image Plane > Import Image.
5 At the prompt, load the side view sketch of your character.

Figure 2.3 Template geometry.

6  Go to Display > Ul Elements > Channel Box/Layer Editor to bring up
the Channel Box or click the Channel Box button on the Status Line.

7  Press the Show the Layer Editor button in the Channel Box.

8 Select Layers > Create Layer in the Layer Editor.
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9  Select the newly created layer.
10 Drag select the two planes in the Perspective view.
11 In the Layer Editor, select Layers > Add Selected Objects to Current Layer.

12 Click the middle box of your layer until it displays an R. If you need to
open the layer for work at a later time, simply click the middle box of
the layer until it is empty.

Now you can go back to your scene and begin modeling. If you need to hide
the template objects for any reason, click the first box of your layer until it is
empty. This will turn off the layer and hide any objects within it.

Tip: Keep in mind that layers are useful for more than just template geometry.
Layers help you organize complex scenes in the same manner as many of the image
manipulation programs available. | like to organize my scenes by having all of the

characters in one layer, the terrain in another, particles in a third, and so on.

Polygonal Modeling

Polygons are probably the most commonly used modeling format. Low-res
polygonal models are used extensively for video games, while hi-res models are
widely used in print and films. Polygons are an extremely easy modeling form

to work with, hence their widespread use.

An important note on polygons: unlike NURBS and subD surfaces, polygons are
made up of straight edges. No matter how much you smooth or tessellate an

object, if you get close enough, the straight edges will be visible.

Polygonal objects can be open or closed shapes. They can also contain multiple
shells (more commonly known as meshes). A shell is a separate, self-contained

mesh that is part of, but not physically connected to, a larger unit.

Tip: The number of meshes contained in your scene usually isn't a problem except
in games. Most game engines not only have limitations on the number of polygons
that can be used, but also on the number of meshes as well. By combining separate
meshes together you can get around this.
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Primitives are the building blocks of modeling. They are a fast and easy way to
get basic shapes into your scene and often a properly lit and textured primitive
will work fine in your scene. Primitives are available for polygons, NURBS, and
subD. In this section we will be focusing on polygonal primitives, but keep in

mind that all primitives function in the same way.

1  Select Modeling from the Status Line pull down or press the F3
shortcut to enter the Modeling menu.

2 Go to Create > Polygon Primitives > Cube. A default cube will appear

in your scene.

Remember, Maya is completely customizable. This is only one method that can be
used to create the cube. You can also go to the Polygons shelf and select the

polygon icon to create a cube, or you can press the Spacebar while in the working
area to bring up the Hotbox controls and create your primitive from there. You can

even create a keyboard shortcut or MEL script to create your object.

There is an option box 3 next to each primitive listing. You can go in and change
the creation options for each primitive if desired. Open the option boxes and
experiment with creating primitives using varied settings. If you create a primitive
and later decide you would like to adjust it, you can do so by selecting the object
and going to the Attribute Editor (Window > Attribute Editor or use the hotkey
Ctrl + a) to make the changes.

1 Go to Create > Polygon Primitives > Sphere to place a sphere in your
scene. Use the move tools to position it so that there is an overlap

with the cube you created a moment ago.

2 Select the sphere, press the Shift key and select the cube. To select
multiple nodes in Maya 5, you hold down the Shift key and click on
everything you want included in the selection. To deselect nodes,

use the Ctrl key.

3  Go to Polygons > Booleans > Difference.

You should now have something similar to Figure 2.4 below.

Mirror Geometry creates a mirrored duplicate of the selected geometry along
a specified axis. There are options included that allow you to merge vertices
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Figure 2.4 Boolean objects.

during the mirroring process or to connect border edges with new faces.
Mirroring geometry is a great workflow habit to get into — you will be saving

yourself half the work.

Smooth Proxy works on the principle of using a low-res mesh to build your
hi-res geometry, but it differs from Smooth in that you do all of your work on a
simple proxy object while a copy of the smoothed final object updates
automatically.

1  Start a new scene.
2 Go to Create > Polygons Primitives > Cube and create a default cube.

3  Select the cube and go to Polygons > Smooth Proxy. Your cube will
now be semi-transparent and there will be a smoothed copy in its

center.

4 RMB click on the original cube to bring up the marking menu and select
Vertex.

5 Select a vertice and move it. The smooth copy will move as well.
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With Smooth Proxy anything you do to the original object will update
automatically on the smooth copy as well.

Other commonly used tools from the Polygon menu are the Create Polygon
Tool and Append to Polygon Tool. The tools allow you to make customized
polygon shapes by placing the vertices where desired. The only restriction is
that any new polygonal faces you create must be at least a triangle. Combine
allows you to select separate meshes and make them into one piece. Reduce
will trim down the number of polygons in your object while keeping your
UVs intact.

The Edit Polygons menu contains the tools for fine-tuning polygons. This is
where you'll find the tools that let you work on not just the polygons, but also

the vertices, edges, and faces that comprise them.
1 Create a polygonal cube with one division each for height, width, and
depth.
2 RMB click on the cube and go into edge mode.

3 Select the top four edges of the cube.

Figure 2.5 Beveled edges.
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N o a b~

Go to Edit Polygons > Bevel > .
Set the Offset to .05.

Set the Segments to 3.

Check the Auto Fit box.

Click Bevel.

Bevel rounds the selected edges. This is a highly useful tool; there are very few

objects that have completely hard corners. Applying a bevel is a simple step

that can lend quite a bit of realism to an object.

1

2

Undo the bevel and select the top four vertices on the object.

This time go to Edit Polygons > Chamfer Vertex. The chamfer function
replaces each selected vertex with a face. Chamfered vertices are

another small touch that can add a great deal of realism to your object.

Figure 2.6 Chamfered vertices.

Select all of the vertices that made up the chamfer. Go to Edit Polygons >

Extrude Vertex. You will now have spikes protruding from the cube. Extrude the
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vertices a few more times and you can come up with some very intricate shapes
quite easily.

Undo the extrusions and chamfer and select Edit Polygons > Cut Faces Tool.
Drag the manipulator over the cube and when you release the mouse button
the tool will slice the cube. You can set up the options for this tool to either

delete or offset the cut portions.

Extract separates the selected faces from the polygonal object. Separate will
separate any shells you have in your object.

The Colors and Normals tools are invaluable for games development.

With these tools you can properly align vertex normals or color your vertices
directly in the model without affecting your texture budget. You can even
reverse the direction of polygon faces to point the normals in the opposite
direction.

1  Start a new scene in Maya and create a sphere with a radius of 5 and
100 subdivisions along the Axis and Height.

2  Go to Edit Polygons > Sculpt Polygon Tool > 0.

Figure 2.7 Sculpted polygons.
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5

6

Set the Radius{U} to .500 and the Radius{L} to .100. The U is the
maximum size the brush can become, while the L is the smallest size.

Click the first Shape button.
Change the Opacity to .100 and set the Operation to pull.

Paint your name on the sphere.

Tutorial: Creating a Snake

Let's begin building a polygonal character. I'm going to be using a snake

character | created for one of my animations. He's not really an evil character

per se, he's just hungry all the time. This snake is on a never-ending hunt for

food and he is ready to eat anything that moves.

1

Set up a template for your scene and import the orthogonal views of
your object onto the image planes.

Create two more layers. Name one layer hideMe and the other
geometry. Turn the visibility off for the hideMe layer. The hideMe layer

Figure 2.8 EP curve outline.
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will contain things that will aid in building the object, but that we don’t
want in your final scene. The geometry layer will be for your character.

3 Go to the Side viewport and create an EP curve outline of your
character that matches the template.

4  If needed, RMB click on the EP curve and use the Control Vertices and
Edit Point options to fine-tune the curve.

Tip: If you need more edit points to work with, RMB click on the curve and select
Curve Point. Click the spot on the curve that you would like to place your new edit
point and go to Edit Curves > Insert Knot.

5  Once you are happy with the curve, go to Surfaces > Planar > 3. Set
the Degree to Cubic. For the Curve Range click Complete. Choose
Polygons as the Output Geometry with the Type set to Quads, and the
Count set to 100. Click the Planar Trim button. Using a lower polygon
count here is very important. If you set the count too high, your model
will be too difficult to work with later.

Figure 2.9 The flat outline.
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10

11

12

Place the EP curve in the hideMe layer. Because hideMe is already a
hidden layer, anything you add to it will also become hidden.

Select your mesh and rename it to snakeLow. Maya scenes can become
very hectic very quickly; by renaming things now, you'll have a much

easier time keeping track of things.
Delete the history for snakeLow.

Now we need to match the edges of the mesh to the template. RMB
click the mesh and go into Vertex component mode. Using the Move
tool, adjust the vertices so they match the outline. You'll notice some
areas that you can’t match because of the low polygon count. To
correct these use the Split Polygon Tool.

Go to Edit Polygon > Split Polygon Tool. Click the tool where you want
to begin the split and again where you want it to end. Press Enter on

your keyboard to finalize the split.

Continue using the Split Polygon Tool along with moving vertices until the
mesh edges roughly match the outline. Keep in mind that you want to
keep the polygon counts low at this stage so don't try to match things up
exactly. That will all be done later.

The snake has a couple of ridges that run down its side. Use the Split
Polygon Tool to add these ridges to the snakeLow mesh.

Figure 2.10 The added ridges.
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13

14

15

16

17

30

Using a planar trim and splitting polygons can sometimes lead to extra
vertices. We need to clean these up before we continue. Go into vertex
component mode for the mesh and select every vertex.

Select Edit Polygons > Merge Vertices > 3. The Merge Vertices tool
works by combining any vertices within the distance you set. The trick
here is to merge overlapping vertices with just the right amount,
otherwise you will wind up with a mangled snake. If you set it too high,
undo and lower the amount before trying again.

You should go over the model to see if there are any areas that could
benefit from a higher power of merged vertices. Cleaning up any loose
vertices now can save you a great deal of frustration later.

We are now ready to add some depth to the character. Before you
begin, make sure Polygons > Tool Options > Keep Faces Together is
checked. This option forces the selected faces to extrude as one. If you
turn this off, each face would extrude as its own entity.

Go into face component mode and select all of the faces of the snake.

Figure 2.11 Extruded snake.
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Go to Edit Polygons > Extrude Face. There are move, rotate, scale
handles on the Extrude tool. Drag the X move handle until the extrusion

roughly matches the template in the front viewport.

Now you need to adjust the vertices so they match the front view of
your template. Take extra care not to move the vertices that lie on the
zero coordinates. We are building half of the snake now and will mirror
later; if you move the inside vertices, you won't be able to mirror the
object correctly.

Select the faces that make up the ridge and extrude them to match the
template.

Delete the faces on the bottom of the snake.

Select the faces at the front of the neck and extrude them forward to

make the basic form of the head.

Now that we have the basic form for the snake, let’s create the other half.
We won't actually do any work on the second mesh; it’s just for visual

reference. Having both halves visible will help you shape the model.
Select the mesh and go to Edit > Duplicate > .

Set the X scale to —1. Using a negative scale during a duplicate

operation mirrors the object.

For Geometry Type, use Instance. An instances object will update

automatically any time you change the original object.

Set Group Under to Parent. Make sure Smart Transform and Assign
Unique Names to Child Nodes are both off.

Press Duplicate.

Continue to mold the snake to match the main shape of the template.
Remember to work only on the original mesh; any changes you make
will automatically pass down to the other models. Use the Split Polygon
Tool to create more detail in a particular area if it is needed.

Once the main shape is done, use the Split Polygon Tool to create the

outline for the eyebrow and eye.
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Figure 2.12 Second half.

Figure 2.13 Eyes created using the Split Polygon Tool.

31 Push and pull the vertices until you have properly shaped the brow and

eye.

32 Select the new polygons that make up the faces of the eye. Go to Edit
Polygons > Extrude > 3. Set the X translate to —.004 and the X, Y, and
Z scales to .75. Click Apply.
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36

37

38

Delete the faces that you extruded. We want to create the actual
eyeball later. The reason for extruding the faces before deleting them is
that this adds a bit of depth to the eye socket.

Next use the Split Polygon Tool to create an outline for the nose.

When the nostril outline is ready, extrude the faces that are to be the
actual cavity back.

Again use the Split Polygon Tool to draw an outline of the mouth.
Notice the creation of the top and bottom of the mouth. This is a very
important step. By creating the full outline of the mouth, it will make
constructing the inner mouth much easier.

For creation of the inner mouth you should hide all but the main mesh.
This will allow you to get inside the snake’s mouth. Select the three

other meshes and go to Display > Hide > Hide Selection. Don't worry
this in no way affects your models. We just need to hide them until we

are finished creating the mouth.

Now back to the main mesh. Select the inner row of faces of the mouth
outline and delete them. Select the two edges that form the front end
of the top jaw.

Figure 2.14 Creating the inner mouth.
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41

Go to Edit Polygons > Extrude Edge. Click the Local/World switch on
the extrude manipulator so you will be extruding in world space.
Extrude the edges back until they line up with the first vertex of the top

jaw.

With the edges still selected, go to Edit Polygons > Extrude Edge
again. This will create the next segment of the inner mouth. Extrude
this back until it lines up with the next vertex of the top jaw. Do this
for each vertex of the top jaw. Remember to go into world space each
time you extrude here. Once these are finished, create some extra

segments to extend down into the throat.

Now you need to line up the vertices of the segment you created. Select
the vertex nearest the first jaw vertex, go into Snap to Points mode, and
snap the points together. Continue until each segment is snapped to the
proper jaw vertex. The segments you created for the throat won't need
to be snapped to anything. Once finished, turn off Snap to Points.

Figure 2.15 Snapping the vertices.

42 There will now be two vertices at each top jaw position. Use Merge

34
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45
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49

Follow the steps above to create the bottom half of the inner mouth.

Go to Display > Show > Show Last Hidden to display all of the snake
meshes.

Now you need to complete the bottom half of the snake. Select the
bottom edges and extrude them down. Make sure you are in world
space during the extrusion. Also, extrude down in chunks so that your
object has enough faces to deform properly during animation.

After each extrusion, adjust the edges in the side view to match your
desired curvature.

Once you are happy with the length, go to the front view and begin
matching the vertices to the snake’s front view.

Figure 2.16 Creating the bottom half.

You are now ready to merge the pieces into one. Select both halves of
the lower polygon snake and click on Polygons > Combine.

This will create a new mesh node. Delete the history on this node and

rename it snake.
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50 Go into the front viewport, select the center column of vertices and run
a low-strength Merge Vertices operation. This will clean up any

overlapping vertices.

51 All that is left now is to create eyeballs and a tongue. These are each
made from a simple primitive by pushing and pulling vertices into the
desired shapes. Once complete, duplicate the eye and put one in each
socket and position the tongue inside the throat.

52 Your model is now done.

Figure 2.17 The final snake.

The final combining of the halves was done on the low polygon version
because this affords you the most options. If you need to keep a low polygon
version, it is ready to go as is. But if you can go with a higher resolution, simply
run a smoothing operation on the model; we already know this works. You can
even run multiple smoothing operations on it and go ultra-high res. | didn't
extend the template down for the snake because the tail section was very
similar to the main body of the snake. Also, | modeled the head in the arched
position to get more of a menacing look to the snake. Before this could be

used for animation, the head would need to be turned up for proper rigging.
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NURBS Modeling

NURBS (short for Non-Uniform Rational B-Spline) is great for modeling organic
shapes. A NURBS object comprises curves and surfaces.

The curves you create act as a framework for you to stretch a surface over.
Curves have many uses in Maya. Not only are they used for creating geometry,
but curves can also be used for creating text, setting animation paths, and for

controlling character animation rigs.

Figure 2.18 The different curves.

If curves act as the skeleton, surfaces would be the skin laid on top of these
curves. Usually you will manually create NURBS surfaces using tools like Loft,
Revolve, and Extrude, but there are also primitives available in Create > NURBS
Primitives to aid in your modeling. Working with surfaces is similar to working
with curves. Just keep in mind that a curve has one direction to work with,
whereas a surface has two directions (U and V). The U and V directions are used

to form the N (or surface normal) direction.

Go to the Create window. In the curves sub-group you will see the CV (control

vertices) Curve, EP (edit points) Curve, and Pencil Curve tools. The CV Curve
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tool creates curves by placing a control vertex at each mouse click. The EP
Curve tool places an edit point with each mouse click. To create a free flowing
curve, use the Pencil Curve tool. After placing the points of your curve you
need to press the Enter key to finalize it.

To edit a curve RMB click on it to go into component mode. Use the Control
Vertex and Edit Point options to manipulate the shape of the curve. Selecting
Curve Point allows you to fine-tune the curve by adding an edit point at the
specified spot using the Edit Curves > Insert Knot tool.

1 In the top viewport, create an EP curve.

2  In the front viewport create a NURBS circle oriented on the Z axis.
3 Select the circle then the EP curve.
4

Go to Surfaces > Extrude. When you extrude, you first select your
shape followed by the path. You should have a tube similar to the one
below. Tube is the default extrusion method.

Figure 2.19 Extruded circle.

Undo the extrude operation, select the EP curve first and the circle second. If
you run the Extrude tool now, it will use the circle as the path and create an
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entirely different shape. Of course, if Construction History is still on, you

can continue to manipulate the curves to alter the surface.

Tutorial: Binoculars

1

2

Start a new scene in Maya 5.

In the top viewport create an EP curve similar to the one shown in
Figure 2.20.

With the curve selected, go to Surface > Revolve > .
Set the Axis Preset to Z and the Pivot to object.

For Surface Degree select Cubic and use 0.00 for Start Sweep Angle
and 360 for the End Sweep Angle. This will create a solid shape. If you
started and ended at different angles, you would get a different
surface.

Choose 8 for Segments. Set the Curve Range to Complete and NURBS
as the Output Geometry. Click Create.

Figure 2.20 EP curve before and after revolve
operation.
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Figure 2.21 Isoparms needed to build the crosspiece.

Now you need to build the crosspiece. Select two adjacent isoparms

partway along the barrel of the revolved binocular barrel.

Go to Edit Curves > Duplicate Curves. This will make separate curves
for the isoparms that you selected.

Name the larger curve Crosspiece01 and the smaller curve
Crosspiece02.

Hint: Maya allows you to rename nodes when they are initially created. Or you
could also rename the node in question by clicking on the name and changing it in
the Channel Box or Attribute Editor.

10

11

40

With the two new curves selected, go to Edit Curves > Open/Close

Curves.

We will only be using parts of the new curves so delete the unneeded
edit points on the two curves. If your curves lose their shape in this
process, try deleting only one edit point at a time.
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Figure 2.22 Readying the new curves.

Turn on Snap to Points mode.

Select the EP curve tool, then RMB click on the first curve and enter
Edit Point component mode. Click near the top edit point of the curve
and the EP tool will snap the first edit point to that point.

RMB click on the second curve and enter Edit Point component mode.

Click near the top edit point of this second curve and the next EP curve
point will snap to that point.

Press enter to create the EP curve. This is the top guide that will help us
in construction of our crosspiece.

Follow steps 13 to 16 to create the bottom guide.
Turn off Snap to Points.
In the front viewport, create the inner outline for the crosspiece.

Duplicate the outline and adjust the CVs and EPs to form the outer
edge of the outline (see Figure 2.23).
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Figure 2.23 Inner and outer outlines.

21 Duplicate the inner edge twice and the outer edge three times. Place

them according to Figure 2.23.

22 Rename the outline sequentially starting with Outline01 for the curve
aligned with Crosspiece01, to Outline07 for the curve aligned to
Crosspiece02.

23 If you look at the crosspiece outlines, they won't match up with the
guidelines you created. To do this, select the top guideline and RMB
click to Curve Point component mode, select the spot where you want
to create an EP and run Edit Curves > Insert Knot.

24 Turn Snap to Points on.

25 RMB click on an outline curve and enter Edit Point component mode.
Select the end EP.

26 RMB click on the guideline and enter Edit Point mode. Now when you
move the edit point, it will snap to the guideline curve.

27 Repeat steps 26 for the tops of the other outline curves.

28 Once the top is done, follow steps 25 to 27 to complete the bottom.
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Figure 2.24 Adding edit points.

Figure 2.25 The completed outlines.

We are now ready to loft the surfaces for the crosspiece. For this particular
object we are going to loft the surfaces in chunks. This makes it easier to create

slightly rounded edges, which will add to the realism.
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Select Outline01 first, followed by Outline02.

Go to Surfaces > Loft > 0.

Set the Parameterization to Uniform with Auto Reverse.
For Surface Degree use Cubic with a Section Span of 1.

The Curve Range should be set to Complete and choose NURBS for the
Output Geometry.

Click Create.
Next select Outline02 and Outline03 and run Surface > Loft.

Repeat step 35 for Outline03 and 04, Outline04 and 05, Outline05 and
06, and lastly Outline06 and 07.

Select Outline01 followed by Crosspiece01 and go to Surface > Loft.
Select Outline07 followed by Crosspiece02 and go to Surface > Loft.
Select the first loft and second loft surfaces.

Go to Edit NURBS > Attach Surfaces > 0.

Set the Attach Method to Blend and the Blend Bias to .25. Check Insert
Knot options.

Leave Insert Parameter at .100.
Click Attach.

Select this new surface and the second loft surface. Go to Edit
NURBS > Attach Surface.

Repeat step 44 for each loft surface making sure to only attach one
surface per operation. Attach the two surfaces created with the

Crosspiece curves last.

Select the Crosspiece and go to Edit > Duplicate > 3. Set the X scale
to -1 and click Duplicate.

Line the second crosspiece up with the first one.
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Figure 2.26 The completed crosspiece.

Figure 2.27 The completed binoculars.

48 Duplicate the first lens and line it up with the second crosspiece.

49 Go to Create > NURBS Primitives > Cylinder > . Change the Axis to Z
and choose Both for Caps. Click Create.
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50 Place the cylinder in the hole between the two crosspieces and scale it
to fit. This will be the focusing knob.

51 Duplicate this cylinder and move it below the focusing knob. It should
intersect the bottom of each crosspiece. Scale it to fit. This will be the
part that holds the two halves of the binoculars together.

Subdivision Surfaces

Subdivision surfaces (or subD surfaces) are best described as a cross between
polygons and NURBS surfaces. They work by starting with a coarse base mesh for

your model, which is then made finer and finer as you subdivide any desired areas.

One advantage of subdivision surfaces is they can be modeled using a single
surface. This means that the potential of having seams in your models is not
present as they are with NURBS surfaces. Another big advantage is that a
coarse subD surface can be rigged for animation and the information will

automatically transfer to the finer levels.

1  Go to Create > Subdiv Primitives > Cube. This will place a subD cube
in your scene.

2  RMB click on the cube and select Vertex from the marking menu. You
will see a 0 displayed next to each vertex. This indicates that the
vertices are set to base level. The display levels range from zero to
thirteen.

Figure 2.28 A subdivision cube.
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3

4

Select a row of vertices marked by 0.

Go to Subdiv Surfaces > Refine Selected Components. This will refine
the selected vertices to level 1.

You can continue to refine the selected vertices. Repeat step four until you have

the desired smoothness for your vertices. You can also perform refine

operations using faces and edges.

1

2

Start a new scene in Maya.

Create three subD cubes using Create > Subdiv Primitives > Cube and
place them side by side.

Select the upper front row of vertices on the first cube.
Run Subdiv Surfaces > Refine Selected Components twice.

Double click on the Move Tool icon in the Tool Box to bring up the
attribute editor for the tool. For Move Settings select Normal.

Select the N handle and move the vertices a tad in the positive Z.

Repeat steps 3 to 6 for the second cube, selecting the upper front two
edges.

Repeat steps 3 to 6 on the faces of the third cube.

Figure 2.29 Three different manipulated subdivided cubes.
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By refining different components, you get drastically different results. Keep
in mind that you can choose different component types for different levels. Also,
you will get different results if you move the components before refining them.

1  Start a new scene in Maya.

2  Go to Create > Subdiv Primitives > Cylinder to place a subD cylinder in

your scene.
3 RMB click on the cylinder and go into vertex component mode.
4  Select the top center vertex of the cylinder.

5 Go to Subdiv Surfaces > Full Crease Edge/Vertex. This will create
a crease on our selection. Subdivision surfaces excel at creating creases
and edges, something that NURBS surfaces have trouble with.

6 Double click on the Move Tool icon in the Tool Box to bring up the
attribute editor for the tool. For Move Settings select Normal.

7  Move the vertex up on the Y axis. Notice how, because you selected
the full crease tool, the vertex forms a well-defined point on top of the
cylinder.

8  With the vertex still selected go to Subdiv Surfaces > Partial Crease
Edge/Vertex. A partial crease creates a softer edge compared to a full

crease.

9  Use the Move Normal Tool to move the vertex selection on the positive
Y axis until you have a bulb in your scene.

Figure 2.30 Subdivision bulb.
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10 Double click on the Move Tool icon in the tool box to open the attribute

editor.

11 Change the Move Settings to Object. You can switch between the move

settings without losing your selection.

12 Move the vertices down, as in Figure 2.31.

Figure 2.31 Flattened bulb.

13 Select the vertices that form the top of the object and run Subdiv
Surfaces > Refine Selected Components twice to smooth them to level 3.

14 Save your scene as subDMushroom.

Figure 2.32 Final mushroom.

There is another way to work with subdivision surfaces — Polygon Proxy Mode.
When you switch to Polygon Proxy Mode, a polygonal cage surrounds the base

level of your subdivision surface.
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1  Open the mushroom you created in the previous tutorial.
2  Select the object.

3  Go to Subdiv Surfaces > Polygon Proxy Mode. You will see a low
resolution cage appear in your model.

4  Press 4 to switch to wireframe mode. As you can see, the polygonal
cage matches the work you did on the base level of the object.

5 In order to get a polygonal cage to surround your object once you have

refined it, you need to collapse the hierarchy of the levels.

6 Go to Subdiv Surfaces > Standard Mode to return to the standard subD
editing mode.

7  Go to Subdiv Surfaces > Collapse Hierarchy > 3. Type 3 for the
Number of Levels and press Collapse. The number of levels options
refers to how many levels of refinement you want to collapse. You can
collapse up to the number you currently have set for your object.

8 Go to Subdiv Surfaces > Polygon Proxy Mode. The polygonal cage will
now surround the entire mushroom object.

Figure 2.33 Polygon proxy mushroom. Notice the
proxy cage vertices are selected.
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In Polygon Proxy Mode you can use any of the polygonal editing tools on the
new proxy mesh. Experiment with extruding some faces and pulling vertices of
the new polygon cage. The subD surface will deform as well. When you are
happy with your edits, go to Subdiv Surfaces > Standard Mode to return to the
normal subdivision work mode. When you switch back to standard mode, the
polygonal cage will automatically be deleted.

A very common workflow with subdivision surfaces is to start with a low
polygon object that you form into the basic shape you desire. Once you have
the basic form ready the object is converted to subD surfaces using Modify >
Convert > Polygons to Subdiv.

Tutorial: Creating a Hand with Subdivision
Surfaces
1  Start a new scene in Maya.

2 Create image planes in the front and side viewport to template your
hand drawings.

Figure 2.34 Hand drawings to be modeled using subD surfaces.

3  Go to Create > Polygon Primitives > Cube > 0. Set 4 for the
subdivisions along the X, Y, and Z axes. Click Create.

4  Position the cube of the palm of your template.

5  Scale the cube to the approximate dimensions of the palm of your
template. We will be extruding the fingers later.

6  RMB click on the cube and enter Vertex Component mode. Start
moving vertices to get the basic shape of the palm (see Figure 2.35).
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Figure 2.35 Beginning polygon model.

7 Now that you have the basic shape of the palm, it's time to convert it
into subD surfaces. Go to Modify > Convert > Polygons to Subdiv. Your
model will now be smoother. But it still lacks fingers and good palm

definition.

8 Select the model and go to Subdiv Surfaces > Polygon Proxy Mode.
A cage of the original polygonal mesh will surround the subD surface.

9 Select the faces that are in line with the index finger of the sideview

template drawing.

10  Using the polygon toolsets, extrude the faces out to just before the first

knuckle.
11 Adjust the faces so they match the area of the template.

12 Extrude again to the middle of the knuckle and adjust the faces to
match this area.

13 Extrude a third time to just after the knuckle and adjust the faces to
match the template. The reason for extruding in chunks around the
knuckles is because the extra detail in these areas allow for deformation
of the model.

14 Continue extruding in chunks until you have the basic shape of the

index finger.
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16

17
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21
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26

Figure 2.36 SubD surface index finger.

Take some time to fine-tune the shape of the index finger. Remember,
during this stage, all of the polygon tools are at your disposal. If you
need to merge vertices or split faces to match the template, now is the
time to do so.

Select the faces that correspond to the fingernail of the index finger.
Extrude them down a very slight amount.

Scale the faces uniformly down a small amount.

Extrude the faces back to their original position.

Split the polygon cage on the sides of the finger to add dimples around
the fingernail.

Pull the vertices in around the fingernail so they overlap the nail.

Use the Split Polygon Tool to create extra faces between the two fingers.
Repeat steps 9 to 22 to shape the other finger.

Select the faces that lie over the thumb in the template.

Extrude them out.

Rotate the selection so that edges nearest the wrist are back near their

starting point. This is an important part of cleaning up the thumb.
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Figure 2.37 Creating extra space between the fingers.

Figure 2.38 Creating the thumb.

27 Merge the vertices that have been rotated back to their starting point
with the vertices that are currently in those coordinates. This step is
vital for creating the bulge of the thumb where it shoots out from
the wrist.

28 Continue manipulating vertices to get the shape for the base of the
thumb.

29 Select and extrude the thumb faces using the same methods as used
for the fingers.
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Figure 2.39 Merging the vertices at the base of the thumb.

Figure 2.40 The base of the thumb.

Figure 2.41 Extruding the thumb.
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Create the nail for the thumb. Remember to use the Split Polygon Tool

to create extra faces so you can overlap them over the thumbnail.

Select the faces at the base of the hand and extrude them back to
make the wrist.

Figure 2.42 Making the wrist.

Once the wrist is extruded, delete the faces of the base. They will not
be needed.

Go to Subdiv Surfaces > Standard Mode. We are now ready to finish
the hand. We can get more finely tuned details in standard subD mode.

Select the rows of edges starting at the wrist and extending to the first

set of knuckles (see Figure 2.43).

Figure 2.43 Edges on the top of hand.
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Figure 2.44 Forming the bones and muscles of the wrist.

35 Go to Subdiv Surfaces > Partial Crease Edge/Vertex. Pull the crease up
a bit to form ridges on the back of the hand.

36 Use the Partial Crease Edge tool to create the bones and muscles of the

wrist.

Figure 2.45 The completed hand.

37 RMB click on the hand and select Vertex Component mode from the

marking menu.

38 Select the vertices for each fingertip.
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39 Go to Subdiv Surface > Refine Selected Components. The fingertips will
now be smoothed to level 1. Keep in mind that with subdivision

surfaces you only need to smooth out areas that need the extra detail.

The images | have used are unique hands for an android | created named
Feedle. Feedle only has a thumb and two fingers on each hand. Of course if
you are modeling a traditional hand, simply repeat the steps for each finger.
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After you create the geometry, you will need to let Maya know the surface
properties of the object. In Maya this is known as a Shading Network. Each
Shading Network you build holds such information as transparency, color,
incandescence, and textures. All of the material work is done in a work area

known as the Hypershade.

The Hypershade

Start a new scene in Maya 5.0, and open the Hypershade by going to
Window > Rendering Editors > Hypershade. You could also select the
Perspective/Hypershade button on the Tool Box to create a stacked window

of the two views.

Figure 3.1 The Hypershade window.

The Hypershade is separated into three main areas. To the left is the node
creation area. This is where you initially create your shading networks. You can
also RMB click in the Hypershade and create these nodes through the marking
menu. The two other key areas of the Hypershade are the top and bottom work
spaces. The top space contains the main node information. You can switch
between node types using the tabs along the top of this area. The bottom
space is the working area where you actually construct the shading networks.
You navigate through the Hypershade using the same mouse and keyboard

command used in moving through Maya’s main menus.

You will notice that there are always three material nodes present. These are

non-deletable nodes that Maya uses as default shaders for new objects.
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Material Types

You have many different material types to choose from when you begin
constructing your shading network. It's very important to choose the correct

material type as they each render differently.

Anistropic — For surfaces with small grooves, like brushed metal or a CD.
As your view of an object with an Anistropic material changes, the highlight

will change depending on the direction of the grooves.

Blinn — For surfaces that have soft specular highlights. Blinn materials are

a good choice for soft metal surfaces.

Lambert — For matte surfaces. Use for object that will have no specular
highlights.

Layered Shader — Use if you want more than one material on an object. Using

a Layered Shader you can mix the added materials to create unique surfaces.

Phong - For use on very glossy surfaces. Phong materials have a hard specular
highlight.

Phong E - Similar to Phong, but with a slightly softer specular highlight. Phong E

also renders faster than a regular Phong.

Ramp Shader — Uses gradients to control color changes of the material
associated with changes of lights and angle.

Shading Map - For creating non-photorealistic surfaces.

Surface Shader - Allows you to connect keyable attributes to the material.
With a Surface Shader you could have an object’s color change automatically as

it moves through the scene.

Use Background - For use with blending real-life images with computer-
generated objects. Objects using the Use Background material will not appear
in your scene, but they are still affected by nodes in your scene. Thus shadows
can still fall on them and they can still accept reflections. If you had a
photograph of a fence and you wanted it to appear that your character walked

behind it, you would create a stand-in object to match the outline of the fence
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and apply a Use Background material to it. If a shadow fell across the stand-in
object, it would appear to actually affect the fence in the photograph.

Texturing Objects Using NURBS

There are two ways to texture your object, procedurally and with image maps.
Procedural textures are generated within Maya using mathematical formulae.
Image maps are user-created files that you import into Maya and place on

an object.

1  Open the binoculars you created earlier.

2  Hide the left barrel and crosspiece. For identical objects it's a good idea
to texture the original piece before you duplicate it. When you
duplicate an object, the Shading Network is transferred onto the new
geometry.

Figure 3.2 Preparing the binoculars for texturing.

3 RMB click on the barrel and select the isoparms that make up the main
lens of the binoculars.
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10

11

Go to Edit NURBS > Detach Surfaces. This will detach the lens into

multiple surfaces.

Select the two separate surfaces of the lens and go to Edit NURBS >
Attach Surfaces > . Set the Attach Method to Connect and the
Multiple Knots to Keep. Press Attach. By attaching the surface in this
way, you get the lens to not distort during the attachment.

Continue attaching until the lens is all one surface.

Check the CVs at the center of the lens and if necessary snap them
together using the Snap to Point tool.

Repeat steps 3 to 7 for the smaller eyepiece lens.

Open the Hypershade by going to Window > Rendering Editor >
Hypershade.

Click once on the Phong icon and once on the Phong E icon in the
Create work area of the Hypershade. If the Create area does not have
the Materials loaded, click on the bar at the top and select Create
Materials from the menu. Also, remember you can RMB click in the work

areas and use the marking menu to create your material.

Double click on the Phong E material swatch in the work area to open
the Attribute Editor.

Tip: If you lose track of the icons in the work area press the a key on your keyboard
to frame all. Remember that you can navigate through here using the regular Maya
controls.

12

13

Click on the checkered box next to the Color setting. This will bring up the
Create Render Node. This window has the same nodes you can access
through the Create window of the Hypershade but if you assign them
through here, they are linked automatically to the Shader Network for you.

In the Create Render Node select the Textures tab and click on Checker.
The reason for applying the checker material is that it helps locate
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Figure 3.3 The Attribute Editor

Figure 3.4 The Create Render Node.
for the Phong E material.

Figure 3.5 The Checker texture.

problem areas on your mesh. With a checker textures assigned, you can

quickly see which areas of your object need work to prevent texture
stretching and crunching.

14 Select the barrel of the binoculars.
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15

16

17
18

Figure 3.6 The Phong E Material checker ready to assign.

Go back to the Hypershade. The Phong E material will now appear as a
checkered sphere.

With your object still selected, RMB click on the checkered Phong E
material and click on Assign Material to Selection in the marking menu.

Press 6 on your keyboard to enter hardware texturing mode.

You will see a checkered barrel similar to Figure 3.7.

Figure 3.7 The checkered barrel.
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Select all of the surfaces for the crosspiece and assign the checkered
Phong E to them.

Select the two lenses and repeat steps 11 through 19 using the Phong
material. This will give the lenses a shinier appearance.

Inspect the checker textures for any stretching. The crosspiece needs a
bit of work.

Select the crosspiece surface and go to Window > Attribute Editor (or
use the Ctrl + a keyboard shortcut).

In the Attribute Editor select the Shape node for the crosspiece.
Click on the arrow next to Texture Map to expand the options.
Click the Fix Texture Warp swatch. Leave the Grid divisions at 4.

This Fix Texture Warp works on a per surface basis. It does not affect

the material you created in any way.

To see the changes this makes to your crosspiece you will need to
render the scene. Center the crosspiece in your Perspective View and

click on Render the Current Frame in the Status Line.

The checker texture is no longer stretched way out of proportion on the
object.

Open the Hypershade and double click on Phong E material. We need
now to replace the checker texture with the one we will be using for

rendering.

Select Graph > Input and Output Connections in the Hypershade

window.

Select the checker texture and the place2dTexture swatches and delete
them. The Phong E material is still mapped to surfaces all we have to do

is add our final texture.
Double click on the Phong E swatch to open the Attribute Editor.

Click on the color bar next to Color to bring up the Color Chooser.
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34

35

36

37

38

39

40

Set each of the RGB values to 37.

If the Color Chooser is in HSV (Hue,
Saturation, and Value) mode click on
the HSV/RGB pulldown in the Sliders
section. If the numerical value
pulldown is set to 0-1, you may want
to change it to 0-255. Most people
are more familiar with the 0-255 color

picking system.

Click on the checker box next to

Bump Mapping.
Set the Bump Depth to .125.

Click on the checker box next to
Bump Value.

The Create Render Node window will
come up. Select Leather from the
3D Textures list.

Enter these attributes:

— Cell color of R 89, G 89, and B 89.

— Crease color of R 51, G 51, and B51.
- Cell Size to .500.

— Density to .488.

- Spottyness to .100.

- Randomness to .500

— Threshold to .909

— Creases checked.

) Color Chooser ,_ 0| x|

[~ [Sliders
m 0 "

mB lend |
u Palette |

docept | Resst | Cancel |

Figure 3.8 The Color Chooser.

Go back to the Hypershade and select the Phong material that is

mapped to the lenses and open it in the Hypershade.
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41 Enter the following attributes:

Color of R 128, G 128, and B 128.

Transparency of R 198, G 198, and B 198.

Expand the Raytrace Options section and turn on Refractions.
- Refractive index of 1.1.

Refractions Limit of 2.

Surface Thickness of 1.0.

Shadow Attenuation of .5.

42 Now that you have textured this half of the binoculars, duplicate and
position the lenses, crosspiece, and barrel as you did in the modeling
tutorial.

43 Press the Render the Current Frame button to see your final work. Keep
in mind that though we set up the lenses to use a refracted raytraced
material, it will not show up until the final render.

Figure 3.9 The finished binoculars.

Texturing Polygonal and SubD Models

Texturing polygons and subdivision surfaces uses a completely different
workflow from NURBS. NURBS embed the UV information automatically when

68



MATERIALS AND TEXTURES

you create a surface. With polygons and subD surfaces, you actually have to let

Maya know where the UV coordinates lay. This is done using the Texture

commands found in Edit Polygons > Textures and Subdiv Surfaces > Textures.

Mapping polygons and subD surfaces are essentially the same so we will be

focusing on polygons. The only differences between mapping the two model

types is that subD surfaces have fewer mapping types to work with compared

to polygons and when mapping subD surfaces, you need to remember to

select the Display Level which contains the faces you want to map.

10

11
12

Create three subdivision spheres in a new scene and place them side

by side.

Name the first sphere1 and leave it as is; name the second and third
sphere2 and sphere3 respectively, select the top face of each and

refine to level 3.

Open the Hypershade by going to Window > Rendering Editor >
Hypershade.

Create a Phong material.

Double click on the Phong material swatch in the work area to open
the Attribute Editor.

Click on the checkered box next to the Color setting to bring up the
Create Render Node.

In the Create Render Node select the Textures tab and click on Checker.
Select all of the faces of the base level of sphere1.

Go to Subdiv Surfaces > Textures > Automatic Mapping to create
a UV set for the base layer.

Go to the Hypershade and, with base level faces still selected, RMB
click on the checkered Phong material and click on Assign Material to

Selection in the marking menu.
Pick sphere2 and select all of the faces of the base level.
Go to Subdiv Surfaces > Textures > Automatic Mapping to create

a UV set for the base layer.
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13 Go to the Hypershade and, with base level faces still selected, RMB
click on the checkered Phong material and click on Assign Material to

Selection in the marking menu.
14 Now pick sphere3 and all of the faces for the level 3 refinement.

15 Go to Subdiv Surfaces > Textures > Automatic Mapping to create
a UV set for the base layer.

16 Go to the Hypershade and, with base level faces still selected, RMB
click on the checkered Phong material and click on Assign Material to

Selection in the marking menu.

Figure 3.10 UV mapped subdivision spheres.

Notice how the checker texture is mapped differently on each sphere. That is
because with subD UV mapping you can map the desired layer and the coordinates
automatically apply to any refinement levels upstream. This can give you a very

different result to that you would get if you mapped each level separately.

The UV Texture Editor

The UV Texture Editor is where you adjust the UVs for polygonal and subD
models. This is an integral part of texturing polygons and subdivision surfaces.
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1

To open go to Window > UV Texture Editor.
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Figure 3.11 UV Texture Editor.

Select the subD model you created, sphere.

Open the UV Texture Editor. You will see your sphere coordinates
spread out over the checkerboard texture. Use the standard Maya

command to navigate in the Texture Editor window.

DQlEMe [ vHS BHEH|2EEO (22D

Figure 3.12 An object in the UV Texture Editor.
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4 RMB click over one of the sphere outlines and select UV from the

marking menu.

5 Drag select all around an outline to select all of the UVs of that area. You
will notice that when you select something in the UV Texture Editor, the

selection also occurs in the main Maya viewports. The reverse is also true.

6  Scale the UVs up. While working in the UV Texture Editor keep an eye
on the object in the Maya viewports. As you scale the outline, the
selected area of sphere updates with more checkers. Try moving and
rotating the UVs to see the effects they have.

After mapping a polygonal or subdivision model the UV Texture Editor is where you
do all of the UV manipulation. While working in the editor, you can use the drop-
down options to snap UVs together, cut UVs, or even flip them. Take some time to

practice with both polygonal and subD objects to get a feel for how each works.

1  Open the polySnake tutorial. For this tutorial you will need to create
image maps to project onto the model similar to those in Figure 3.13.

Figure 3.13 Image maps.

Hint: If you have not already done so, rotate the snake’s head so that it is pointed
up. This will make texturing much easier.
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Select the faces for the underside of the snake.

Go to Create > Sets > Quick Select Set to add the faces to a quick
selection set named Belly.

Figure 3.14 The faces of the snake’s belly.

With the faces of the belly selected go to Edit Polygons > Texture
Planar Mapping > 3. Apply the following settings:

Smart Fit checked.
Fit to Bounding Box checked.
Mapping Direction set to Z axis.

Click Project. A mapping gizmo will appear similar to the one in
Figure 3.15.

The selected faces of the belly now have UV coordinates. All we need
to do now is supply the image. Open the Hypershade and create a new

Lambert material.

Double click the Lambert material to open the Attribute Editor.
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Figure 3.15 Mapping gizmo.

Click on the checkerboard next to Color to bring up the Create Render
Node window.

Select File from the Textures tab.

This will create, and connect to the Lambert material, a node for your
image file.

Double click on the Lambert material again and you will see that the
checkerboard next to Color has changed to a different icon. This is the
Input Connections icon, which indicates there are now more nodes in
that path.

Click on the Input Connections icon next to color.

The texture file node will come up. Click on the folder icon next to
Image Name and select the belly texture. The load image icon defaults
to the source images directory of the current project, but it can be
directed to any folder.

Tip: Unless you are specifically using alpha transparency in the texture file, make
sure your image is 24 bit before you load it into Maya.
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Quick select the belly faces.

RMB click on the Lambert material and select Assign Material to
Selection. The texture will now be assigned snake’s belly, but it is
horribly stretched. To correct this we need to adjust the number of
V repetitions.

Double click on the place2DTexture tab for the belly texture in the
Hypershade to open the Attribute Editor. You can also reach the
place2DTexture node by selecting the input and output connection
buttons at the top of the Attribute Editor if you have the main material

selected.
Change the Repeat V node to 14.

Repeat steps 19 to 20 for the back of the snake. When you create the
Lambert for this material, point it to the texture you created for the

snake's back.

Select the sides of the ridges and create a Quick Selection Set
for them.

Go to Edit Polygons > Texture > Planar Mapping > 0 and change
the Mapping Direction to project along the X Axis in.

Apply the Lambert used for the back of the snake to the ridges.
Select the sides of the head and add them to a Quick Selection Set.
Assign a Planar Projection to the selection oriented along the X axis.

Go to the Hypershade and select the Lambert material used for the
back of the snake. If we applied this material to the current faces, the

image would tile too much.
In the Hypershade window, select Edit > Duplicate > Shading Network.

Select the new network and adjust the V tiling in the place2dTexture
node. Currently the Repeat U is set to 1 and the V is 14.

Change the V to 1.5.
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Figure 3.16 The outer

34

35

36

37

76

mouth texture.

31

32

33

Select the faces that make up the upper
portion of the outer mouth and create a
Quick Selection Set for them. Because the
mouth needs to blend to the interior mouth,
you will need to create a texture that blends
from the scales into the fleshy interior of the
mouth (see Figure 3.16).

Apply a Planar Projection to the selection
along the X axis.

Create a new Lambert and load the outer
mouth texture. If needed, rotate the UVs
using the UV Texture Editor.

Repeat steps 31 to 33 for the faces along the lower edge of the outer

mouth.

Map the inside of the mouth with a pinkish texture that blends with the

edge of Figure 3.16.

Use the back texture to finish mapping the faces around the eyes and

snout.

Adjust any UVs needing work using the UV Texture Editor.

Figure 3.17 The textured snake.



MATERIALS AND TEXTURES

38

39
40

41

42

Open the Hypershade, double click on the Lambert material for the
belly and click on the checker box next to Bump Mapping.

Set the Bump Depth to .250.
Click on the checker box next to Bump Value.

The Create Render Node window will come up. Select file from the
Textures tab and point to the grayscale image you want to use for your
bump map. | made a copy of the snake’s belly texture and converted

that to grayscale, but you can use any grayscale image.

Figure 3.18 The final snake.

Repeat steps 38 to 41 for each material using the corresponding
grayscale image. Take care to match RepeatUV values of the bump

map's place2dTexture node with that of the image map node.
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Lighting is often an afterthought when creating a 3D scene. Don't fall into this
trap. A well-lit scene is often the difference between a mediocre image and

a truly outstanding one.

Light in the real world is emitted from a source as photons that are either
absorbed or bounce from object to object. As the photons bounce, light and color
are absorbed depending on the makeup of any surfaces that they strike.

In Maya, light doesn’t bounce. Because of this, all surfaces in Maya need to be
lit directly by the lights in your scene.

Types of Light

All of the lights are accessed through Create > Lights >. There are five main
types of lights: ambient, directional, point, spot, and area. There is also a sixth

light, the volume light, which is not used as often.

Figure 4.1 An ambient light emits
light uniformly in each direction
from the source.

Each light is displayed in Maya with a different icon. These are just for

placement purposes and will not render in your scene.

Once you create a light, use the Attribute Editor to change its parameters. Each
light has a Light Attribute section in the Attribute Editor. The Light Attribute
section is where you control a light's color and intensity. This is also where you

control a light's decay rate and cone properties.
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Figure 4.2 A directional light
emits parallel light rays from the
source. Sunlight striking the earth
is a common example of
directional light.

Figure 4.3 A point light has rays
that travel in all directions
emanating from a single point.

Figure 4.4 A spot light originates
from a single point, but is limited
by a cone.
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Figure 4.5 An area light emits
light from a 2D area.

Figure 4.6 The volume light.

Figure 4.7 The different light icons.
From left, they are ambient, directional,
point, spot, area, and volume.
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Figure 4.8 Light Attribute section for a spotlight.

The other section that all lights share is Shadows. Maya does not render
shadows by default; you need to set up this option on a per light basis.
Additionally, some lights will have a Mental Ray and/or a Light Effects section.
The Mental Ray section is for setting up lights to be used with the Mental Ray
renderer. The Light Effects section is to add optical effects such as lens flares or
fog to a light.

Tutorial: Creating a Three-Point
Lighting System

The three-point lighting system is a good foundation to build upon to light your
scene. This method of lighting is commonly used in real world photography
and motion picture shoots. It's quite a simple rig, but can do wonders to liven
up your scenes. You start with a Key light that provides the main illumination of
your object or scene. Next you place a Fill light to soften the shadows in your
scene. Finally you add a Backlight to separate the object from the background.
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Figure 4.9 Three-point lighting rig.

In the basic three-point lighting system the Key light is the main source of
illumination. The Fill light is approximately forty-five degrees from the Key light on
the opposite side of the camera. The Fill light has less intensity than the Key. The
Backlight is behind the object pointing toward the camera. It is almost opposite
the Fill light and generally raised a bit. The Backlight intensity varies by what is
needed to highlight the edges of the object.

1 Create three polygonal planes and arrange them into a floor and two
walls (see Figure 4.11).
2 Place a NURBS sphere in the center of the room.

3  Go to Create > Camera. Position the camera so it is looking at the
sphere. To check the camera point of view, go to Panels > Perspective >

Camera1 in the drop-down menus of your current viewport.

4 Go to Create > Lights > Spot Light. Name this light Key and position it
according to Figure 4.12.

5 Create a Fill light and a Backlight. Name them Fill and Backlight

respectively and position them according to Figure 4.13.
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Figure 4.10 Object lit using a three-point lighting rig.

Figure 4.11 Walls and floor for three-point lighting.
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Figure 4.12 Key light only.

Figure 4.13 Key and Fill lights.

6 Select the Key light and press Ctrl +a to open the Attribute Editor.

7 Inthe Spot Light Attributes section, change the Penumbra Angle to 5.372.
Lights rarely have a hard edge. This will give the light cone a soft edge.

8 Repeat step 7 for the Fill and Back lights.
9 Go to Panels > Perspective > Camera1 to look through your camera.

10 Press the Render the Current Frame button on the Status Line.

86



LIGHTING

Figure 4.14 Backlight only.

-

Figure 4.15 The final lit sphere.

Notice how the addition of the Backlight adds depth to the object. The
three-point system will, more often than not, be a good starting point to begin
lighting your scene. This scene lacks a very important element though — shadows.

Shadows will help ground your object into the scene.

Shadows

There are two types of shadows available in Maya: Depth Map and Raytraced.
Depth Map (or Dmap) shadows take much less time to render compared to
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raytraced shadows and will often give you very good results. Raytraced
shadows may be more time-consuming to render but you get the added

benefit of being able to use transparent and colored shadows.

Figure 4.16 Depth Map on left versus Raytrace shadow on right.

The rendering time for this very simple scene using a high anti-aliasing quality at a
resolution of 1000 X 1000 on a 1.8 GHz P4 was 32 seconds using Dmap shadows.
Compare that to the 54 seconds it took using raytraced shadows. Of course the
Dmap shadow is quite blocky, but this is where one of the huge benefits of depth
map shadows comes into play — you can adjust the resolution of the shadow map
without significantly raising the rendering time. The rendering time for Figure 4.17
is only 33 seconds with the newly adjusted depth map. That's not much more than

the original rendering, but still a huge saving over the raytraced shadow.

Depth map shadows work by creating a grayscale image that displays the

distance from a light to the nearest shadow-casting object it encounters.

1  Open the three-point lighting tutorial you finished earlier.
Select the Fill and Back lights.
Go to Display > Hide > Hide Selection.

Select the Key light and press Ctrl +a to open the Attribute Editor.

a A W N

Expand the Shadows section.
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Figure 4.17 Adjusted Dmap resolution.

Ml Frheck: 3pointDMAPSHADOWSDEPTH_camerashapel_tmpiff - 51215

Figure 4.18 Depth mask.
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6  Check the Use Depth Map Shadows box.
7  Change the Dmap Resolution to 1024.

8 Change the Dmap Filter size to 2. The Dmap Filter controls the softness
of the edges of the shadow. Be aware that higher values can increase

rendering time.

Figure 4.19 Increased Dmap Filter.

Render the scene. Notice how the edges become softer. Also note that the
shadow behind the sphere is completely opaque.
1  Select the Key light again.

2 In the Shadows section of the Attribute Editor click on the color swatch
and change color values to R 255, G 0, and B 0.

Render the scene again and you will see that the shadow cast by the sphere is
now red. Playing with the shadow colors of Dmap shadows can give some

interesting results.
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Figure 4.20 Red Shadow.

1 Undo the red color for the shadow and turn off Dmap Shadows.

2 Go to the Raytrace Attribute section and check the Ray Trace Shadows
button.

Go to Window > Rendering Editors > Render Globals.
Click the Maya Software tab.

Expand the Raytracing Quality tab and check the Raytracing box.

o o A~ W

Render the scene. Notice how sharp the edge of the shadow is. This is

an inherent part of raytracing.

N

Change the Light Radius to .050.
8 Change Shadow Rays to 12.
Render the scene. The shadows will be much softer now.

1  Open the Hypershade and create a Phong material.

2  Click the Transparency color swatch and change the RGB values to R 41,
G 140, and B 255. Click Accept.

3 Assign the Phong material to your sphere.
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Figure 4.21 Softer raytraced shadows.

Render the scene and you will notice that the shadow has a blue tint. If you set
a color (or texture map) to the transparency channel of an object, the shadows

will take on that color.

Figure 4.22 Colored raytraced shadows.
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Tutorial: Indoor Lighting

For this tutorial, you will need to create a polygonal room approximately five
meters by five meters with a height of two and a half meters. Add some
windows and a table, lamp and vase (see Figure 4.23) to one corner. Place a

camera in the opposite corner to look toward the lamp.

Hint: The yellow glow of the light bulb is a Lambert material with the Incandescence

channel cranked to the maximum and a yellow tint to it.

£t Persp Yien
] dg_Liferg show Hot

Figure 4.23 The indoor scene using default lighting.

1 Go to Create > Spot Light to add a spot light to your scene.
2  Scale and position it so that it sits inside the lightbulb.

3 Adjust the light's Cone Angle so it matches the hood of the lamp.

If you render you scene now, you won't see any light because the
bulb blocks it.

4  Open the Attribute Editor for the spotlight and check Use Decay

Regions in the Decay Regions section. Decay regions allow you to
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10

11

12

94

specify when light starts and stops. Spotlights are the only type of light
that has decay regions.

Go to Display > Show > Light Manipulators to display the decay
regions for the light.

Figure 4.24 Decay regions.

Adjust the bottom decay region so that it extends through the floor.
Adjust the other decay regions so they line up with the edge of the bulb.

Render the scene and you can now see the light emitted from the
spotlight.

Select the color swatch and change the RGB values to R 255, G 255,
and B 195.

Change the Penumbra to 10 to soften the edges.

Change the Dropoff to 12.644 so the center of the light is brighter than
the edges.

Turn on Use Raytraced Shadows in the Raytrace Shadows Attributes

section.
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£l Persp Yien

Figure 4.25 Decay regions set for the bulb.
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Figure 4.26 Yellow color.
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Set Light Radius to 1.250.
Change Shadow Rays to 12.

If you render the scene now, the light doesn’t appear. Because you
placed the light inside the bulb, Maya is having problems calculating the
raytraced shadow effects.

Select the light-bulb geometry and click on the shape node in the
Attribute Editor.

Expand the Render Stats section.
Deselect Casts Shadows.

Open the Light Effects section of the Attribute Editor. Light Effects add
nodes to your light that makes it react more like a real world light. You
can add fog and optical F/X-like lens flares. Not all Light Effects are
available for every light.

Click on the checker box next to Light Fog.

Change the Density in the Light Fog node to .750.

[=| Light Effects

Light Fog [lightF o1 |
Fag Spread IW '__l— ﬂ
Fag Intensity IW '__l— ﬂ

Light Glow | 1=l

Intenzity Curve Create "] ‘

Calor Curves Create

Figure 4.28 Visible Light Fog.

Add a point light to the scene and position it above the lamp.
Set the Color to R 255, G 255, B 206.
Change the Intensity to 24.

Set the Decay Rate to Linear.
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26

27
28
29
30
31

32

33

Add a spotlight to the scene and position it behind and above the
camera. The purpose of this spotlight is to add a low level light through
the scene. Depending on the room you are lighting, you could use a
different type of light, but for our purposes, a spotlight works well.

Set the Intensity to .650.

Set the Cone Angle to 120.
Change the Penumbra to 6.198.
Set the Dropoff to 4.126.

Create an area light and place it behind the lamp. Rotate it to face the

wall.

Scale the area light to fit the corner (see Figure 4.29).

Figure 4.29 Corner area light.

Set the Intensity to —.004. Any time you apply a negative intensity value

to a light, Maya will remove light from the scene.

The room is nearly complete. The only thing left now is to add some depth to

the objects. The spotlight for the lamp is the main point of illumination for the
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scene and can be considered the Key light. The second spotlight is used as the

Fill light. That leaves us with Backlights to add in order to bring out the depth

of the objects.

34 Add a spotlight and position it behind the vase (see Figure 4.30).

35

36

37

98

Figure 4.30 Vase backlight.

The vase has a nice backlight now, but the extra light washes out other
parts of the scene. The problem is that whenever a light is added in
Maya, by default it affects the entire scene. We can fix this by using the
Light Linker.

Go to Window > Relationship Editors > Light Linking > Light-Centric.
The Relationship Editor will open in a new window. On the left you will
see all of the lights in your scene listed in the Light Source window. On
the right are the scene nodes affected by the lights in the Illuminated

Objects window.

Click on the vase backlight in the Light Source window. The nodes in
the Illluminated Objects window will turn gray to indicate that the

current light affects them.
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Figure 4.31 The Relationship Editor.

38 Select Show > Objects > Geometry
in the Illuminated Objects menu list.
By setting the window to list only
geometry, you'll be able to navigate

the window more easily.

39 Deselect everything but the

vase.

40 Repeat steps 36 to 39 to create two
backlights for the table, one for each

end.

Figure 4.32 The final render of
the interior scene.

Tutorial: Outdoor Lighting

1  For this tutorial you will need an outdoor environment similar to the one in
Figure 4.33. The lighting scheme for an outdoor environment will be
completely different depending on the time of day, season, or

atmospheric conditions.
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Figure 4.33 Outdoor
environment ready for
lighting.

2  Open your outdoor scene in Maya. In Figure 4.34 you can see the terrain
meshes are considerably spread apart. But the same terrain using default
lighting viewed through the scene camera lacks depth. Remember how
the basic three-point lighting rig adds depth and form to a scene? We'll
be using that as our starting point.

Figure 4.34 Perspective
view of a default lit
environment.
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Go to Create > Lights > Directional Light. The sun can be thought of as
the Key light.

Adjust the Intensity to 1.175.

Position the Key at roughly where the sun would be during mid-morning
(see Figure 4.35).

Figure 4.35 Placing the
Key light.

Go to Create > Lights > Point Light to add a fill light to your scene.
Set the Color to R 162, G 190, B 214.

Adjust the Intensity to .125.

Position this light on the opposite side of the camera from the Key light
(see Figure 4.36).

Now comes the trick to lighting outside environments: for each chunk
of terrain, you should add a different backlight and use the Light Linker
so the backlight will only affect specified terrain.

Create a Directional light to act as the main backlight. Position this
behind and slightly above the first cliff.
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Figure 4.36 Adding the
fill light.

Figure 4.37 Placing the
backlights.

12 Set the Intensity to .5.

13 Create a second Directional and place this behind the terrain in the
middle of the scene.
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14

15

16
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Set the Color to R 183, G 250, and B 255.

Change the Intensity to .600.

Create a third Directional light and place it behind the rear mountains.
Set the Color to R 37, G 217, and B 255.

Go to Window > Relationship Editors > Light Linking > Light-Centric.
Set the first backlight to affect only the foreground terrain, have the
second backlight affect only the middle terrain, and change the third
backlight to affect only the rear terrain.

Figure 4.38 The final scene.
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Maya excels at animation. In fact almost everything in Maya can be animated.
The main type of animation used in Maya is keyframes. A keyframe is an
individual frame showing the extreme of an action. Once the keyframes are set,
Maya interpolates the in-between frames automatically. Other types of

animation include path based, dynamic, and blend shapes.

Many of the guidelines used for traditional animation are also useful for 3D
animation. While the focus of this book is not on the principles of animation, it
is nonetheless important to point out that functions such as anticipation, squash
and stretch, timing, follow through, ease in and ease out, secondary action, and

arcs are all vital to creating a solid animation.

Animation Terms

Anticipation — The preparation to an action. A slight turn of the head to the left
before the full turn to the right is one example of anticipation. Another example

would be a boxer cocking a fist back before throwing the punch.

Squash and stretch — The mass and deformability of an object. Kick a football

and it will squash upon contact and stretch while moving away.

Timing - Defines the weight and size of objects. A bowling ball takes longer to
reach full speed and slow down than a tennis ball does.

Follow through — Relates to the stopping of one action while setting it up for
another. A waving flag is the perfect example of follow through. As the base of
the flag stops moving in one direction and begins moving the other way, the
end of the flag trails behind.

Ease in and ease out — Also known as slow in and slow out. This refers to
adding extra frames moving into and out of an animation so the object does
not abruptly reach its goal.

Secondary action — Refers to an object reacting to a different action. If a dog
with droopy ears suddenly stops, the ears will continue moving forward

resulting in a secondary action.

Arcs — This refers to movement along natural arcs.
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To access the animation tools, Press F2 or select Animation from the Menu Set

on the Status Line.

&nimate  Deform  Skeleton  Skin Constrain Character

Figure 5.1 The Animation menu.

Keyframe Animation

Set the Playback end time to 30. Figure 5.2 The Animate
drop-down menu.

The Animate drop-down menu is where animate..|||
you'll find the basic animation keyframing Stk o
information. In the first section you will find Set Breakdown o
key options. The clip section is for use with Hold Current Keys
the Trax Editor which we shall work with later Set Driven Key ¢
. . »
in this chapter. Set Transform Keys
IKIFK Keys 4
The bottom of the work area contains the :
Create Clip )
Timeline and Range sliders. Create Pase |
. y m |
1 Start a new scene in Maya. Mhnst aiecion
Unghost Selecked )
2 Go to Windows > Settings > Unghast Al
Preferences and click on Settings. e MotioR Al a
. Create Animation Si hiok m ]
3 Change the Time to NTSC (30 fps). SRR R e T
|Update Mation Traillsnapshok
4 Click on the Timeline category. Biestenimatetsmeen -
5 Set the Playback start time to 1. Motian Paths »
6
7

Change the Animation start time to 1.
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I I I 1 1

Figure 5.3 Timeline.
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Figure 5.4 Range slider.
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Change the Animation end time to 30.

Click Save.

Create a NURBS plane with a width and length of 20.
Create a default NURBS sphere.

Move the sphere up one unit so it is sitting on the plane.
Freeze transformations on the sphere.

Drag the black bar in the Timeline to frame one.

Press the Key Transform shortcut W or go to Animate > Set Transform
Keys > Translate. A line will appear in the Timeline at frame one
indicating there is a keyframe on that frame. The line will be blue if that

frame is currently active and red if it is inactive.

Drag the black bar to frame 16

of the Timeline.
T —

Open the Channel Editor for the EE EE % 4& O ﬂ
sphere and change the Y
P ° Channels  Object
Translate to 4.
nurbsSphere1

Press the Key Transform tranzlateX [0
shortcut W or go to Animate > tranzlatey’ (4
Set Transform Keys > Translate. tranzlates |0
Any channel that has a rotate |0
keyframe will indicate thus by rotate’’ |0
being shaded a sort of pale rotates |0
orange in the Channel Editor. sCaElEr |1
Drag the black bar to frame 30 B

L zcalel |1
of the Timeline. o

wigikility |on

Go to the Channel Editor and Figure 5.5 Channel Editor keyframes.

change the Y Translate to .635.

Press the Key Transform shortcut W or go to Animate > Set Transform

Keys > Translate.
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Tip: Click and drag the black bar in the Timeline. The animation will update as you
move the bar. This is known as scrubbing and can be very helpful in setting up your
animations.

Press the Play button on the Timeline. The playback buttons act just as a VCR.

The ball bounces in place. Not very exciting, | know, but this is a good

introduction to keyframing, which plays a huge role in Maya animation.

Experiment with setting keyframes for the other channels.

1

2

3

4

5

Go to frame 1 and input the following in the Channel Box.
Rotate X 28.91.

Rotate Y 4.296.

Rotate Z -24.273.

Go to frame 16.

Hint: In the Playback controls are buttons that allow you to either step forward to
the next key or step back to the previous one. These can be very helpful when
working with many keyframes.

10

11

12

13

14

Change Rotate X to -76.699.

Change Rotate Y 75.331.

Change Rotate Z 81.706.

Go to frame 30.

Change Rotate X to -133.367.
Change Rotate Y 139.75.

Change Rotate Z 108.06.

The sphere now rotates as it bounces.

Save this scene as bouncingBall.
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Create a playblast for your bouncing ball animation by going to Window >
Playblast. Playblasts allow you to quickly view your animations running at full
frames per second. Smaller animations are usually not a problem, but for files
that have a larger number of characters, playback within Maya might actually be
off. Creating a playblast may be the only way to view the animation at full

speed without actually having to render it out.

When you reference a file, Maya simply points from within the current file to the
reference in question. When you really start diving into large numbers of
animations, and especially if you have many separate animations controlled by
a single character rig, it's a good idea to use the Reference Editor. That way, if
you need to change any part of the model, rather than changing each
animation you just have to change the master file and the changes will occur

automatically within any files that use it as a reference.
1 Create a new scene in Maya.

2 Go to File > Reference Editor.

reterenceitor Y
IFile Edit Reference Help

« | File Particulars

Mame:  NA

Tope:  N/A Sub-Tepe:  NAA

Status: N4 1/0; A

Load: A0 Fenarne Prefil /4
Suntitled

Figure 5.6 The
Reference Editor.

3 Click on File > Create Reference in the Reference Editor window.
4  Point the load reference prompt to the bouncingBall file.
5 Save this file as ballDeformer.

The objects will now appear in your scene. Press play and the animation will
play as normal. Referenced objects have the letter r placed over the icon in the
Outliner.
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Iﬂ bouncingB allFINAL: nurbsPlane
Iﬂ bouncingB allFINAL: nurbzS pherel

Figure 5.7 Referenced objects in the outliner.

Load ballDeformer.

Select the sphere and open the Channel Editor.

Shift click on Rotate X, Rotate Y, and Rotate Z in the Channel Editor.
The channels will become highlighted in black to indicate they are

selected.

RMB click on one of the channels and select Break Connections. This will

remove the keyframe information for those channels. However, because

this is a referenced file, it will only break the

channels in this file; the original bouncing
ball file will remain unchanged.

Change Rotate X, Rotate Y, and Rotate Z
to 0. The ball no longer rotates as it
bounces.

Go to frame 8 and select Deform > Create

Lattice > 0. Enter the following.

Divisionsto S2,T5,and U 2. S, T, and U are
lattice-specific axes and are the equivalent of
X, Y, and Z.

Check Use Local Mode.

Local Divisions, S 2, T 2, and U 2.

Key Selected
Key Al

Breakdown Selected
Breakdown Al

Cut Selected
Copy Selected

Paste Selected —

Delete Selected

Break Connections

Figure 5.8 Break
connections.

[[[[]
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('] Lattice Options
Edit Help
Basic |Ad\\.'an|:gd I

Divisions |2 |5 |2
Local Mode ¥ Use Local Mode
Local Divisions |2 |2 |2

Fasitioring v Center Around Selsction
Grouping | Group Base and Lattice tagether
F‘areh!fn;i ™ Autoparent ta Selection

Freeze Mode [ Freeze Geomety Mapping

Create Apply Cloge

Figure 5.9 Lattice options.

10 For Positioning, check Center Around Selection.

11 Click Create. The lattice will appear around the sphere.

Figure 5.10 The lattice deformer.

12 RMB click on the lattice to bring up the marking menu and select
Lattice Point.
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13 Select the middle row of lattice points and scale them down to a narrow

opening.

Figure 5.11 Scaled lattice points.

14 Play the animation. As the sphere passes through the scaled portion of
lattice points, it deforms to try to fit through the smaller opening.

Figure 5.12 Sphere scaled to fit lattice points.
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15 Select the lattice and delete it. The sphere should switch back to its
original shape.
Deformers
A lattice is just one type of deformer. Maya also allows you to work with
deformers such as squash, bend, and twist.
1 Go to frame 1.

2 Select the sphere and go to Deform > Create Nonlinear > Squash > 3.

Enter the following.

3 Low Bound -1.
4 High Bound 1.
5 Start Smoothness 0.
6 End Smoothness 0.
7 Max Expand Position .5.
8 Expand 1.
9 Factor 0.
10 Press Create. INPUTS
11  Open the Outliner and select the tweak1
squashHandle node then Ctrl click the transformGeometryl
makeHurbSphered
sphere.
envelope ||
12 Go to Edit > Parent or press the fa'j':'; -0.2
expand |1
shortcut p. The squash handle now s I
moves with the sphere as it bounces. startSmoothness [0
A parent object is used to control the endsmacthiness |0
attributes of child objects. For example, Iu?qulnund i
. highBound |1
if you rotate or translate the parent
object, any child objects attached to it Figure 5.13 Channel
will rotate and translate as well. editor inputs.
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13

14

15

16

17

18

Select the sphere and open the Channel Editor.

In the Inputs section of the Channel Editor, select the squash node.
Go to frame 1.

In the Channel Editor, change the squash factor to -.2.

Select the factor channel and RMB click to bring up the marking menu.

Select Key Selected.

Tip: You can click on a channel to highlight it in the Channel Editor, then using your
MMB you can click and drag in a viewport to change the value interactively.

19

20

21

22

23

24

25

26

At frame 8 key the Factor at .3.

At frame 13 key the Factor at -.25.
At frame 16 key the Factor at 0.
At frame 19 key the Factor at .26.
At frame 24 key the Factor at .4.
At frame 28 key the Factor at 0.
At frame 30 key the Factor at -.1.

Play the animation, and the sphere will squash and stretch as it

bounces.

You can add as many deformers as you like. Also, deformers are also helpful

in modeling. If you need to bend a model, apply a nonlinear bend. Once you

like the shape, simply delete the history and your model is permanently bent.

Tutorial: A Falling Lamp

Now that you've seen the basics of keyframe animation, let’s try something

more advanced. Open the scene you created for the interior lighting tutorial.
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Go to Windows > Settings > Preferences and click on Settings.
Change the Time to NTSC (30 fps).

Click on the Timeline category.

Set the Playback start time to 1.

Set the Playback end time to 150.

Change the Animation start time to 1.

Change the Animation end time to 150.

Click Save.

Select the lamp and rotate it on the Z axis toward the floor. The first
thing you will see is that the pivot point is in the center of the object,
which causes the lamp to rotate incorrectly. Also notice the lights don't

rotate at all.

Figure 5.14 Pivot point
on lamp.

The scene needs to be prepped for animation. The lights are fairly

straightforward to set up.
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11
12
13
14
15
16
17

18

19

20

21

22

23

24

25

26

27

28

Select the spotlight then Shift select the light bulb surface.
Go to Edit > Parent > .

Set the Parent Method to Move Objects.

Check Preserve Position.

Press Parent.

Select the light bulb surface then shift select the lamp.

Go to Edit > Parent or use the keyboard shortcut p.

Select the point light above the lamp then Shift select the lamp
surface.

Go to Edit > Parent or use the keyboard shortcut p.

Select the lamp and try rotating it again. The lights will now properly

follow the lamp as it rotates.

Setting up the lamp rotating is a bit more involved. You could press the
Insert key to edit the lamp’s pivot point and place it in the proper
position, but in this case there is a better method.

Select the lamp and add it to a group by going to Edit > Group or by
using the Ctrl+g shortcut.

Name this group lampMain.

Press Insert and move the pivot point of the group to the edge of
the lamp.

Press Insert a second time to exit the pivot point edit mode.

Select the group and rotate it. The lamp, bulb, and lights should
properly rotate now (see Figure 5.16).

This rotation will only work on the side where the pivot is located. If you
try rotating in the other direction, the lamp will clip the floor. We can
correct this by creating another group.

Go to Window > Outliner.
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29

30

31
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Figure 5.15 Moving the
pivot point of the group.

Figure 5.16 Rotating the
lamp.

Click the plus next to the first group to expand it.
Select the lamp surface.

Go to Edit > Group 3.
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32 Change Group Under to Parent.
33 Leave Group Pivot at Origin.
34 Press Group. This will add the lamp to a new group2 that is parented
under the first group.
P
FIEFILE‘;.-' Shaw  Help Prm—
'Ihl e
"
B S/ lamphain ﬂ
= lampS econdany
= larmpRall
B ' extruded5uface]
B ' nurbsSpheres
] spotLight?
_ﬁ_ painiLight] ;I Figure 5.17 The
groups in the outliner.

35
36
37

38

39
40
41
42

Name the second group lampSecondary.
Select the lampSecondary group.

Press Insert and move the pivot point to the edge of the lamp on the

opposite side of the first group.

Open the Channel Editor by going to Display > Ul Elements > Channel
Box/Layer Editor or by pressing the Channel Box button on the

Status Line.

Go to frame 1 of the animation.

Select the lampMain group.

Enter —2.333 for the Rotate Z.

Create a rotation key by going to Animate > Set Transform Keys >

Rotate > or by pressing the keyboard shortcut E.
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43

44

45

46
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Figure 5.18 The second
group.

Set six more rotation keys for lampMain with the following values.

. Frame 5 with X0, Y0, and Z 0.

. Frame 25 with X 0, YO0, and Z 0.

. Frame 36 with X 0, Y 0, and Z -26.049.

. Frame 50 with X 0, Y 0, and Z 97.5.

. Frame 53 with X -3.6, Y 0, and Z -87.67.
. Frame 56 with X -9, Y 0, and Z -97.5.

Select lampSecondary and enter the following rotational keyframe
values.

« Frame 5 with X0, YO0, and Z 0.

.« Frame 9 with X0, YO, and Z 8.37.

. Frame 13 with X 0, Y 0, and Z 9.686.

« Frame 25 with X0, Y0, and Z 0.

Select the lamp surface.

Go to Edit > Group. This will add a third group parented to second
group.



ANIMATION

47 Name this group lampRoll.

Figure 5.19 Adding
the third group.

48 Move the pivot point for lampRoll to the center of the base of the lamp
surface. This will allow you to add some roll to the lamp as it falls

without making it clip through the floor.

Figure 5.20 The pivot
point for the third group.
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49 Enter these rotational keyframe values for lampRoll.

. Frame 5 with X0, Y0, and Z 0.

. Frame 13 with X 0, Y 14.684, and Z 0.
. Frame 25 with X 0, Y 24.42, and Z 0.
. Frame 36 with X 0, Y 44.193, and Z 0.
. Frame 50 with X 0, Y 45.633, and Z 0.
. Frame 56 with X 0, Y 45.633, and Z 0.
. Frame 62 with X 0, Y 48.153, and Z 0.
. Frame 56 with X 0, Y 45.633, and Z 0.

50 Select the main lamp spotlight and go back to frame 1 of the

animation.

51 Click on Visibility in the Channel Editor. It will become highlighted in
black.

e
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G| Curves Setict | Prirgr | Subeies | Detewmaten | Armsaton | Dy | Ferebores | Pari€iiects | Ol | Pl | | Cisbee |

(0N sdenPRInbacER L KN TS AIRL S
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Figure 5.21 Changing the visibility.
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52

53

54

55

56

57

58

59

60

61

62

63

64

65

66

67

68

69

70

RMB click on it to bring up the marking menu and choose Key
Selected.

Go to frame 49. Visibility should still be highlighted in the Channel
Editor.

RMB click on Visibility to bring up the marking menu and choose Key
Selected.

Go to frame 50.
Type ‘off’ in the Visibility slot.
Click on Visibility in the Channel Editor again to highlight it.

RMB click on Visibility to bring up the marking menu and choose Key
Selected.

Repeat steps 50 to 58 for the point light parented to the lamp.
Open the Outliner and select the outside spotlight.

Go to frame 1 of the animation.

Type ‘off’ in the Visibility slot of the Channel Editor.

Click on Visibility in the Channel Editor and RMB click to bring up the

marking menu.

Choose Key Selected.

Go to frame 55 and again key the visibility off.

Go to frame 56.

Type ‘on’ in the Visibility slot of the Channel Editor.
Choose Key Selected from the marking menu for Visibility.

Go to frame 1.

Open the Hypershade.
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Double click on the light bulb texture to bring it up in the Attribute
Editor.

RMB click on Incandescence to bring up the marking menu and choose
Set Key.

Go to frame 49.

RMB click on Incandescence to bring up the marking menu and
choose Set Key.

Go to frame 50.

Drag the Incandescence slider all the way to the left to turn off this
channel.

it |lightGlow ’—

S

Figure 5.22 Changing the incandescence.

- RMB click on Incandescence to bring up the marking menu and
choose Set Key.

- Save this file as fallingLamp.
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Forward Kinematics
Forward kinematics (or FK) animation is when you rotate each joint or pivot
individually. A character waving is a good example of FK.

1  To build an FK arm rig you would parent the hand to the forearm, the
forearm to the bicep, the bicep to the shoulder, and finally the shoulder
to the torso (see Figure 5.23).

' Persp Vicw

Figure 5.23 Character to add FK arm.

2 Create a new scene in Maya.

3 Create a new character. It doesn't have to be super-detailed for this
example. Just make sure that it has separate meshes for the hand,
forearm, upper arm, shoulder and torso. FK animation can also be
performed on a skeleton rig, but for this tutorial, we will use an even
simpler setup.

4  Select the hand and Shift select the forearm.
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5

6

7

Go to Edit > Parent or use the shortcut p.
Select the forearm and Shift select the upper arm.
Go to Edit > Parent or use the shortcut p.
Select the upper arm and Shift select the shoulder.
Go to Edit > Parent or use the shortcut p.

Select the shoulder and Shift select the torso.

Go to Edit > Parent or use the shortcut p.

00O o),

R L_shoulder

L_arm

>
R L_farearm
>

L_hand

Figure 5.24
FK parenting.

12

13

14

15

16

17
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Next you would need to move the pivot point for each piece so that it
will rotate in the proper place.

Select the hand and press Insert to edit the pivot point.
Move the pivot point to the wrist.

Select the forearm and press Insert to edit the pivot point.
Move the pivot point to the elbow.

Select the upper arm and press Insert to edit the pivot point.
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18

19

20

21

22

23

Move the pivot point to the shoulder.

Select the shoulder and press Insert to edit the pivot point.
Move the pivot point into the center of the shoulder.

Go to frame 1.

Rotate the arm into the starting position and keyframe its rotational
values. With FK you rotate the parent piece first then move down the
line. In this case you would start with the shoulder (the torso is acting

only as an anchor).

Continue rotating each piece and keyframing it at different positions in

the timeline until you have your finished wave.

FK is a great way to move the arms and upper torso around. Working with

forward kinematics lends itself to creating natural arcs of movement, which

happens to be one of the foundations for working in animation.

Inverse Kinematics

Inverse kinematics (IK for short) is, of course, the opposite of FK. With IK you

select the end node in the rig and move it to the desired position. Everything

else follows. Legs are a great example of what can be set up with IK. Setting up

a leg with IK allows you to move just the foot and the rest of the leg will follow.

Creating an IK chain requires a skeleton rig to be set up for your character.

Commonly known as character rigging, this is a highly advanced area of Maya.

1

2
3
4
5

Start a new scene.

Create a simple low polygons leg similar to the one in Figure 5.25.
Select Skeleton > Joint Tool.

In the side viewport click the joint tool near the hip to place a joint.

Move a tad and create the joint for the top of the leg. As joints are
connected they will be joined by triangular shapes known as bones.

Move down to the knee and click to add another joint. Make sure you

make this a bit bent, the same as a real knee.
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Figure 5.25 Leg for use with IK.

If\Persp View

Figure 5.26 Joint and bone.
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7 Move down again to the ankle and create a joint.

9
10
1
12
13
14
15

16

Place a couple more joints in the foot to finish it off.

Figure 5.27 Placement of the bones.

Go to Skeleton > IK Handle Tool.

Click on the ankle joint.

Click on the joint just below the hip.

This will create an IK solver and place a handle for you to move it.
Select the hip bone and Shift select the mesh.

Go to Skin > Bind Skin > Rigid Bind.

Select the ankle IK solver at the ankle.

Move it around and the rest of the leg follows.
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Persp ¥

Figure 5.28 Adding the IK solver.

Set Driven Animation

Set driven animations are a unique way to have one attribute change (or drive)
another attribute. Using driven keys, you could have an object fall when a
character nears it or have a bird’s wings flap when it flies in a specific direction.
Driven keys work by linking one attribute to another.

1 Create a new scene in Maya.

2 Create a pair of wings with the pivot points at the base. Name the left
one wing01 and the right wing02.

Group the wings using Edit > Group or the Ctrl + g shortcut.
Name the group wingDriver.
Press Insert to edit the pivot point of the group.

Snap the group to match the pivot point of the wings.

N o0 u b~ W

Press Insert to exit the edit mode.
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9

10

11

12

13

14

15

Figure 5.29 Wing.

Open the Channel Editor.
Go to Animate > Set Driven Key > Set > 0.

Select the wingDriver node and click the Load Driver button. The Driver
window is for the object that will control the driven keys. When you
load an object, it will be listed on the left side of the window. The right
side lists the attributes it will work with.

Select the two wings and click Load Driven. The Driven window is where
you place the object to be affected.

Move the group node -40 units on the Z axis.

Select the group node in the Driver window and click on translate Z in
the attribute section of the Driver window.

In the Channel Editor, change the translate Z to —40.

Select wing01 in the Driven window.
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1o/

Load Options Key Select Help

Driver

wizibility
translatek
translatey’
trarslates
rotates
rotate’’
rotates
srale
sraley’
saled

Driven

wizibility
H translate
tranzlate’
tranzlateZ
Totater
Totate’y’
rotates
Faler
soaley
sl

Key Load Diriver Load Driven Close | Figure 5.30 The Set
Driven Key window.

16 Click on rotate Z in the attribute section of the Driven window.
17 In the Channel Editor, change the rotate Z to 40.

18 Click the Key button in the Set Driven Key window.

19 Select wing02 in the Driven window.

20 Click on rotate Z in the attribute section of the Driven window.
21 In the Channel Editor, change the rotate Z to —40.

22 Click the Key button in the Set Driven Key window.

23 Select the group node in the Driver window.

24 In the Channel Editor, change the translate Z to -35.

25 Select wing01 in the Driven window.

26 Click on rotate Z in the attribute section of the Driven window.

27 In the Channel Editor, change the rotate Z to -10.
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28
29
30
31
32
33

34

Click the Key button in the Set Driven Key window.

Select wing02 in the Driven window.

Click on rotate Z in the attribute section of the Driven window.
In the Channel Editor, change the rotate Z to 10.

Click the Key button in the Set Driven Key window.

Repeat steps 21 to 32 five times, each time changing the Driver Z

translation by 5 and alternating between 40 and -10 Z rotation.

Save this scene as Wings.

Select the wingDriver group and move it around the perspective window.

Whenever it reaches the range you designated, the wings will begin flapping.

Driven keys are based on the attributes you set and not the timeline. This

means that the wings will flap anytime they move within the range you set up.

Blend Animations (Morphing)

Blend shapes (also known as morphing) changes one object into another. Blend

animations are commonly used for lip-syncing. Using the Blend Shape editor,

you can morph between as many targets as desired.

Create a new scene.
Set the animation length to 90 frames.

Build a face similar to the one in Figure 5.31 and name it ‘face’. This will
be the base object.

Duplicate the face four times. Name them faceBase, faceM, faceA, and
faceY.

Hide the original face model.

Shape faceBase to a neutral resting position. The original geometry is in
an unnatural open-faced position, which is a great starting point for
shaping the other nodes but not so good to use as the base position in

our blend animation.
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If\Persp View

Figure 5.31 Face to be used for blending.

Figure 5.32 Creating the base position.
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10

11

12

13

14

Shape faceM to form the letter M (see Figure 5.33). Move the vertices
into place, but do not merge or delete any. The default blending mode
is to blend between objects with identical vertex counts. There are
other blending modes available but | find that the default works best.

Figure 5.33 FaceM forming the letter M.

Shape faceA into the letter A.
Shape faceY into the letter Y.

In this order select faceM, faceA, faceY, and finally faceBase. The base
object is always the final selection.

Go to Deform > Create Blend Shape 3.
Name the BlendShape node faceBlend.
Set the Envelope to 1.

Set the Origin to Local.
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Persp Yiew

Figure 5.34 FaceA forming the letter A.

Figure 5.35 FaceY forming the letter Y.
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bt} Create Blend Shape Options

T —
iginn £+ Local ol

Figure 5.36 The Create Blend Shape window.

For Target Shape Options, select Check Topology.
Click Create.

Hide faceM, faceA, and faceY.

Go to Window > Animation Editors > Blend Shape.

Figure 5.37 The Blend
editor.
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Each shape node gets its own slider that ranges from off (0) to on (1), or
anywhere in between. You can also elect to keyframe the blend nodes
individually or all at once.

19 Go to frame 1 and set faceM to 0O, faceA to 0, and faceY to 0.
20 Press Key All.

21 Go to frame 10 and set faceM to 1, faceA to 0, and faceY to 0.
22 Press Key All.

23 Go to frame 20 and set faceM to 0, faceA to 1, and faceY to 0.
24 Press Key All.

25 Go to frame 30 and set faceM to 0, faceA to 0, and faceY to 1.
26 Press Key All.

27 Go to frame 40 and set faceM to 0, faceA to 1, and faceY to 0.
28 Press Key All.

29 Go to frame 55 and set faceM to 0, faceA to 0, and faceY to 0.
30 Press Key All.

31 Save your scene as faceBlend.

Figure 5.38 After the
blend.
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When you playback the animation, the shapes seamlessly blend into a talking

character. Also, once the blend is set up, you are free to tweak the faceBase

node. You can move it to a different spot or even run a smooth operation on it

without breaking the blend animation (see Figure 5.38).

Sound

Sound is often overlooked when creating an animation. But Maya allows you

to quickly add sound to your work environment to help make timing and

lip-syncing easier for you.

1

To add sound to your scene go to File > Import.

Change the type of file it is looking for to Audio.

Direct the importer to the audio file and click Import.

Right click on the Timeline
bar to bring up the marking

menu.

Select Sound to list all of the
current sound files loaded in
Maya. You can only have one
sound in your Timeline at
any one time. If you need to
load a different one, go
through the marking menu

again to pick the new sound.

Select the one you want.

Cuk
Copry
Paste [ 3
Delete
Snap
Kews
Tangents

[ Sound AT
Flayblast. .. )

Flayback Looping
et Range ta

b . .

Figure 5.39 Timeline marking menu.

The Timeline will display an audio line.

IH& 10
| |

15 20
I I I

Figure 5.40 Timeline audio.

Scrub the black bar back and forth in the Timeline to hear your animation.
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Motion Paths

Motion paths use a curve to define the motion of an object. A motion path
gives very nice flowing animations. Motion paths are ideal for such things as an
airplane flying overhead, a whale swimming through the sea, or even a camera

moving through your scene.
1  Start a new scene in Maya.
2  Set the animation length to 90.
3  Inthe top viewport create an S-shaped CV curve.

4  Create a polygonal cube on the Y axis with a width and height of one
and a depth of four.

Figure 5.41 Readying a motion path.

5 Select the cube then Shift select the curve.

6 Go to Animate > Motion Paths > .
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br}, Attach to Motion Path Options

Figure 5.42 Motion path options.

For Time Range select Time Slider.
Deselect Parametric Length.

Deselect Parametric Follow.

Click Attach.

The cube will snap the starting point of the curve. Numbers will also appear on
the curve designating the start and end points of the motion path.

Play the animation. As you can see, the cube moves along the path, but

it continues to face along its own axis.
Select the cube and open the Attribute Editor.
Click on the MotionPath tab.

Click the Follow checkbox.

Leave the World Up Type on Vector.
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™ PRrSn View

Figure 5.43 Moving along the path.

Figure 5.44 Object set to follow.
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10

Change the Front Axis to Z.
Change the Front Axis to Y.

Press play. The cube is now oriented correctly on the path, but it moves
too evenly throughout the scene.

Click the Bank checkbox.

Change the Bank Scale to 5. Now when you play the animation, the
cube will bank going into and exiting each curve.

Motion paths are also a good way to have an object move along the terrain.

Having a car drive along a road is quite easy to set up using a motion path.

w

N o o b

10
11
12

Start a new scene in Maya.
Set the animation length to 90.

In the top viewport create a NURBS plane with a width and length of
40 and U and V patches of 10.

Deform the CVs to create hills.
Select the plane and go to Modify > Make Live.
Use the Pencil Curve Tool to draw a curve on the surface of the plane.

Select the plane and go to Modify > Make Live to return the plane

to normal.

Create a polygonal cube on the Y axis with a width and height of one
and a depth of four.

Select the cube and Shift select the curve.
Go to Animate > Motion Paths > .
Set the Time Range to Time Slider.

Select Follow.
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13 Choose Z for the Front Axis.

14 Choose Y for the Up Axis.

15 Select Scene Up for World Up Type.
16 Deselect Inverse Up and Inverse Front.
17 Check Bank.

18 Set the Bank Scale to 1.

19 Press Attach.

Play the animation and the cube will follow the curve that exactly matches the

surface of the plane.

Figure 5.45 Attaching to a terrain.

1 Open the wings animation you made using set driven keys.

2 Create a looping curve similar to the one in Figure 5.46.
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Figure 5.46 Looping curve.

3 Create the curve so that part of it lies within the boundaries you
created for the set driven keys.

4 Select the wingDriver group node and shift select the curve.
5 Go to Animate > Motion Paths > Attach to Motion Path > 3.
6 Check Follow.

7 Set World Up Type to Normal.

8 Check Bank.

9 Set the Bank Scale to 1.

10 Click Attach.

Play the animation. The wings travel smoothly around the loop but when they
encounter the Set Driven Key range, the wings flap.
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Hint: The Front, Up, and Side Twist option are available when you manually create
a motion path using Animate > Motion Paths > Set Motion Path Key. But you can
still use them with a normal motion path. To do so, open the motion path in the
Channel Editor, RMB click on the twist you want to use and select Break
Connections from the marking menu. You can now enter twist values. Once done,
you should RMB click on the twist and choose Lock Selected.

Figure 5.47 Flapping wings on path.

Another use for motion paths is to use them as flow paths. A flow path causes

an

1

a b~ W

object to deform realistically along the path.
Create a new scene in Maya.
Create a reference to the snake you modeled previously.
Set the animation to 600 frames.
Create a squiggly curve in the top viewport.
Select the snake and Shift select the curve.

Go to Animate > Motion Paths >Attach to Motion Path > 3.
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Set the Time Range to Time Slider.
Check Follow.

Set the Front Axis to Z.

Set the Up Axis to Y.

Change the World Up Type to Scene Up.

Click Attach.

Play the animation. The snake follows the curve but, as you can see, its body
remains rigid. To fix this we need to create a flow attachment.

i+l Flow Path Dbject Dptions

Figure 5.48 Flow path options.

Select the snake.

following.

- Go to Animate > Motion Paths > Flow Path Object > 3. Input the
- Front Divisions of 300.

Up Divisions of 2.
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17 Side Divisions of 2.

18 Lattice Around set to Curve.
19 Check Local Effect.

20 Front Local Effect set to 15.
21 Up Local Effect set to 2.

22 Side Local Effect set to 2.

23 Click Flow. A lattice will appear along the length of your path.

Figure 5.49 Flow
lattice.

Play the animation and the snake will bend as it moves along the path. But keep an
eye out for problem places. In Figure 5.50, the geometry passes outside the flow
lattice, causing it to stretch.

24  To fix this go to Window > Outliner.

25 Select the ffdBase node and uniformly scale it out until the stretching
disappears.

26 Save this file as snakeMotion.
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Figure 5.50 Problems
along the flow path.

The Dope Sheet

Go to Window > Animation Editors > Dope Sheet. The Dope Sheet is based
on the traditional animation tool of the same name. The Dope Sheet is used to
help synchronize sounds and to edit keys.

-

Open your scene, bouncingBall.
2 Go to Window > Animation Editor > Dope Sheet.

3  Ifitis not checked, click on View > Scene Summary in the Dope
Sheet drop-down menu. The black marks in the view area indicate
keyframes.

4  Select the sphere in your scene. It will now show up in the Dope Sheet.
5  Click on the plus marks next to the sphere to expand the information for it.

6  Select Translate Y in the Dope Sheet outliner. All of the keyframes
associated with Y translation become highlighted.

7  Click the Move Keys button on the Dope Sheet status line.
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Figure 5.51 The Dope Sheet.
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Figure 5.52 The Dope Sheet status line.
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MMB select and drag the middle Translate Y keyframe five frames to

the left in the view area. The ball will bounce earlier now.
Select the middle Translate Y keyframe in the view area.
Delete the middle Translate Y keyframe.

Playback the animation and the sphere no longer bounces.
Undo the deletion.

Select Scene Summary to pick every keyframe in the scene.
Go to Edit > Scale > 3 in the Dope Sheet menu.

Change Method to Start/End.

Change New Start Time to 10.

Change New End Time to 20.

Click Scale Keys. The entire animation now plays between frames
10 and 20. You could also scale the frames out and make the animation

longer.

The Graph Editor

Go to Windows > Animation Editors > Graph Editor. The Graph Editor allows

you to edit animation curves. Fine-tuning a curve can go a long way toward

giving your animation that extra bit of polish.

1

2

Open your scene, bouncingBall.
Go to Window > Animation Editors > Graph Editor.

Select the sphere and it will appear in the Graph Editor. In the View
Area you will see red, green, and blue colored lines. These correspond
X (red), Y (green), and Z (blue).

Click on the plus next to the sphere in the Graph Outliner.

Select Translate Y. Selecting a single attribute will remove the other

attributes from the view.
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Figure 5.53 The Graph Editor.

Go to frame 16.

Click the Move Nearest Picked Key Tool from the Graph Editor Status
Line.

Select the middle keyframe in the view area and move it up. The sphere
will now bounce higher.

With the keyframe still selected, click on the Linear Tangents button
on the Status Line. The transitions into and out of this frame are now

very snappy.

Click on a keyframe. Tangents will appear for that frame.
Select a tangent with the MMB to edit it.
Click on a keyframe.

Click on the Break Tangents button. You can now edit each half of

a tangent separately.
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The Trax Editor

Go to Windows > Animation Editors > Trax Editor. The Trax Editor is
a non-linear animation tool which you can use to create animation clips

that blend into one another. You can even move the clips to change the

playback times.

-

A W DN

NV 00 N o O

tr] Trax Editor

Fle_Edt View Modfy Create Options Lbrary e

Open your scene, bouncingBall.
Use the Dope Sheet, delete all of the animation data on the sphere.
Open the Channel Editor.

Change the rotation values of the sphere back to 0 for the X, Y,
and Z channels.

Go to frame 1.

Key Translate X at —2.
Go to frame 16.

Key Translate X at 2.

Go to Window > Animation Editors > Trax Editor.

e EIEEE

Figure 5.54 The Trax Editor.
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- Select the sphere.

- Click Create > Character Set > 3 from the Trax Editor drop-down

menus.

trl Create Clip Dptions

Figure 5.55 Clip window.

Name the set ballMove.

For Character Set Attributes, select All Keyable.

Click Create Character Set.

Select the sphere again.

Go to Create > Clip > 0 from the Trax Editor drop-down menus.
Name the clip ballMove.

Select Put Clip in Trax Editor and Visor.

Choose Animation Curve for the Time Range.

Click Create Clip. The Trax window now has a bar representing the
animation you just created. The keyframes will disappear from the Timeline.

-
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Save this scene as ballForward.

Open the original bouncingBall scene.

Select the sphere.

Click Create > Character Set > 3 from the Trax Editor drop-down menus.
Name the set ballBounce.

For Character Set Attributes, select All Keyable.

Click Create Character Set.

Select the sphere again.

Go to Create > Clip > 0 from the Trax Editor drop-down menus.
Name the clip ballBounce.

Select Put Clip in Trax Editor and Visor.

Choose Animation Curve for the Time Range.

Click Create Clip.

Go to File > Create Reference and choose ballForward as the
reference file.

Open the Trax Editor.

Click the clip ballMove from the file you just referenced. It will turn

yellow, indicating it is selected.

Go to Edit > Copy in the Trax Editor drop-down menus.
Click anywhere in a gray area to deselect the clip.

Click on the ballBounce Character Set.

Go to Edit > Paste in the Trax Editor drop-down menus. This will copy
the clip from the referenced file directly into your scene. This is a vital
step for working with multiple trax clips. Maya will have interpolation
problems if you try to bring in clips from other sources using any other
method.
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Go to File > Reference Editor.

Expand the arrow and select the reference on the bottom portion of

the window.

Select Edit > Remove Reference from the Reference Editor drop-down

menus.

Press play. The sphere will bounce and move forward at the same time.
These are two distinctly different animations that are playing at the

same time.

Open the Trax Editor again. Each of the clips is a self-contained track of
animation that can be moved at your discretion.

Change your animation length to 45 frames. You can do this by simply
typing 45 in the End Time box on the Range Slider.

Drag the ballBounce clip to frame 16.

Play the animation. This time it moves forward before bouncing.
Drag the ballBounce clip back to frame 1 in the Trax Editor.
Click on File > Visor in the Trax Editor drop-down menu.

Click on the Character Clips tab of the Visor. You will see a source clip

for each of the clips.
Open the Channel Editor.
Click on ballBounce source clip in the Visor.

Click on ballBounce1 in the Outputs section of the Channel Editor. This
is a very important step. Make sure you are selecting the correct

output.
Change the Cycle to 2.

Select the ballMove source clip from the Visor. Be aware that because
you copied this clip from a referenced file the name will actually begin

with the name of the original reference.
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ballMove1

Figure 5.56 Output options.

Click the ballMove1 output in the Channel Editor.
Change the Cycle to 4.

Change the Offset to Relative. Click on where it says absolute and a
drop-down menu will appear.

Go to the Trax Editor and drag the ballMove clip so it ends at the same
frame as the ballBounce clip.

Change the End Time animation to 59.

Press play. The ball now bounces forward. The relative setting
forces a cycled clip to start each cycle from the end of the
previous one.

- Save this scene as bounceTrax.
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l ;' Trax Editor

balltdowe

Figure 5.57 Cycled clip.

You can layer as many clips as you need. The Trax Editor also allows you to
create blends between two animations, poses, and change animation times

without affecting the curves (called time warps).
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In Maya dynamics are the simulations based on physics. Rain, sparks, and
tumbling objects are all examples of dynamics. In Maya dynamics are split into
two distinct areas, particles and soft/rigid body.

Particle Effects

Particle effects are useful in creating fire, smoke, laser blasts, nebulae and
other voluminous matter. Body dynamics are for creating realistic impact and
reaction simulations. In addition, there is an Effects drop-down menu that has
preset F/X types available which utilize a mix of particles and body dynamics
to help you quickly create more common phenomena. To access the dynamics
toolset, press the F4 key or select the Dynamics drop-down from the Status

Line.

Particles  Fields Soft/Rigid Bodies Effecks  Solvers

Figure 6.1 The Dynamics menu set.

Select the Particles drop-down menu. An important thing to remember when
working with Maya particles is that most types need to be rendered using
Hardware Rendering. You will need to render the hardware particles in a
separate pass from the rest of your scene and add them to your animation

using a compositing program during post-production.

Hardware particles can be multi-point, multi-streak, numeric, points, spheres,
sprites, or streaks that you can animate with a variety of techniques including

keyframes, expressions, and fields.

Software particles can be a Blobby Surface, Cloud, or Tube. Software particles
can be animated just like hardware particles, but they have the added benefit of
being able to be rendered directly in your scene.

Particle Tool lets you manually place individual particles as desired throughout

your scene.

Create Emitter places an emitter and particle in the scene.
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Particle Tool

_reake Emitker
Ernit From Object

lse Selected Emitker

= s =

Per-Paoint Emission Rates

Make Collide )

Particle Collision Events. ..

izoal m
Instancer (Replacement) m
Sprite \Wizard. ..

Conneckt ko Time Figure 6.2 The Particles
drop-down menu.

Emit from Object turns the selected object into a particle emitter.
Use Selected Emitter binds the selected particles to the selected emitter.

Per-Point Emission Rates allows you to vary emission rate for individual

particles within omni or directional emitters.
Make Collide causes the selected particles to collide with selected geometry.

Particle Collision Events is used when you want particles to perform a special

function when they collide with geometry.
Goal specifies how much the particles are attracted to the object they are trailing.

Instancer (Replacement) is used to replace the selected particles with a specific

piece of geometry.

Sprite Wizard takes you through the creation of particle sprites step by step.
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Connect to Time is used to connect duplicated particle networks back to the

timeline.

Tutorial: Dragging Particles

1

2

VO 00 N o a
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Open bounceTrax.
Go to Window > Animation Editors > Trax Editor.

RMB click on the bounce clip and uncheck Enable Clip. The clip name

will gray out and the bounce animation will no longer play.

Press F5 or select Dynamics from the status line to open the dynamics

tools.

Go to Particle > Particle Tool > 3. Input the following settings.
For the Particle Name use Dust.

Set Conserve to 1.

Check Create Particle Grid.

Particle Spacing of 1.

For Placement select With Cursor.

Click near the left forward corner of the plane to place the first particle

point.

Click near the right forward corner of the plane to place the second

particle point. Do not press Enter yet.
Press the Insert key to go into edit mode for the particles.
Drag the second particle point to the rear right corner of the plane.

Go to the front or side viewport and drag the second particle point up

one unit.
Press Enter. You will now have a 3D particle grid in your scene.
Select the particle grid.

Go to Fields > Air > 3. Enter the following settings.
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Figure 6.3 3D particle grid.

19 Select Wake.

20 Change the Magnitude to 3.

21 Check Enable Spread.

22 Change the Spread to 1.

23 Check Use Max Distance.

24 Set the Max Distance value to 8.

25 Click Create.

26 Move the airField behind that sphere as in Figure 6.4.
27 Parent the airField to the sphere.

28 Press play. The particles will move as the field passes through them.

The particles currently have a default texture assigned to them. Generally you

will want the particles to vary over their lifespan.
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Figure 6.4 Positioning the airField.

Figure 6.5 Animated particles
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- Select the particle grid and go to the Attribute Editor.

- Expand the Add Dynamic Attributes section.

Figure 6.6 Add Dynamic Attributes.

- Click on the Color button in the Add Dynamic Attribute section.

- In the Particle Color window, choose Add Per Particle Attribute.

bl Particle Colar l_l_ | - Click Add Attribute.

- In the Attribute Editor,
expand the Per Particle
(Array) Attributes section.
As you add particle
attributes, the new

attributes will appear

Figure 6.7 Particle Color window. here.

Figure 6.8 Per Particle Attributes.
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- RMB click on rgbPP, drag to Create Ramp and release. An Array mapper
node will appear in the rgbPP box.

RMB click the arrayMapper node and select Edit Ramp.

The ramp will open in the Attribute editor.

Figure 6.9 Particle color ramp.

Select the green circle to activate the color channel.

Click on the Selected Color swatch to bring up the Color Chooser
window.

Change the color to a bright yellow.
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Repeat steps 38 to 40 for the blue channel, but pick a purple color this
time.
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Play the animation.
Go to the particle shape node in the Attribute Editor.
Expand the Lifespan Attributes section.

Change Lifespan to 2. The particles now live for 2 seconds rather than

the default 1.

Save this scene as sphereWake.

Using the particle attributes allows you to customize everything from size, to
randomness, to velocity. You can also use Expressions to drive the attributes to

get even more realistic results.
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Rendering is the output of a Maya scene as a 2D image. This image could be a
high-resolution still for use in a magazine ad, or it could be an animated
sequence ready to playback on a TV. Finding the right render settings is
dependent on the final medium used for viewing the images. In general, print

requires the highest resolution images, followed by film, games, and lastly TV.

Rendering times can be significant, so keep that in mind when you begin working
on your scene. A high-resolution, fully anti-aliased image could potentially take a
couple of hours to render just one frame. Imagine if you tried to render out an

animation with similar settings: 24 seconds of animation would take 48 hours.

Rendering a Scene

Press F5 or select Rendering from the Status Line. Go to Window > Rendering
Editors > Render Globals.

Lighting/shading Texturing Render Paink Effects

Figure 7.1 The Rendering set.

Il Render Global Settings = Inlﬂ

Edit Presets Help

Render Using | tdapa S ofbware 'l

Comman | Maya Saftware I

Path: C:/lazson/Focal/Focal chapters/Renderingfimages/
File Mame: untitled

|_P| Image File Output ﬂ
EI Reszolution

m Render Options. LI

Cloze i

Figure 7.2 The default render globals.
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Maya 5 comes standard with four rendering engines: Maya Software, Maya
Hardware, Mental Ray, and Maya Vector. Please note that Maya 5 Personal
Learning Edition does not include the Mental Ray or Vector renderers. The
default rendering engine is Maya Software. To use a different renderer select it

from the Render Using option at the top of the globals window.

The Common tab is used by all four of the renderers. This is where you set the
project’s resolution and image output format. When you use the Render Current
Frame or IPR shortcuts, it uses the resolution you set here.

Hint: It's a really good idea to set your resolution at the beginning of the project so
you don't accidentally compose your scene to the wrong aspect ratio. If you want to
change the render globals to output a lower resolution to speed up your work
always keep the same aspect ratio. For example, if your original scene is 640 X 480
and you need to render a low-res test, output it at 320 X 240.

Settings

When you are ready to render your scene open the Render Globals and make
sure you have the correct settings in the Image Output Settings.

Any render you make will default to the Images folder of your current project. For
every new render, you will need to set the following.

File Name Prefix is the name that you would like to call your render. Type in a

name, otherwise it will default to the name of your current scene.

Frame/Animation Ext is set to single frame by default. If you are rendering an
animation, select one of the other options. | always use name#.ext when
rendering an animation as it make it much easier to load the sequence into

post-production editing programs later.

Image Format needs to be set to your desired output format. The benefits for
using Targa files for both single frame and as sequential frame animations
cannot be stressed enough. Render out as a Targa sequence and recompile
the frames in a video-editing program if available. Otherwise use AVI for your

animations.
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trl Render Global Settings

refis |[hat set; uzing filename)
b | narme. ext [Single Frame] l_
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Figure 7.3 Image
output settings.

Start and End Frames should be set to match the length of your animation.
It defaults to end at frame 10.

By Frame should be set to 1.
Renderable Objects should be set to 1.

Camera needs to be the camera that you used to compose your scene.
RGB Channel (Color) needs to be checked.
Alpha Channel (Mask) should be checked if it is needed.
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Rendering Using Maya Software
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Open your animation file, fallingLamp.

Go to Window > Rendering Editors > Render Globals. Input the
following.

Render Using Maya Software.
Frame/Animation Ext set to name#.ext.

Image Format set to AVI. Normally | would render a Targa sequence,
but not everyone has access to a video post-editing program to
recompile the frames so we'll use AVI for now.

Start Frame of 1.

End Frame of 150.

By Frame 1.0.

Renderable Object set to Render All.
Camera set to cameral.

Go to the Resolution section and set the Width and Height to 512 X 512.
Click on the Maya Software tab.
Expand the Anti-aliasing Quality tab.
Change Quality to Production.
Expand the Raytracing Quality tab.
Check the Raytracing box.

Set Reflections to 5.

Set Refractions to 5.

Set Shadows to 10.

Click on the Motion Blur section.

Check the Motion Blur box.
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22 Set Motion Blur Type to 2D.
23 Close the Render Globals window.

24  Go to Render > Batch Render > 0 to bring up the Batch Render window.

i Batch Render Frame  _ IQ Ii[

[~ illze all Available Processors

Mumber of Processors to Use |'|

Batch Render | Close

Figure 7.4 Batch Render window.

25 Check Use All Available Processors.
26 Click Batch Render.

27 The Command Feedback line will display the rendering progress for
your animation. When it's complete, open the Images folder and play

the AVI file to see the final result.

Rendering Using Maya Hardware

Maya Hardware rendering is the only way to render many of the available
particles. Hardware rendering is very fast. It actually uses processing power
from your video card during the render stage to help speed things up. The
downside to Hardware rendering is that the quality is not as good as Software
mode. However, the quality is fine for particles because they are points or

streaks as opposed to a full character walking about.

1 Open sphereWake.

2 Render the current frame. The sphere and plane appear just fine, but
the particles are nowhere to be seen.

3 Go to Window > Rendering Editors > Hardware Render Buffer. The
Hardware Render Buffer is where you set up your scene to be rendered

with the aid of your graphics card.
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Figure 7.5 Hardware
render buffer.

4 In the Cameras menu select the camera you want to render from.

[}

Go to Render > Attributes on the Hardware Render menu. This will
open the Hardware Render settings in the Attribute Editor.

Enter ‘test’ as the name.
Start Time of 1.

End Time of 59.

NV 00 N O

By Frame of 1.

10 Image Format set to Targa. Note that in the hardware buffer, you can
only render out image sequences.

11 Set the Resolution to 640 X 480.

12 Alpha Source set to Hardware Alpha.
13  Check Write ZDepth.

14 Click on the Render Mode section.

15 For Lighting Mode select Default Light.
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16 Check Texturing.

17 Check Line Smoothing.

18 Check Full Image Resolution.

19 Check Geometry Mask. This will turn off the geometry at render time.
20 Go to Window > Rendering Editors > Render Globals.

21 Click the Maya Hardware tab.

22 Set the Quality Presets to Production Quality.

23 Go to Render > Render Sequence on the Hardware Render menu.
This will render out the specified sequence. It's very important that you
don’t do anything while the sequence is rendering. Maya is actually
taking screenshots of the buffer so if you move your mouse over it
your final sequence will have unwanted extras.

24 Once the sequence is done click on Flipbook > test to playback the

sequence.

Rendering Using Mental Ray

Mental Ray is a renderer that has been around for quite some time but only
recently became available for use with Maya. It has proved to be so popular
that in Maya 5 it is fully integrated into the program. Mental Ray is a superior
photo-realistic renderer that excels at rendering caustics and global illumination
effects. Be forewarned: the quality when using Mental Ray can be exceptional
but the rendering times can increase significantly.

1 Open your three-point lighting scene, threeLighting.

2 Adjust the camera angle to look down at the sphere.

3 Hide the fill and back lights. For this tutorial, we want to see what

Mental Ray can do on its own.
4 Open Window > Rendering Editors > Render Globals.

5 For Render Using, select Mental Ray.
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Figure 7.6 Mental Ray globals.

Click on the Mental Ray tab.

Open Window > Rendering Editors > Render Globals.
For Render Using, select Mental Ray.

Click on the Mental Ray tab.

Expand the Quality tab.

Choose Custom Quality.

Expand the General Tab.

Check the Ray Tracing box.
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Set Max Reflection Rays to 10.

Set Max Refraction Rays to 10.

Set Max Ray Depth to 20.

Expand the Caustics and Global lllumination section.
Check the Global lllumination box.

Set Max Reflection Photons to 10.

Set Max Refraction Photons to 5.

Set Max Photo Depth to 5.

Check the Photon Map Rebuild button.

Expand the Final Gather button and check the Final Gather box. Close

the Render Globals window.

Select the sphere and click on the Transform tab in the Attribute
Editor.

Expand the Mental Ray section.
Uncheck the Derive From Maya box.
Change Caustic to Cast+Receive.
Change Globillum to Cast+Receive.

Select the box mesh and click on the Transform tab in the Attribute
Editor.

Expand the Mental Ray section.
Uncheck the Derive From Maya box.
Change Shadow to Yes.

Change Caustic to Cast+Receive.
Change Globillum to Cast+Receive.

Open the Hypershade.
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Create a Phong material and assign it to the sphere. Keep the default

settings.

Create a Lambert Material and assign it to the box. Keep the default
settings.

Select the Key light and expand the Mental Ray section in the Attribute
Editor.

Expand the Caustic and Global lllumination section.
Check the Emit Photons box.

Change the Energy to 2500, 2500, 2500.

Set the Exponent to 2.

Set the Global Illum Photons to 10000.

Save the scene as mentalGlobal.

Render the scene. Notice how Mental Ray’s global illumination gives

added realism to the scene.

Figure 7.7 The rendered sphere.
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Mental Ray also renders caustic effects. An example of caustics would be the

rippling light shimmering on the bottom of a swimming pool.
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Open the mentalGlobal scene.

Open Window > Rendering Editors > Render Globals.
For Render Using, select Mental Ray.

Click on the Mental Ray tab.

Expand the Quality tab.

Choose Custom Quality.

Expand the General Tab.

Check the Ray Tracing box.

Set Max Reflection Rays to 4.

Set Max Refraction Rays to 4.

Set Max Ray Depth to 4.

Expand the Caustics and Global Illlumination section.
Check the Caustics box.

Change Caustic Filter Type to Cone.

Check the Global lllumination box.

Set Max Reflection Photons to 5.

Set Max Refraction Photons to 5.

Set Max Photo Depth to 7.

Check the Photon Map Rebuild button.

Expand the Final Gather button and check the Final Gather box.
Close the Render Global window.

Select the sphere and click on the Transform tab in the Attribute Editor.
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Expand the Mental Ray section.
Uncheck the Derive From Maya box.
Change Caustic to Cast+Receive.
Change Globillum to Cast+Receive.

Select the box mesh and click on the Transform tab in the Attribute
Editor.

Expand the Mental Ray section.

Uncheck the Derive From Maya box.

Change Shadow to Yes.

Change Caustic to Cast+Receive.

Change Globillum to Cast+Receive.

Open the Hypershade.

Create a Phong material and assign it to the sphere.
Expand the Common Material Attributes section.

Click the Transparency color box and change the values to R 26,
G 160, and B 226.

Change the Diffuse value to .250.
Expand the Mental Ray section.
Expand the Photon Attribute section.
Uncheck the Derive From Maya box.

Press the Take Settings From Maya button. This will import the material
information from the Common Attributes section.

Change the Refractive Index to 1.3.
Check the Refractions box.

Check the Absorbs box.
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45 Create a Lambert material and assign it to the box.
46 Change the Diffuse value to .9.

47 Select the Key light and expand the Mental Ray section in the Attribute
Editor.

48 Expand the Caustic and Global lllumination section.
49 Check the Emit Photons box.

50 Change the Energy to 5000, 5000, 5000.

51 Set the Exponent to 2.

52 Caustic Photons to 15000.

53 Set the Global lllum Photons to 6000.

54 Save the scene as mentalCaustics.

55 Render the scene to see the caustic effects.

Figure 7.8 The sphere rendered using caustics.
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Rendering Using Maya Vector

The Maya Vector rendering engine creates images with a cartoon-like quality.
You control options like line edge width and internal shading to output line art
or cartoon-like images. Maya Vector can also render directly into vector format

for use on the web or within a vector-based art program.

Below are some things to be aware of when building a scene for use with Maya

Vector rendering.

Bump maps will not render using Maya Vector so any shading nodes using
bump maps will need to be rebuilt.

Figure 7.9 The fallingLamp animation rendered using Maya Vector.

183



THE FOCAL EASY GUIDE TO MAYA 5

Point lights are the only type of light supported.

Image planes and particles are not supported.

Cameras

Understanding cameras is crucial in getting good images from Maya. Thankfully
Maya’s cameras work on the same principles as real-world ones. You have three

options when creating a camera.

e Camera — Places just the camera in
Cameras =

your scene.
Carnera o
Camera and Aim — Places a camera

Camera and Aim o with the lens constrained to always

Camera, Aim, and Up m ) look at a specific node.

Figure 7.10 Camera creation. Camera, Aim, and Up - Places an
up constraint in addition to the aim.
1  Start a new scene in Maya.
2  Set the animation length 60 frames.
3  Go to Create > Camera > Camera and Aim.
4 Go to Create > NURBS Primitives > Sphere.
5 Go toframe 1.
6  Open the Channel Editor.
7 Change Translate X to -10.
8 Change Translate Z to -10.
9  Press the s key to keyframe all attributes for the sphere.

10 Go to frame 30.
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Figure 7.11 The three
camera types.

Change Translate X to 0.

Change Translate Y to 10.

Press the s key to keyframe all attributes for the sphere.
Go to frame 60.

Change Translate X to 10.

Change Translate Y to O.

Press the s key to keyframe all attributes for the sphere.
Go back to frame 1.

Select the aim constraint.

Snap move it to the sphere.

Shift select the sphere.

Parent the aim to sphere.
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Play the animation. The aim constraint is now parented to the sphere and

will move with the sphere during the animation. The camera is still attached

to the aim constraint and will continue to follow it throughout the animation.

This is a great way to create follow-shot animations. The constraints make

it easier to track your camera’s aim, but aside from that all cameras function

the same.

1 Create a new scene.

2 Go to Create > Camera > Camera.

3 Go to Create > NURBS Primitives > Sphere.

4 In your viewport menus, select Panel > Perspective > cameral. This will
change you to the camera view. This menu will list as many cameras as
you have loaded in your scene.

5 While in camera view, use the Alt + mouse dolly, zoom, and tilt controls
to center the sphere in the camera’s view. This allows you to interactively
move the camera in your scene. If you are unhappy with the moves use
the [ key to undo your last viewport move. The | key will redo the
viewport move.

6 Open the Channel Editor.

7 Change Translate Y to 5.

8 Change Translate Z to -10.

9 Change Rotate X to -25.

10 Enter O for the other translation and rotation channels if needed.

11 With the camera selected, open the Attribute Editor to see the default
camera values.

12 Adjusting the Focal Length changes the view without moving the objects.

It's important to remember that the Maya camera functions in the same way as

a real-world camera. By simply changing your camera settings you can

dramatically alter the appearance of your scene.
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Figure 7.12 The default camera focal length of 35.

Figure 7.13 Focal length of 10.
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Figure 7.14 Focal length of 75.

Tip: The Display Options section displays white lines, which do not render, in the
camera view allowing you to see what will and will not be included in the final
rendering of your camera view. | generally check Display Resolution, Display Action,
and Display Safe Title.

1  Open your outdoorLighting scene.

2  Select your camera and open the Attribute Editor.

3 Go to the Display Options section.

4  Turn on Display Resolution, Display Action, and Display Safe Title so you

can make sure you are working within the proper frame areas.

5 Go to the Camera Attributes Section adjust the Clipping Planes if you
cannot see any pieces of your geometry that should be there. When
working with either a very small scene or with terrain chunks spaced
extremely far apart, geometry might fall outside of the visible area
known as a Clipping Plane.
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Figure 7.16 Camera Environment tab.

Go to the Environment Section in the Attribute Editor.
Click on the Create button next to Image Plane.
Expand the Placement rollout section.

If needed, change the Depth for the Image Plane. The Depth indicates
how far from the camera the Image Plane will be located. You can
create multiple Image Planes and stack them to get unique background.
Just remember to change the Depth of each Image Plane so they will
render in the proper order.

Expand the Image Plane Attributes rollout section.

Change Type to Texture. This unlocks the Texture bar directly below.
Click on the checkered box next to Texture.

In the Create Render Node, expand the Environment Textures section.
Click on Env Sky. The Env Sky (or environment sky) procedurally creates

atmospheric conditions.
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j Atmospheric Settings

Sky Brightness
Air Denzity (1.000 F
Dust Density |0.000 'f
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Figure 7.17 Env Sky attributes.

In the Sun Attributes section change the Elevation to 80. This will put

the sun almost directly overhead.
In the Atmospheric Settings section change the Sky Thickness to 500.
In the Cloud Attributes section check Use Texture.

Click the checkered box next to Cloud Texture.

Figure 7.18 Added sky.
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In the Create Render Node window select Fractal from the 2D textures

section.

Expand the Fractal Attributes section.

Change Frequency Ratio to .917.

Expand the UV Coordinates section and click on the Inputs box.
Change the Coverage to 1.5 for U and 1.5 for V.

Change Repeat UV to 1.5 for U and 3 for V.

Go back to the Env Sky node in the Attribute Editor.

Click on the Cloud Attributes section.

Change the Altitude to .09.

Save your scene.

Other Rendering Options

Most of the options in the Rendering menu are accessible elsewhere. The

Lighting/Shading drop-down menu tools can also be manipulated through the

Hypershade and through Window > Relationship Editor.

Start a new scene in Maya.
Create a 40 X 40 NURBS plane.
Select Texturing > 3D Paint Tool > 3.

Try painting your initials on the plane. A red X will appear and you will
see the error message in the Command Feedback line that says

// Warning: Some surfaces have no file texture assigned to the current
attribute. // The error message appeared because we need to actually
set up an image to paint with first.

Create a Lambert material in the Hypershade and assign it to the plane.

In the Attribute Editor for the 3D Paint Tool, expand the File Texture

section.
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Figure 7.19 3D Paint tool.

bl Assign/Edit File Textures

Figure 7.20 The Assign Textures prompt.

Set the Attribute to Paint to Color.
Set the Image Format to Targa (tga).

Click on Assign/Edit Textures. A window will pop up prompting you for
the texture dimensions.

Set the X size to 256.
Set the Y size to 256.
Click Assign Texture.

Now paint your initials on the plane. Black letters appear; altogether
not very exciting.

Expand the Brush section in the Attribute Editor.
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Figure 7.21 The Brush section.

15 Click on the Paint Effects Get Brush button. The Visor will appear.
16 Click on the Paint Effects tab.

17 Select the metal directory from the folder list on the left.

Figure 7.22 Metal initials.
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Click on the metalweave icon on the right-hand side.

Paint your initials on the plane again. This time it will be a weaved metal

texture.

Create a large sphere and place it behind the plane. If you render the

scene now the sphere will be blocked from view by the plane.

Go to the Brush Settings in the Attribute Editor and resize the Brush
Scale to 10.

Paint the weave metal over the entire plane.

Figure 7.23 Metal plane.

Go to the File Textures section and change the Attribute to Paint to

Transparency.
Click Assign/Edit Textures.
At the prompt, set the X and Y to 256 and click Assign.

Paint the entire plane a second time.
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If you render the scene, the sphere will now be visible on the other side of the
plane. The second painting pass you made solely affected the transparency

channel. You can repeat as needed, painting a different channel each time.

Figure 7.24 Transparent metal plane.
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Maya Paint Effects is a module that allows you to paint custom effects directly
in your scene. You can paint either in 2D, just like painting on a traditional
canvas or you can paint directly within 3D space.

The Paint Effects Panel

Go to Window > Paint Effects to open the Paint Effects Panel. The Paint Effects
Panel defaults to the perspective view, but you can switch to orthogonal views
by selecting the Camera menu along the top toolbar. The Paint menu allows

you to switch between working on a canvas and the current scene.

aint Etfects

Figure 8.1 The Paint Effects Panel.

Working with Brushes

1  Start a new scene in Maya.

2 Go to Window > Paint Effects. Figure 8.2 Paint menu.
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3  Select Brush > Get Brush or click the Get Brush button on the toolbar.

The Visor window will appear. The Visor lets you view thumbnails for

things like textures, shading nodes, and character.

File_Yiew Tobs _Hel

Paint Elfecs | Ooean Examples | Fhid Examples | Fd Iriisl States | Character Cips | Charaster Poses | Uruised Cips | Unused Pases | Projects |

-] airbrush
-] animal

[—:Ij C:fProgram [ilesfAliasWavefrontMayab. Ofbrushes! ﬂ

] rityMesh
77 clouds

-7 alectrical
- feathers
- fibers

-7 fire

-7 flesh

-] Nowers

+ 21 flowarsMash
- food

- foodMesh
-] un =

Figure 8.3 Visor.

Click the Paint Effects tab and select the grasses folder from the
left-hand folder list. The available grass brushes will appear on
the right.

Click the largeFlames icon.

Paint some squiggles in the Paint Effect panel. Some shaded lines will

appear in the window as well as in your main Maya scene.

Render the current frame. Paint Effects often uses simple lines or points
to represent Paint Effects in your scene; this helps to avoid Maya
getting bogged down. Any time you render, the full effect will

be visible.

Select Brush > Edit Template Brush or click the Edit Template Brush
button on the toolbar. The Paint Effects Brush Settings window
appears. This contains all of the information pertaining to the currently
selected brush.
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Pr} Paint Effects Brush Settings

Figure 8.4 Brush Settings.

Change the Global Scale of the flame brush to 10.

Paint some more large flames in your scene. You can mix and match

brush sizes.

Close the Paint Effects panel and click the Play animation button. The

lines move slowly.

Render this current frame and you can see that, yes, the flames are
animated.

Paint Effects can also be used to paint directly onto a NURBS surface. Maya
only supports painting effects on NURBS surfaces, but you can get around this

very easily.

- Start a new scene and create a default NURBS sphere.

- Go to the Rendering menu set.
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3 Select the sphere and Go to Paint Effects > Make Paintable.

4 If it is not currently checked, select Paint Effects > Paint on Paintable
Objects.

5 Go to Paint Effects > Get Brush. For this exercise, we will be working

directly in the scene.
6 Click on the hair folder and select hairThickBlond.

7 In the perspective view, paint some lines on the sphere. Notice how the

curve follows the sphere.

Figure 8.5 Hairy ball.

8 Select the sphere and open its Shape node tab in the Attribute Editor.
9 Expand the Render Stats section and uncheck Primary Visibility.

10 Render the scene again. The sphere is no longer visible.
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Figure 8.6 Hair.

Using this method, you can easily create paint effects to match any object you
would like by building an underlying NURBS template. If you need the paint
effect to move with another object, simply group the paint nodes together and

parent the group to the new object.

Mesh Brushes

New to Maya 5 are Mesh Brushes and the ability to convert a brush into
polygons. Mesh brushes render with particles rather than the standard brush
stamp. This makes for an even more realistic rendering. Converting a brush to
polygons allows you to then edit in scene as you would any other geometry.

1 Create a new scene.
2  Go to Paint Effects > Get Brush. For this exercise, we will be working

directly in the scene.
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3 In the Visor, select the grasses folder and click the grassWindWide icon.

4 Go to Paint Effects > Template Brush Settings and change the Global
Scale to 2.

5 Paint a simple grass curve.
6 Press Play and you can see that the grass Paint Effect is animated.

7 Select the strokeGrassWindWide node in the Outliner. Make sure you
select the stroke and not the curve.

8 Go to Modify > Convert > Paint Effects to Polygons.
9 Select and hide strokeGrassWindWide.

10 Press Play and you can see that the new polygonal grass animates as well.
It will continue to animate with the grass effect until the History is deleted.

The curve you draw as you create an image with Paint Effects is known as the
stroke. Any object that sprouts from the stroke is a Tube.

1 Create a new scene in Maya.

2 Set the animation to 180 frames.

Figure 8.7 Setting the
scene.
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Create a NURBS sphere.

Go to Paint Effects > Get Brush. For this exercise, we will be working
directly in the scene.

In the Visor, select the glows folder and click the laserGlow icon.
Starting from within the sphere, paint a simple arc.
Select the sphere and go to Paint Effects > Make Paintable.

Go to Paint Effects > Get Brush. In the Visor, select the fire folder and
click the largeFlame icon.

Paint a single flame curve around the top of the sphere.

Go to frame 1.

Figure 8.8 Adding the
flame.

Select the laserGlow stroke and open it in the Attribute Editor.
Click the shapenode tab and expand the End Bounds section.

Set the Min Clip to 1, RMB click on it and select Set Key from the

marking menu.
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Go to frame 60.

Set the Min Clip to 0, RMB click on it and select Set Key from the

marking menu.

Click the laserGlow tab in the Attribute Editor and expand the Tubes

section.
Expand the Creation section.

Still at frame 60, set the Length Max to .244, RMB click on it and select
Set Key from the marking menu.

Go to frame 61, set the Length Max to 0, RMB click on it and select Set

Key from the marking menu.
Select the largeFlame stroke and open the Attribute Editor.
Go to frame 1.

Click the largeFlames tab in the Attribute Editor and expand the Tubes
section.

Expand the Creation section.

Set the Length Min to 0, RMB click on it and select Set Key from the

marking menu.

Set the Length Max to 0, RMB click on it and select Set Key from the
marking menu.

Go to frame 61.

Set the Length Min to 0, RMB click on it and select Set Key from the
marking menu.

Set the Length Max to 0, RMB click on it and select Set Key from the

marking menu.
Go to frame 120.
Set the Length Min to .020, RMB click on it and select Set Key from the

marking menu.
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31 Set the Length Max to .150, RMB click on it and select Set Key from the
marking menu.

32 Play the animation. The fuse zips down the fuse and ignites the sphere.
Using this workflow, you can create any number of Paint Effects
animations.
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Maya's user interface was built from the ground up using a proprietary scripting
language called Maya Embedded Language (MEL for short). As you work in the
Maya Ul, MEL scripts are executing in the background. Alias provides access to

the MEL language to allow artists to further enhance their work.

The scripting tools are split into two tools, the Command Line and the Script
Editor. Everything is text based so you can copy, paste, and delete as needed.
The Command Line

The Command Line is for entering single-line MEL commands (see Figure 9.1).
Simply type the command you wish to execute into the Command Line and

press Enter.

Enter gsimple MEL cornmands here.

Figure 9.1 The Command Line.

The Script Editor

The Script Editor is for executing advanced scripts (see Figure 9.2). Open the
Script Editor by going to Window > General Editors > Script Editor or by
selecting the shortcut icon on the right edge of the Command Line. The Script
Editor is divided into a top history section and a bottom input section. The
History section displays any commands you run and lists any error messages.

When working with the Script Editor it is important to remember that the main
keyboard Enter key is used to go to the next line, whereas the numeric Enter
key will execute the selected script. Also, if you highlight the script before you
press the numeric key, it will remain in the window. If the text is not highlighted

when you press Enter, it will be cleared from the Input window.

For example, suppose you have a large number of alternating NURBS and
polygonal objects in a row in your scene. If you wanted to make a copy of just
the polygonal cubes, and rotate the duplicates to make a column, MEL
scripting would be the best way to achieve this.
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bl Script Editor

Figure 9.2 The Script Editor.

- Open the Script Editor.
- Type the following in the bottom Input Window.

select -r “listTransforns “-type nmesh”’;
group; xform-os -piv 0 0 O;

sel ect groupl;

rotate -r 0 90 O;

- Click and drag to highlight the text.
- Press the Enter key on the numeric keypad.
- The polygonal objects will rotate under a new group.

Working with shelves is a very easy way to access your tools. Highlight the
script you created and using the MMB drag it up to a shelf. An icon will
be created. You can simply press this button whenever you need to run the

script.
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File Edit Script Help
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Figure 9.3 Selected text in the Script Editor.

Copy the following text into the Script Editor and execute it.

| oadNewshel f “shel f _General . nel ”;

| oadNewShel f “shel f _Curves. nel ”;

| oadNewsShel f “shel f _Surfaces. nel”;

| oadNewshel f “shel f _Pol ygons. el ”;

| oadNewShel f “shel f _Subdi vs. nel ”;

| oadNewsShel f “shel f _Defornation. nel”;
| oadNewsShel f “shel f _Ani mati on. mel ”;
| oadNewShel f “shel f _Dynami cs. nel ”;

| oadNewsShel f “shel f _Rendering. nel ”;
| oadNewshel f “shel f _Fl ui ds. nel ”;
saveAl | shel ves $gShel f TopLevel ;

This will ensure you have the more useful features for the shelves loaded and it
will save your shelves so they will remain when you next run Maya.

A very useful feature of the Script Editor is the Echo All Commands. This is
located in the Script menu of the editor window. When enabled, everything you
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do in Maya is listed in the history window of the Script Editor. Using this
command, you quickly see the commands for any function. In fact, simply
copying the echoed history of commands into your own scripts is often
enough to create unique MEL scripts. Scripts can be saved or created in any

text editor.

Here is one useful script that will help you in creating low-polygon characters.
The double slashes (//) will comment out that particular line so that Maya will
ignore it during execution. This allows you to enter in specific comments
anywhere during the length of the script. Also, notice that there is a lot of
extra space in the body of the script. Maya does not require the extra space,
but it does help organize it for easier reading in case there is a problem.

/[ Hal f Cube

I

I

/' Aut hor: Jason Pat node
I

/I Description: Creates a cube for |ow pol ygon
//mrror nodeling. Creates cube, deletes half of the
//faces and positions the cube to the proper point on
//the grid. Creates a snoothed copy of these as a

/I nodel i ng ai d.

{

polyCube -w 1 -h 1 -d 1 -sx 3 -sy 3 -sz 3 -ax 010
-tx 1 -ch 1;

updat eConponent Sel ect i onVasks;

aut oUpdat eAt t r Ed;

updat eObj ect Sel ect i onMasks;

{
sel ect -r pCubel.f[51];

aut oUpdat eAt tr Ed;
select -tgl pCubel.f[52];

aut oUpdat eAt t r Ed;
select -tgl pCubel.f[53];
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}

aut oUpdat eAt t r Ed;
select -tgl
aut oUpdat eAt t r Ed;
sel ect -tgl
aut oUpdat eAt tr Ed;
select -tgl
aut oUpdat eAt t r Ed;
select -tgl
aut oUpdat eAt t r Ed;
sel ect -tgl
aut oUpdat eAt tr Ed;
select -tgl
aut oUpdat eAt t r Ed;
del et e;

pCubel. f[50];

pCubel. f[49];

pCubel. f [ 48] ;

pCubel. f[ 45];

pCubel. f [ 46] ;

pCubel. f [ 47];

aut oUpdat eAt t r Ed;

changeSel ect Mbde -obj ect;

select -r
changeTool | con;

pCubel;

updat eObj ect Sel ect i onMasks;
aut oUpdat eAt t r Ed;

ct xEdi t Mode;
snapMode -point true;
move -x 0.5 -spr -rpr;

Ent er Edi t Mode;

snapMode -point false;

instance; scale -r -1 1 1; group
move -x -0.5 -spr -rpr;
sel ect -r pCubel;

pol yDupl i cat eAndConnect ;

nmove -z -5 -spr
select -r

pCube3. f[0: 44];
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-rpr;

group pCubes;
group pCubes3;

pCube3. f[0: 44];
pol ySmooth -dv 1 -c¢c 1 -kb 1 -ksb 1 -kt

pCube2;

1

-ch 1
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sel ect -r pCube3;

instance; scale -r -1 1 1; group pCube4;
nmove -x -0.5 -spr -rpr;

sel ect -r pCubel;

}
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Maya 5 is an incredibly complex package; a person could work for a long time
with the program and still not have used all of the modules or uncovered
some of the very exciting hidden gems. This section contains information on
often-overlooked work areas.
Body Dynamics
Body dynamics simulate real-world physics on either a rigid or soft form. A rigid
body will not deform upon collision with another body; a soft body will deform.
1 Create a new scene in Maya.
2  Set the animation to 300 frames.
3 Select Dynamics from the Status Line or press the F4 shortcut.
4 Create a polygonal plane of 20 X 20 units with X and Y subdivisions of 1.
5 Createa 1 X 1 X 1 cube with 1 subdivision on each axis.

6  Duplicate the cube three times and position them according to
Figure 10.1.

Xl Persp View

Figure 10.1 Positioning
the cubes.
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9

10

Select all of the cubes and go to go to Soft/Rigid Bodies > Create
Active Rigid Body.

Select the plane and go to Soft/Rigid Bodies > Create Passive Rigid Bodly.
Select the cubes a second time and go to Fields > Gravity.

Press Play.

Body dynamics can be affected by the same fields that affect particle effects.

Active rigid bodies cannot have keyframes on them but passive rigid bodies

can. Using a combination of the two types you can create many different types

of crash simulations.

9

Select the bottom-most cube and shift select the one directly
above it.

Go to Soft/Rigid Bodies > Create Constraint > 0 and choose Pin for
constraint type.

Select the second cube and shift select the one directly above it.

Go to Soft/Rigid Bodies > Create Constraint > 0 and choose Pin for
constraint type.

Select the third cube and shift select the final cube.

Go to Soft/Rigid Bodies > Create Constraint > J and choose Pin for
constraint type.

Select the topmost cube and go to Soft/Rigid Bodies > Create
Constraint > 3.

Choose Nail for constraint type.

Play the animation again.

Constraints are one way to control active bodies. For example, you could create

a wrecking ball with the constraints attached to the crane at one end and the

ball at the other. When the simulation starts the ball will swing smashing any

active bodies it encounters, but it will stay tethered to the crane.
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Expressions

Expressions allow you to control keyable attributes over time. You can use
math, conditions, or MEL commands to drive an expression.

Start a new scene.
Set the animation length to 60 frames.
Create a polygonal torus oriented on the Z axis.

Go to frame 1 and select the torus.

Open the Channel Editor and create a keyframe of 0 for Translate X.

Il Expression Editor

wigibility
tranzlate
translatey’
tranzlates
rokates
rotate’r’

N T
oot

Figure 10.2 The Expression Editor.
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6 Go to frame 60 and enter create a keyframe of 25 for Translate X.

7 Select the torus and go to Window > Animation Editors > Expression
Editor.

8 Select the torus from the Objects list.

9 Click on rotateZ in the Attributes list.

10 The box next to Selected Obj & Attr lists pTorus1.rotateZ. This is the
actual name for the selected attribute. This is what you will need to use
in your expression.

11 In the Expression field type the following.
if (pTorusl.translatexX > 0)
pTorusl.rotateZ = tinme*360 + 1;

12 Click Create.

13 Play the animation. The torus now rolls along during the animation like
a tire rolling on the ground.

14 Change the animation length to 100 frames.

15 Key the TranslateX channel to 45.

16 Play the animation again. The expression automatically updates.

Light Arrays

A light array is a set of light specifically placed to create natural-looking

lighting. The general theory is that many low-level lights create a softer, more

diffuse and thus more realistic rendering than a few brighter ones. Generally,

you want to match the color of the lights to the immediately surrounded area.

Arrays can take many forms, of which this is just one example.

1
2

Create a new scene in Maya.
Place two different-sized spheres on a plane (see Figure 10.3).
Next build a polygonal sphere with six subdivisions along both the

height and axis.
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Figure 10.3 Setting the
scene.

Delete the bottom half of the sphere.

Open the Attribute Editor and expand the Render Stats section.
Uncheck Primary Visibility. This will be your light array cage.
Create a point light.

Open the Attribute Editor.

Set the Intensity to .025.

Snap the point light to one of the vertices on the bottom edge of the
sphere.

Duplicate this sphere five times, snapping each one to a different vertex

along the bottom row.
Create another point light.
Open the Attribute Editor.

Set the Intensity to .125.
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24

Figure 10.4 Light array
with point lights.

Snap the point light to one of the vertices on the second row of vertices
on the sphere.

Duplicate this sphere five times, snapping each one to a different vertex
along the bottom row.

Create a third point light.

Open the Attribute Editor.

Set the Intensity to .250.

Expand the Shadow Maps section.
Set the Resolution to 1024.

Set the Dmap Filter size to 2.

Snap the point light to one of the vertices on the third row of vertices
of the sphere.

Duplicate this sphere five times, snapping each one to a different vertex
along the third row.
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25 Create a fourth point light.

26 Open the Attribute Editor.

27 Set the Intensity to .5.

28 Expand the Shadow Maps section.
29 Set the Resolution to 1024.

30 Set the Dmap Filter size to 2.

31 Snap this light to the topmost point.
32 Render the scene.

A light array is a great way to build lighting for a skydome. It makes creating
soft, natural-looking shadows very easy.

Figure 10.5 Image rendered with a light array.



Resources

http://www.alias.com/eng/index.shtml
The home page for Alias, the makers of Maya 5.0. Tons of great tutorials and

forums available.

http://www.highend3d.com/maya/
Probably the most widely known Maya website aside from Alias’s. This site

contains tons of helpful information.

http://www.learning-maya.com/tutorials.php
Formerly known as boris3d, this is another feature-rich site. This is rich with

tutorials.

http://www.ewertb.com/maya/mel/
Great MEL scripting examples.

http://avalon.viewpoint.com/
Public domain meshes and textures available for download. This is one of the

oldest 3D library sites on the Internet.
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Aim constraints, 184, 186
AirField, 163
Alpha channel, 172
Anatomy, 125
Animation, 105-58
Anistropic material, 61
Anti-aliasing quality, 173
Anticipation, 106
Arcs, 106
Area lighting, 82, 97
Arms, 125-7
Array:
lighting, 219-22
mapper node, 166
Atmospheric settings, 189-90
Attaching surfaces, 63
Attributes:
driven keys, 133
expressions, 218-19
lighting, 80, 86
per-particle, 165
shadows, 88-90
texture, 66-8, 73
Audio, 139
Automatic mapping, 69-70

Backlighting, 84, 97-8, 101-3
Base objects, 133

Bending, 115

Bevel, 25-65

Binoculars tutorial, 39-46
Blend animations, 133-9
Blinn material, 61

Body dynamics, 160, 216-17
Bones, 125-30

Brushes, 192-3, 198-206
Bump maps, 67, 77, 183

By frame, 172

Cages, polygonal, 49, 50
Cameras, 84, 172, 184-91
Cartoon style animations, 183-4
Cast and receive, 178, 181
Caustic effects, 180-2

Channels, 109, 111
Character set, 154-5
Clips, 153-8
Collapse hierarchy, 50
Collision events, 161, 216-17
Color, 26-7

lighting, 94

objects, 66-7

particles, 165-6

shadows, 91-2
Command line, 208
Comments, 211
Concept sketches, 19
Cone angle, 93
Constraints:

active bodies, 217

aim, 184, 186
Convert menu, 14
Converting polygonal objects, 51, 52
Crash simulations, 161, 216-17
Creases, 48, 57

Create:
emitter, 160
menu, 14-15

polygons, 22-4

render node, 63-5, 67, 69, 73,77
Curves, 28, 140

duplicating, 40

editing, 151-2

NURBS modeling, 37-8

paint effects, 203
Customization, 2

Decay regions, 93-4
Deformers, 114-15
Depth, cameras, 189
Depth map:

filter, 90

shadows, 87-8
Directional lighting, 81, 101
Directories, 6-8
Display menu, 15
Dope sheet, 149-51
Dragging particles tutorial, 162-7
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INDEX

Driven keys, 130-3
Dropoff, 94

Duplicating, textures, 62
Dynamics, 159-68, 216-17

Ease in/out, 106
Echo all commands, 210-11
Edit point component mode,
41-2
Editing, 8-10
curves, 38
polygons, 24-7
Effects:
lighting, 96
paint, 198
Emitters, 161
Enter keys, 208
Env sky, 189-90
Expressions, 218-19
Extruding:
curves, 38
faces, 30-6, 52-6

Faces, extruding, 30-6, 52-6
Falling lamp tutorial, 115-24
File:

menu, 8

name prefix, 171
Fill light, 84
Final gather, 180
Fix texture warp, 66
Flat outlines, 28
Flow paths, 146-9
Focal lengths, 187-8
Follow through, 106
Forward kinematics, 125-7
Frame/animation ext, 171

Global illumination effects, 176-9
Goal, 161

Graph editor, 151-2

Groups, 117-21

Guidelines, 42

Hand tutorial, 51-8
Hardware:
render buffer, 174
rendering, 160

226

Heads up display, 15
Hotbox, 3

Hotkeys, 2
Hypershade, 60, 69

Icons, lighting, 82
Image:

format, 171

maps, 62, 72-3

modes, 74

planes, 20, 51, 184
Importing sketches, 20
Incandescence, 124
Indoor lighting tutorial, 93-9
Input connections icon, 74
Instancer, 161
Inverse kinematics, 127-30

Joints, 125-30

Key:
light, 84, 101
transform, 108
Keyframes, 106
Keys sub group, 8-9

Lambert material, 61, 73, 75
Lattices, 112-14
flow paths, 148
Layered shader, 61
Layers, 20-1
clips, 155-8
visibility, 27-8
Layout, MEL scripting, 211-13
Legs, 127-30
Levels, hierarchy, 50
Light:
arrays, 219-22
linker, 98-9, 103
Lighting, 79-99
animation, 116-17
natural, 219-22
Lip-syncing tutorial, 133-9

Make live tool, 13

Manipulators, 11-14
Marking menu, 3-4
Material types, 61-2



INDEX

Maya:
hardware, 174-6
software, 173-4
vector, 183-4
Maya Embedded Language (MEL),
207-13
MEL see Maya Embedded Language
Mental ray, 83, 176-82
Menu bar, 6-16
Meshes, 21
brushes, 202-6
dividing, 46
duplicating, 31
visibility, 33
Mirror geometry, 22-3
Modeling, 17-58
Modify menu, 10-14
Morphing, 133-9
Motion paths, 140-8
Mouse, 2-3
Move tool, 47-9

Naming nodes, 29, 40
Natural lighting, 219-22
Nodes:
creation, 60
shape, 138
Non-linear animation, 153-8
Non-Uniform-Rational B-Spline see NURBS
Normals, 26-7
NTSC time, 107
NURBS:
modeling, 18, 19, 37-46
paint effects, 200-2
texturing objects, 62-8

Objects:
renderable, 172
texturing, 62-70
Organic shapes, 37
Orthogonal views, 19
Outdoor lighting tutorial, 99-103
Outliner, 110-11

Paint effects, 193-4, 197-206
Parent objects, 114, 125-6
Particles, 184

effects, 160-7

rendering, 174
tool, 160
Penumbra, 86, 94
Per particle attributes, 165
Per-point emission rates, 161
Phong material, 61, 63-5
Photons, 178, 180
Pivot points, 117-22, 126-7
Planar mapping, 72-3, 76
Playback controls, 109
Playblasts, 110
Point lighting, 81, 96, 101, 184
Polygons:
combining, 35, 36
mesh brushes, 202
modeling, 18, 21-36
proxy mode, 49, 50-1
Preferences, 16
Primitives, 22
Procedural textures, 62
Project folders, 6-8

Quick select sets, 9
Ramp shader, 61

Raytraced shadows, 88, 91-2, 94-6
Reference editor, 110

Refine selected components, 47, 49, 58

Relationship editor, 98-9, 103

Rendering, 88, 169-95

Resolution, 36, 88, 90
rendering, 171

Resources, 223

RGB channel, 172

Rotation, 109, 117-22

Scale, 151

keys, 9
Scenes, rendering, 170-1
Scripting, 208-13
Scrubbing, 109
Secondary action, 106
Set driven animation, 130-3
Shading:

map, 61

network, 60
Shadows, 83, 87-92
Shapes, blending, 135-8
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Shells, 21
Shelves, 209-10
Shortcuts, 5-6
Smooth proxy, 23-4
Smoothing, 36, 47
Snake tutorial, 27-36, 72-7
Snap to points mode, 34, 41-2
Soft/rigid bodies, 216-17
Sound, 139
Split polygon tool, 29, 31-3, 53
Spot lighting, 81, 93, 97
Sprite wizard, 161
Squash, 114-15
and stretch, 106
Start/end frames, 172
Status line, 5-6
Strokes, 203-6
Subdivision modeling, 19, 46-58
Surfaces:
creating, 39
lofting, 43-5
NURBS modeling, 37
properties, 60
shader, 61
Synchronization, 149-51

Tangents, 152
Targa files, 175
Templates, NURBS, 202
Terrain:

cameras, 188-91

meshes, 100

motion paths, 143-4
Texture:

NURBS, 62-8

polygonal models, 68-70

subdivision models, 68-70
Textures, metal, 193-4
Three point lighting tutorial,

83-92

3D:

animation, 153-8

paint tool, 191-2

particle grid, 162

228

Time:
motion paths, 141
particles, 162, 167
Timing, 106
Title bar, 4
Transformation tools, 10-14
Transparency, 91-2
paint effects, 194-5
Trax editor, 153-8
Tubes, 203-6
Tutorials:
binoculars, 39-46
dragging particles, 162-7
falling lamp, 115-24
hand, 51-8
indoor lighting, 93-9
lip-syncing, 133-9
outdoor lighting, 99-103
snake, 27-36, 72-7
three point lighting, 83-92
Twist values, 146-7
2D texture, 75

Undo, 9
Use background material, 61-2
uv:

coordinates, 69

texture editor, 70-7

V repetitions, 75

Vertex component mode, 51-2, 57-8

Vertices:
dividing, 47, 53
merging, 30, 36, 54-6
Visibility, 122-4
Visor, 199
Volume lighting, 82

Window menu, 16
Wings, 130-3

motion paths, 144-5
World:

coordinate system, 16

space, 34, 35
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